Aplicaciones o programas que interfieren con las actualizaciones de Deepin

Hemos reportado aplicaciones o programas que interfieren con las actualizaciones de Deepin. Cuando instalas desde Deepin Store, o también en Synaptic, deberás tener cuidado ya que suelen necesitar muchas dependencias vinculadas con el sistema. Este genera el problema del «infierno de dependencias», en que buscar un equilibro se hace difícil.

Si actualizas, deberás comprobar si el programa mantendrá a DDE. De no ser así, deberás desinstalar la aplicación conflictiva. Si el programa usa un repositorio complementario, consulta al desarrollador para conocer su estado o prueba una versión appimage.

Motivos que las aplicaciones o programas que interfieren con las actualizaciones de Deepin

De los motivos, señalamos:

  • La aplicación tiene demasiadas dependencias.
  • El programa necesita de una versión Qt incompatible con la de Deepin.
  • Es muy antigua para usarse, debido a sus dependencias obsoletas y no recomendadas por seguridad.
  • Instala programas que no podrían sustituirse con las aplicaciones oficiales de Deepin.

Recomendaciones preventivas

Ejemplos de programas dentro de los repositorios de Deepin

Hemos incluido a las aplicaciones KDE por motivos obvios. Esta lista señala aquellos que están disponibles en los repositorios de Deepin.

AplicaciónDependencias
KDE (Kdenlive, k3b, KDE Connect, Digikam, etc)libkf (varias versiones)
Kodilibasound, libssl, fuente Noto
Dockeriptables
VLCvlc-nox, libvlc
AnkiPython (la última versión no suele estar actualizada)

Lectura adicional

Etiquetas: ,

¿Recomendarías este artículo?