Avisos relacionados a la actualización de paquetes

Al actualizar Deepin, existen avisos relacionados a la actualización de paquetes para adaptarse con versiones posteriores. En esta página te enseñamos que hacer frente a los cambios, sobre todo si lo realizas en la terminal.

Porqué aparecen esos avisos

Al realizar una actualización mayor, se cambian los componentes críticos del sistema como el sistema de apagado, el teclado, el núcleo, entre otros.

Cada paquete de software tiene una configuración (archivo conf). Por ejemplo los archivos del sistemas que lo modificas en el centro de control o las preferencias de una aplicación del sistema. Sin embargo, al actualizar a la última versión, algunos paquetes de software te avisan que hay nuevos cambios o mejoras sustenciales. Por eso, te recomiendan rehacer la configuración para que disfrutes de sus nuevas características o parches del sistema.

Solución

Antes de actualizar, asegúrate de realizar correctamente esos comandos, evitando problemas por falta de dependencias y similares.

sudo apt update
sudo apt-get check
sudo apt full-upgrade

Cuando estás actualizando, aparecerá un aviso en modo texto o mediante botones. Este es un ejemplo de un paquete a mejorar.

Fichero de configuración `/etc/xxxx.d/xxxx.conf'
El proveedor del paquete ofrece una nueva configuración lista para su funcionamiento.
Sin embargo, debido a que la configuración fue alterada, requiere tomar una decisión:
(1) Cambiar la configuración del proveedor
(2) Conservar los cambios de la configuración
(3) Ver los cambios de ambas configuración
(4) Revisar el código fuente de los archivos

Recomendamos realizar la primera opción o similares y pulsar Enter. En algunos casos, las órdenes son representadas en caracteres Y (de yes) o S (de ).

Para diálogos en inglés

Anteriormente mostramos una traducción aproximada. Aquí dejamos una referencia en el idioma original (inglés). Puede resultar útil para consultar a los dearrolladores o en un foro internacional:

A new version of configuration file `/etc/xxxx.d/xxxx.conf' is available, but the version installed currently has been locally modified:
(1) Install the package maintainer's version
(2) Keep the local version currently installed
(3) Show the differences between the versions
(4) Show a side-by-side difference between the versions

Lectura adicional

¿Te pareció útil este artículo?