ACLARACIÓN SOBRE CAMBIOS CON DEEPIN 15.10 ESTABLE (EDITADO)

NOTA ACLARATORIA: Este articulo ha sido modificado de su versión original debido a cambios producidos con la actualización a deepin 15.10.1.

Deepines 3.0 ha sido actualizado a la versión 3.1 debido a cambios introducidos en Deepin 15.10.1, Si ya tenias 2.0 instalado no es necesario removerlo, para actualizar a la ultima versión de Deepines 3.1, solo escribe el siguiente comando en la terminal:

sudo apt update && sudo apt full-upgrade

Actualización 18 de Mayo del 2019 13:15 UTC: En palabras de nuestro querido colaborador Hugo Florentino:

“Los chinos, en su infinita sabiduría milenaria, decidieron que era buena idea nombrar como «estable» también a la versión de Deepin basada en Debian inestable, y de paso ponerle el mismo número de versión.”

Nos han reportado que al actualizar a Deepin 15.10.1 sin hacer ninguna instalación desde cero con la ISO de la versión 15.10, al ejecutar el comando lsb_release -a obtiene en el parámetro Codename: stable. Estamos revisando los datos, de momento adelantamos que el gestor de ventanas y el kernel no han cambiado, por lo que no ha habido un cambio de base inestable a estable real en este momento. También estamos trabajando en el instalador del repositorio Deepines 3.0 para evitar problemas con la base inestable. Si usted no ha instalado desde cero con la ISO de Deepin 15.10 o 15.10.1, le recomendamos no instalar Deepines 3.0 para evitar que su sistema se rompa. Lamentamos la confusiones adicionales que esto está causando y en las próximas horas estaremos actualizando la información.

Actualización 18 de Mayo del 2019 21:01 UTC: Ya revisamos a detalle los cambios aplicados en Deepin inestable al actualizar de 15.10 a 15.10.1. Podemos asegurar que la base sigue siendo Debian 9 SID (inestable), que no se actualizó el kernel y continúa con la versión 4.15.0-29deepin-generic, tampoco cambió el gestor de ventanas, sigue siendo Mutter(DeepinGala), aunque el output de lsb_release -a lo reporte como «estable».



Articulo Original

Construir un sistema informático tiene muchas similitudes a la construcción de edificios. Se construyen por secciones o módulos, se puede dejar espacio para construir algo más en el futuro y, sobre todo, se le debe hacer cambios y mejoras con el tiempo, como una especie de remodelación.

En el caso de las distribuciones de sistemas operativos GNU/Linux, cuando se construye una nueva función o se le hace cambios, se necesita probarlos y asegurarse de que funcionan perfectamente. Estas pruebas requieren tiempo. Entonces los desarrolladores (constructores) tienen versiones del sistema bien probadas pero más viejas, y versiones más nuevas pero aún están en proceso de pruebas y continúan encontrando problemas que se arreglan sobre la marcha.

Las versiones viejas, bien probadas y que funcionan perfectamente se llaman versiones estables y sufren pocos cambios porque funcionan muy bien. Las versiones más nuevas, que aún se están probando y que aún se están arreglando se les llama versiones inestables, porque están sufriendo cambios frecuentemente.

Deepin se basa en otra distribución, Debian, la cual tiene una versión estable y otra inestable. Anterior a Deepin 15.10, Deepin se basaba en Debian inestable, pero esto traía inconvenientes derivados de los constantes cambios y de los fallos aún no detectados.

A partir de Deepin 15.10 y en adelante, Deepin está basado en Debian estable, esto hace que el sistema tenga muchos menos fallos, funcione y se comporte más uniformemente a lo largo del tiempo y no esté cambiando constantemente.

Con una base inestable, los desarrolladores de Deepin debían estar revisando muy frecuentemente los nuevos cambios y adaptando el sistema a los cambios de la base, esto es muy agotador y consume muchos recursos y horas de trabajo.

Con una base estable, los desarrolladores deben revisar menos veces los cambios de la base, lo cual les da  tiempo de desarrollar el sistema con más calma y mayor calidad.

Deepin inestable, Deepin beta estable y Deepin estable

Hubo bastante confusión cuando se empezó a mencionar sobre una versión de Deepin beta estable, pero lo aclararemos a continuación.

Deepin + Debian inestable=Deepin inestable
Deepin + Debian estable=Deepin estable

Ya explicamos los inconvenientes de usar una base inestable y es por eso que los desarrolladores iniciaron la migración de una base inestable a una estable, ellos hicieron un proceso en paralelo que se puede comprender mejor con la siguiente línea de tiempo.

Linea de tiempo de Deepin estable

Deepin en sus inicios usaba como base Ubuntu, pero eso no lo incluimos en la línea de tiempo por ser historia “antigua”. Luego se pasó a usar como base Debian inestable, fue la versión que todos conocimos y usamos en los últimos años, usábamos Deepin inestable, pero como no existía ninguna otra versión, no era necesario diferenciar ni declarar nada más, por eso se le llamaba Deepin a secas.

Cuando se publicó la versión 15.9.2, los desarrolladores tomaron el entorno Deepin y lo montaron sobre Debian estable, naciendo así una nueva versión, Deepin estable, entonces fué necesario declarar Deepin estable y Deepin inestable para poder diferenciarlos.

No fué un cambio pequeño, al contrario, hacer funcionar a Deepin sobre Debian estable requirió de muchos cambios y ajustes, los cuales no habían sido probados, por eso la nueva versión con base estable debía ser declarada además como versión beta, por eso la nombraron Deepin 15.9.2 Beta estable, pues no estaba lista para que el público general la usara.

En paralelo continuó el desarrollo de Deepin inestable y estable, mientras desarrollaban la versión 15.9.3 y 15.10 de la versión inestable, continuaban los preparativos para publicar Deepin 15.10 estable.

Al momento de publicarse Deepin 15.10, su entorno era capaz de funcionar tanto en la base estable como en la inestable, pero las bases son lo suficientemente diferentes como para no permitir cambiar de base inestable a estable mediante un proceso de actualización, por eso es necesario hacer una instalación desde cero para pasar de la base inestable a la estable. En consideración a los usuarios, Deepin desde China continuará brindando actualizaciones hasta julio del 2019, dando chance de programar y hacer las reinstalaciones con calma.

¿Me paso de inmediato a la Deepin estable o espero?

Deepin 15.10 estable aún es un territorio que no está explorado a fondo, los primeros en instalar Deepin 15.10 estable serán una especie de pioneros, y los pioneros siempre encuentran problemas inesperados que tendrán que resolver. En la nueva versión hay cosas que pulir, muchas versiones de software son mas viejas que en la versión inestable, así que algunas aplicaciones instaladas desde fuentes externas podrían tener inconveniente para ser instaladas.

Lo que viene instalado en la distribución y lo que se puede instalar de la tienda funcionan perfectamente, la mayoría de problemas encontrados son detalles de personalización o por instalar aplicaciones que no son parte de la distribución, o sea, que son descargadas manualmente o necesitan repositorios adicionales.

En cuanto a aplicaciones flatpak y snap, funcionan como de costumbre.

En resumen, si pretende instalar en limpio, que todos los detalles funcionen exactamente como lo hacían hasta ahora y no quiere ponerse a resolver prácticamente nada, mejor esperar unas semanas a que otros ya hayan resuelto los detalles, pero si tiene ánimo y tiempo de ser pionero, no hay problema, bienvenido sea.

Nuevamente recordamos que tiene tiempo hasta julio del 2019 para realizar una instalación desde cero con la ISO de Deepin 15.10 estable.

¿Cómo identificar si tengo base estable o inestable?

Hemos publicado un nuevo articulo el cual te muestra como identificar la versión exacta del sistema que tienes por medio de una herramienta creada por nuestro amigo Hugo Florentino, puedes leer el citado articulo aquí.

Repositorio Deepines

El repositorio Deepines también debió adaptarse a la nueva base estable, como resultado se presentó Deepines 3.0, esta versión es compatible sólo con Deepin 15.10 estable y superiores.

Puede encontrar las instrucciónes para instalar Deepines 3.0 en el siguiente enlace – deepinenespañol.org/presentamos-nuestro-repositorio-deepines-3-0.

Lamentablemente el repositorio Deepines para Deepin inestable deja de funcionar, esto porque conservarlo consume los limitados recursos de tiempo y esfuerzo de los voluntarios que lo mantienen, y se decidió enfocar esos recursos en el nuevo repositorio. Esto significa que ya no se puede instalar aplicaciones de Deepines en Deepin inestable, pero lo que tenga instalado seguirá funcionando sin problemas.

Si alguien intenta instalar Deepines 3.0 en Deepin inestable o en cualquier otra distribución diferente a Deepin estable, la instalación fallará. El instalador detecta si está en Deepin 15.10 estable o superior, si no es así, muestra un mensaje de error y no se instala. Esto es por razones de seguridad, para evitar daños al sistema (romper el sistema). A continuación mostramos los mensajes de error para los métodos de instalación más comunes.

Instalación con Deepin Package Manager

Mensaje de error al instalar Deepines 3.0 en Deepin inestable con Deepin Package Manager


Detalle del mensaje de error al instalar Deepines 3.0 en Deepin inestable con Deepin Package Manager


Instalación con GDebi


Mensaje de error al instalar Deepines 3.0 en Deepin inestable con GDebi.



Detalle de error al instalar Deepines 3.0 en Deepin inestable con GDebi.


Instalación con comando DPKG


Mensaje de error al instalar Deepines 3.0 en Deepin inestable con el comando dpkg -i



Detalles del error al instalar Deepines 3.0 en Deepin inestable con el comando dpkg -i



Si usted tiene Deepin inestable le recomendamos desinstalar Deepines 2.0 para evitar inconvenientes. Siga los siguientes pasos:

Ejecute en una terminal el siguiente comando. 

sudo apt purge deepines-repository

Si se solicita su contraseña, escríbala y presione la tecla ENTER. Es normal que al escribir la contraseña no se muestre nada.

Cuando se pregunte si desea continuar presione la tecla ENTER.

Procedimiento Opcional

Un procedimiento opcional para asegurarse de eliminar cualquier rastro de Deepines 2.0 tras una desinstalación habitual es el siguiente:

1- Descargue el siguiente script y guárdelo en Escritorio.

Icon

Desinstalador para Deepines 2.0

INFORMACIÓN SOBRE LA DESCARGA ...

0.48 KB 21 downloads

2- Verifique que el archivo eliminar-deepines-2.0.sh está en Escritorio.

3- Minimice todas las ventanas para poder ver el Escritorio.

4- Haga clic derecho en un lugar vacío del escritorio y luego haga clic en la opción abrir en el terminal.

5- Ejecute el comando

sudo sh eliminar-deepines-2.0.sh

Esperamos este artículo ayude a la comunidad a tener claro el nuevo panorama tras la publicación de Deepin 15.10 estable, porqué es necesario hacer una instalación desde cero y los cambios respecto al repositorio Deppines.

NOTA ACLARATORIA: Estamos investigando nuevos reportes que al parecer cambian alguna de la información contenida en este articulo, por favor mirar mas tarde para posibles aclaraciones y ajustes a la publicación. POR FAVOR MIRAR A TOPE DE ESTE ARTICULO PARA LA ULTIMA INFORMACIÓN DISPONIBLE.

*Agradecimientos especiales a Hugo Florentino, Jose Fenoll y Opik O por su ayuda en la revisión y corrección de este artículo.

19
¿Qué piensas al respecto?

Por favor Ingrese para comentar
11 Hilos de comentarios
8 Respuestas a hilos
0 Seguidores
 
Comentario con mas reacciones
Hilo más comentado
12 Autores de los comentarios
XOdeinorfeoMartinV56Luis Vicente Castillo CorbellaNicolas Smiriglia Autores de los comentarios mas recientes
  Subscribete  
Mas nuevos Mas antiguos Mas populares
Notificar de
Roddivi
Miembro

Qué tal!!. Pues por mí yo uso el sistema de manera muy básica. Mi PC 3s bastante antigua y con otras distritos tengo problemas para mis controladores. Sin embargo con deepin todo marcha a la perfección, apenas ayer instale la actualización y no me falló nada, al menos para la ofimática y usuarios de escritorio… Leer más »

Eli
Editor

Excelente articulo Isaías Gätjens MIsaías Gätjens M, muy bien explicado e informativo para todos, gracias.

Oscar Interliggi
Miembro

Yo lo instalé en mi Vaio FiT 15S, y funciona de maravilla.

Jare GM
Miembro

Uso sistemas basados en GNU/Linux desde el año 2002, y desde 2016, entre otras distribuciones, utilizo deepin basada en Debian. Para mí es una buena noticia la decisión de tomar como base la rama estable de Debian. En este momento la versión estable es la 9.9 (Stretch), pero con Debian 10.0 (Buster) en fase de… Leer más »

Aridany Ypunto
Miembro

Pues yo era de los que tenia problemas con deepin y ya estaba por tirar la toalla y la verdad es que no he vuelto a tener el mismo problema con 15.10, cruzo los dedos porque siempre acababa en reinstalacion hiciese lo que hiciese para recuperar el sistema. Yo lo noto más solido. Hasta ahora… Leer más »

José Luis Berg
Miembro

Hola, yo reinstale el dia de ayer y el único problema que se me presentó fue con virtualbox y sus extensiones ya que no me dejo instalarla desde la aplicación, pero las pude instalar, en otros aspectos aún no encontré problemas. Mi máquina es una Lenovo serie t.
Saludos.

Nicolas Smiriglia
Miembro

Una pregunta. Cuando debían finalmente sea debían 10, deepin actualizará todo el sistema nuevamente desde cero?

Eli
Editor

Hola Nicolas Smiriglia si te refieres a si sera necesario una vez mas re-instalar el sistema de cero debido a un cambio radical de base como sucedió en este caso, la repuesta yo diría es: No, en el caso que creo describes sera una evolución de la base en lugar de un cambio a otra… Leer más »

Nicolas Smiriglia
Miembro

gracias por hacer este articulo tan claro y responder las dudas que tenemos tan rápido

Luis Vicente Castillo Corbella
Miembro

La fregaron al cambiar el manejador de ventanas y no hacer el cambio completo no se pueden redimencionar las ventanas, fijar su ubicación en la pantalla, si cambian a kwin deberían hacerlo bien poniendo los controles completos no se redimencionan con el ratón lo cual es basico.

 

MartinV56
Miembro

Dee vuelta a mis distros favoritas, Arch Linux o Debian 9 chau deepin, no obstante valoro y agradezco a deepin en español sus valiosos aportes, muchas gracias.

orfeo
Miembro

Hola. He instalado la .iso deepin 15.10.1 sobre la versión anterior y de momento todo ha ido bien… Ya tengo la base estable.
Gracias por toda la información.

XOdein
Miembro

No, usted no la tiene, necesitas actualizar de cero para tener estable aunque Deepin le dice que tiene estable, es un bug. De no hacerlo su Deepin dejará de te recibir actualizaciones en unos meses.

orfeo
Miembro

¿A qué llamas actualizar de cero? He instalado de cero la versión 15.10.1 recién descargada, en la misma partición en donde antes tenía la versión 15.09
¿No es eso una actualización desde cero?

Luis Vicente Castillo Corbella
Miembro

Logico mas 0 que eso no hay. Porque el instalador borra la partición antes de instalar o sea 0 absoluto.