CORREGIR EL ERROR DE ACTUALIZACIÓN DE DEEPIN 20 1001

Encabezado

Hola gente, hoy vengo a ayudarles a corregir el error de actualización de Deepin 20 1001. Este problema aqueja a quienes hicieron una instalación en limpio con la ISO «deepin-desktop-community-1001-amd64.iso» publicada el pasado 25 de agosto. También, algunos usuarios, han reportado esta falla en sistemas que actualizaron desde instalaciones hechas con la ISO de Deepin 20 beta, o desde Deepin 15.

El problema se manifiesta al actualizar desde el Centro de control o actualizando desde la terminal como se muestra en las siguientes imágenes.

Mensaje de error al actualizar desde el Centro de control
Mensaje de error al actualizar desde la terminal

En la terminal el mensaje de error se identifica por el siguiente texto.

Err:4 https://community-packages.deepin.com/printer eagle Release
  404  Not Found [IP: 94.130.49.186 443]

El problema está causado porque los desarrolladores cometieron un error y configuraron mal el repositorio de las impresoras, muy útil para poder instalar fácilmente, los controladores de una gran cantidad de impresoras desde el administrador de impresoras de Deepin. Este error ha sido confirmado con el personal de Deepin.

PROCEDIMIENTO

La solución es muy fácil, justo como me gusta, se soluciona copiando y pegando un comando, pero antes vamos a verificar que el problema sea la configuración del repositorio de impresoras. Ejecute el siguiente comando, es una sola línea, debe copiarlo entero.

grep -E "^deb https://community-packages.deepin.com/printer eagle non-free" /etc/apt/sources.list.d/printer.list > /dev/null && echo -e "\nLa configuración debe repararse.\n" || echo -e "\nLa configuración está bien.\n"

Si el resultado es «La configuración debe repararse.» entonces ejecute el siguiente comando.

echo "deb http://packages.chinauos.com/printer eagle non-free" | sudo tee /etc/apt/sources.list.d/printer.list

Si usted desactivó manualmente el repositorio de impresoras, lo puede reactivar con el comando anterior, o si lo prefiere, puede editar la configuración y sustituir el texto por el de la siguiente línea.

deb http://packages.chinauos.com/printer eagle non-free

Lo siguiente es intentar de nuevo, hacer la actualización desde el Centro de control o desde la terminal.

ACLARACIÓN

Normalmente en Deepin en Español nunca recomendamos editar, alterar o modificar la configuración de los repositorios manualmente o con comandos. El método normal para cambiar repositorios espejos es desde el Centro de control de Deepin. Pero como Deepin 20 aún está en desarrollo, no han lanzado la versión final, los espejos aún no existen y el sistema está en constantes cambios y pruebas, se ha hecho necesario estos procedimientos para corregir su funcionamiento. Cuando se publique la versión final de Deepin 20 este procedimiento ya no será necesario.

Si tiene problemas con descargas muy lentas al instalar aplicaciones o al actualizar Deepin 20, le recomendamos usar los espejos de Deepin en Español, puede encontrar el procedimiento aquí.

Esperamos que con esto puedan corregir el error de actualización de Deepin 20 1001, pero aclaramos que esta no es la única causa posible, si este procedimiento no soluciona el problema, por favor cree un nuevo hilo en el foro o solicite ayuda en nuestro grupo en Telegram, ahí alguno de los miembros de la comunidad podrá ayudarle.

4.8 21 votos
Califica el Artículo
 
Subscribete
Notificar de
16 Reacciones
Más populares
Más nuevos Más antiguos
Opinión desde el articulo
Ver todos los comentarios
Jorge Navarro
Jorge Navarro (@jorgenavarro)
24 días atrás

gracias compañero

Эли
Эли (@eli)
Admin
1 mes atrás

Excelente solución al problema, gracias por publicar el arreglo @igatjens estoy seguro que ayudará a muchos.

Luis Linux
Luis Linux (@ddluislinuxfinal)
1 mes atrás

Funciona, gracias!

Jare GM
Jare GM (@jaregm)
1 mes atrás

Gracias por el tip, Isaías.
Corregido el atasco generado por el repositorio para impresoras, y actualizaciones en marcha en una instalación ex novo.
El sistema actualizado desde deepin 15.11 no me mostraba este problema.

Ernesto Junco
Ernesto Junco (@ernesto_junco)
1 mes atrás

A mí me salía un mensaje un poco diferente, decía que el repositorio printer eagle release does not have a release file. pero siguiendo este procedimiento se arregló. adjunto toma. gracias.

deepin error actualizacion
jozef
jozef (@jozef)
1 mes atrás

Bellamente explicado y funciona. Gracias

Justo Moreno
Justo Moreno (@justo-moreno776)
1 mes atrás

Gracias por el todo el trabajo que están realizando, me funciono el tuto.

Rigo Hernandez
Rigo Hernandez (@rigohernandez96)
1 mes atrás

Actualice sin problemas gracias a su tuto, muy bueno y claro.

Mauricio Mandaglio
Mauricio Mandaglio (@mauriciomandaglio)
29 días atrás

Hola a todos, tengo Deepin 20 desde cero, desde el jueves/viernes pasado que me actualizo siento el sistema mucho mas lento… principalmente en todo lo que tiene que ver con conectividad internet… el viernes, después de la actualización del sistema y notando este problema, realice esta corrección y siento que va un poco mejor… Tendrá alguna relación?? igualmente, desde la actualización del sistema no termina de andar bien… una pena…
Agrego.. desde el mismo momento, el ventilador de mi notebook cada tanto levanta al 100% por algunos segundos como nunca lo habia hecho.. se les ocurre por donde puedo arrancar a controlar?

Эли
Эли (@eli)
Admin
Respondiendo a  Mauricio Mandaglio
29 días atrás

 Mauricio Mandaglio le recomendaría usar TOP o la aplicación Monitor del Sistema, para vigilar cuál aplicación o proceso este saliendose de control y causando lo que describe.

cfleidl
cfleidl (@cfleidl)
Respondiendo a  Mauricio Mandaglio
28 días atrás

Si el ventilador del notebook trabaja demasiado y está lento es que hay un proceso consumiendo recursos excesivamente, revíselo con el administrador de tareas.

Mauricio Mandaglio
Mauricio Mandaglio (@mauriciomandaglio)
Respondiendo a  cfleidl
27 días atrás

 cfleidl, Eli, gracias por las respuestas, sinceramente no se que paso, y no tengo tiempo para encontrar el problema… tenia una instalación limpia desde hacia una semana… instale PlayOnLinux, Zenmap, Gimp , ClamAv, algunos de los parches que mencionaban acá y no mucho mas… Quizás el proceso que mas carga presentaba el uno de nombre MainThread que se origina por Firefox, pero el problema de lentitud era general…En conclusión opte por la solución menos ortodoxa y feliz… reinstale Deepin, en esta ocasión con la ultima ISO, ahora todo funciona bien..Gracias.

Dany Lizama
Dany Lizama (@danylizama)
3 días atrás

hola, gente! Ya he revisado todo el foro en busca de una solución. Probé los comandos de más arriba y la terminal acusa que «La configuración está bien.» pero cuando intento actualizar utilizando «apt-get upgrade» detecta «197 actualizados, 0 nuevos se instalarán, 0 para eliminar y 1 no actualizados.
Se necesita descargar 9.887 kB/64,2 MB de archivos.», al darle ok es un error tras otro y finalmente no actualiza. Al intentar lo mismo pero desde el gestor de actualizaciones comienza a trabajar, pero finalmente contesta que la actualización falló…alguna idea? estoy con la versión community…

Ruben PC
Ruben PC (@rubenpc)
8 minutos atrás

Barbaro. Muchas gracias.

16
0
Nos gustaría saber lo que piensas, Únete a la discusión.x
()
x