Notificaciones
Eliminar todas
[ BIENVENIDO  - POR FAVOR LEE LAS REGLAS DE DISCUSIÓN DEL FORO - CLIC AQUÍ - ENCUENTRA O COMPARTE SOLUCIONES ]

RECUERDA, EL FORO NO ES SOLO PARA HACER PREGUNTAS, TAMBIÉN PARA AYUDAR A OTROS SI CONOCES LA SOLUCIÓN

SI EXPERIMENTAS PROBLEMAS DE VISUALIZACIÓN EN EL FORO POR FAVOR LIMPIA EL CACHÉ DE TU NAVEGADOR

Deepines [Resuelto] Error al actualizar


Jona Rodri Alarc
Respuestas: 29
Registrado
Iniciante del hilo
(@jona-rodri-alarc)
Integrante Eminente
Registrado: hace 3 meses

Hola, tengo un problema al actualizar mi sistema, me aparece que la actualización fallo, espero y me puedan ayudar, agradecería un pequeño tutorial, aunque me conformo con una respuesta para solucionarlo.

image

y desde Consola (agradecería que me explicaran y me dijeran como solucionar los demás errores)

image
image

 

[email protected]:~$ sudo apt update
sudo: unable to resolve host LinuxOs: Nombre o servicio desconocido
Obj:1 http://dl.google.com/linux/chrome/deb stable InRelease
Obj:2 http://deb.debian.org/debian buster InRelease
Obj:3 http://security.debian.org/debian-security buster/updates InRelease
Obj:4 http://deb.debian.org/debian buster-updates InRelease
Obj:5 http://deb.debian.org/debian buster-backports InRelease
Obj:6 http://www.deb-multimedia.org buster InRelease
Obj:7 https://brave-browser-apt-release.s3.brave.com stable InRelease
Obj:8 https://download.sublimetext.com apt/stable/ InRelease
Obj:9 http://uos-packages.deepin.com/printer eagle InRelease
Obj:10 http://repository.spotify.com stable InRelease
Ign:11 https://mirror.deepines.com/testing/deeping-20-beta apricot InRelease
Obj:12 https://mirror.deepines.com/testing/appstore eagle InRelease
Err:13 https://mirror.deepines.com/testing/deeping-20-beta apricot Release
404 Not Found [IP: 104.27.187.153 443]
Leyendo lista de paquetes... Hecho
W: El objetivo Packages (main/binary-amd64/Packages) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
W: El objetivo Packages (main/binary-all/Packages) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
W: El objetivo Translations (main/i18n/Translation-es_ES) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
W: El objetivo Translations (main/i18n/Translation-es) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
W: El objetivo Translations (main/i18n/Translation-en) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
N: Omitiendo el uso del fichero configurado «main/binary-i386/Packages» ya que el repositorio http://dl.google.com/linux/chrome/deb stable InRelease» no admite la arquitectura «i386»
E: El repositorio https://mirror.deepines.com/testing/deeping-20-beta apricot Release» no tiene un fichero de Publicación.
N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
W: El objetivo Packages (main/binary-amd64/Packages) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
W: El objetivo Packages (main/binary-all/Packages) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
W: El objetivo Translations (main/i18n/Translation-es_ES) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
W: El objetivo Translations (main/i18n/Translation-es) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1
W: El objetivo Translations (main/i18n/Translation-en) está configurado varias veces en /etc/apt/sources.list.d/google-chrome.list:3 y /etc/apt/sources.list.d/google.list:1

 

soy nuevo en Linux y deepin fue mi primera opción, y hasta ahora no me ha decepcionado

Respuesta
20 Respuestas
1 Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1583

@jona-rodri-alarc Al parecer usted tiene la dirección antigua de nuestro Repositorio Espejo, Por favor visite Esta página para instrucciones sobre cómo configurarlo correctamente.

Adicionalmente parece que el repo a Chrome también tiene algún problena, no estoy seguro, pero ese problena pudiera ser temporario.

Respuesta
Jona Rodri Alarc
Respuestas: 29
Registrado
Iniciante del hilo
(@jona-rodri-alarc)
Integrante Eminente
Registrado: hace 3 meses

Gracias @Эли ya lo he solucionado, lo único que sucede es que no he podido arreglar el problema con google, por lo que he leído google dejo de dar soporte a los sistemas de 32 bits, y al actualizar Google Chrome revisa tanto las de 32 como las de 64 bits, como las de 32 bits fueron eliminadas, aparece un mensaje de error que dice lo siguiente:

image

https://www.linuxadictos.com/google-chrome-para-linux-tiene-un-error-solucionalo-aqui.html     ==== >  No he podido solucionarlo

Desafortunadamente el link no me ha servido, alguna otra idea?

Respuesta
1 Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1583

@jona-rodri-alarc Aunque en el mensaje de error en su toma de pantalla no veo nada relacionado a Chrome, lo que veo es algo raro llamado Linux0s, le pregunto: ¿desde dónde bajo e instalo Chrome? le recomiendo la versión en nuestra tienda, le actualizará sin problemas. Ese error se soluciona por medio de remover el repo de Chrome. Podría hacerlo usando Synaptic.

sudo apt install synaptic

Después abra Synaptic vaya a Configuración arriba, Después Repositorios y entonces busque el repo de Chrome y bórrelo utilizando la aplicación, entonces haga "Aplicar" para salvar los cambios.

Cierre Synaptic y vuelva a tratar de actualizar, el error del repo de Chrome dejará de aparecer.

Al hacer eso sin embargo creo que ya su Chrome no se actualizará más automáticamente, pero de todas maneras en este momento no se le está actualizando tampoco, razón por la cual después de haber hecho los pasos indicados arriba le recomiendo instalar la versión en Tienda Deepines llamado google-chrome-stable

sudo apt purge chrome
sudo apt install google-chrome-stable
sudo apt install google-repository

Saludos.

Respuesta
Car
Respuestas: 718
 Car
Moderador
(@car)
Integrante Honorable
Registrado: hace 3 años

Ya le explicaron que debe actualizar la ruta del espejo deepines por la nueva ya no se usa testing en el . Eso fue para las versiones beta de deepin y la versión 20 que no implementaba espejos la nueva ruta en /etc/apt/sources.list.d/appstore.list debe ser  deb https://mirror.deepines.com/deepin/appstore apricot appstore

Respuesta
Jona Rodri Alarc
Respuestas: 29
Registrado
Iniciante del hilo
(@jona-rodri-alarc)
Integrante Eminente
Registrado: hace 3 meses

Gracias @Эли y @car ya lo he echo y ya he cambiado mis repositorios manualmente y el espejo, eso ha resuelto la mayoría de mis problemas, gracias!

image
image
image

Anexo una captura de como terminaron mis repositorios, gracias por su esmero, soy nuevo usando linux, y aun más usando deepin 20, estoy maravillado con su interfaz y su potencial, corriendo aplicaciones en mi antiguo ordenador, que en windows no los soportaría ni de milagro, deepin le ha dado una nueva vida a mi ordenador, continúen así, son geniales sus aportes.

image

Nota: El cambio de espejos y repositorios permiten poder actualizar deepin y tus aplicaciones desde la configuración (gráfica), sin necesidad de acceder a la terminar, hoy mismo he actualizado de esta forma Wps, Visual Studio Code y Geogebra

Respuesta
15 Respuestas
Jona Rodri Alarc
Registrado
(@jona-rodri-alarc)
Registrado: hace 3 meses

Integrante Eminente
Respuestas: 29

La única duda, es que se supone que deepin 20.1 trae el kernel 5.8 y en mi sistema me sigue marcando que esta en uso el kernel 5.4, habrá algún problema o inconveniente??

¿Como puedo cambiar mi kernel 5.4 a 5.8?

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1583

@jona-rodri-alarc de nada, lo único malo que veo en todas sus tomas es que está usando el sistema como root, ¿por qué hace eso? nadie debe usar eso, es inseguro y cualquier error destrozará su sistema completo. Para eso existe el comando sudo para hacer las labores que requieren root sin estar en root.

Lo que me pregunta sobre el Kernel, se ha respondido a más no poder por acá por el foro, el Kernel por defecto se escoge a la hora de instalación del sistema, otra manera, pero no estoy seguro si está funcional en este momento o no, es a la hora del arranque ir las opciones avanzadas de Grub y escoger el kernel que desea. 

Respuesta
Jona Rodri Alarc
Registrado
(@jona-rodri-alarc)
Registrado: hace 3 meses

Integrante Eminente
Respuestas: 29

@eli gracias, soy nuevo por acá y lo intentare, lo que pasa es que instale deepin en septiembre con el aun kernel 5.4 (la única opción para ese entonces), y todos estos errores no encontré forma alguna de solucionarlos, así que los ignores, hasta hoy, que de casualidad encontré este foro y me han ayudado a solucionar los errores, gracias, intentare cambiar mi kernel al 5.8 desde el arranque, gracias por su ayuda

Respuesta
Hidel
Registrado
(@hidel)
Registrado: hace 5 meses

Nuevo(a) Integrante
Respuestas: 3

@jona-rodri-alarc a mi me susedio que cuando actualice ,reinicie y cuando llego al usuario ,pongo la contraseña y cuando empiesa a abrir el escritorio me bota acia atras y me pide usuario y contraceña nuevamente,como si ubiese tenido algun error en la actualización

Respuesta
Jona Rodri Alarc
Registrado
(@jona-rodri-alarc)
Registrado: hace 3 meses

Integrante Eminente
Respuestas: 29

@hidel No se que estabas intentando resolver, para solucionar el error en las actualizaciones solo cambie los repositorios manualmente, te recomiendo, por cualquier cosas abres el archivo source.list y en un documento copies y pegues tus repositorios actuales.

1.- Abre el archivo sources.list (Yo use nano: nano /etc/apt/sources.list)

2.- Borra las repos (repositorios) que ahí te aparecen

3.- Pegas las nuevas repos ahí:

## Generated by deepin-installer
deb [by-hash=force]  https://mirror.deepines.com/deepin/  apricot main contrib non-free
deb  https://mirror.deepines.com/testing/appstore  apricot appstore
# Repositorio base estable.
deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free

# Repositorio de actualizaciones de seguridad
deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# Repositorio multimedia
deb http://www.deb-multimedia.org buster main non-free

4.- Guarda los cambios con ctrl+o y cierra nano con ctrl+x

5.- Actualiza: sudo apt-get update 

6.- Instala: sudo apt-get upgrade (Comenzara a instalar un montón de cosas)

7.- Si te marca errores al actualizar o al instalar intenta: sudo apt update && sudo apt full-upgrade eso actualiza hasta windows 10 jajaja ?

https://xn--deepinenespaol-1nb.org/mejore-la-velocidad-del-repositorio-de-deepin-20-beta/ ==> Todo se encuentra en el post, si no te funcionan los comandos (como en  mi caso) tendrás que hacerlo manualmente

Respuesta
Jona Rodri Alarc
Registrado
(@jona-rodri-alarc)
Registrado: hace 3 meses

Integrante Eminente
Respuestas: 29

Si te refieres al error de google chrome solo solo edita el repositorio:

1. En la terminar: nano /ext/apt/sources.list.d/google-chrome-ls o terminaba en /google-chrome.list  Una de las 2

2.- agrega al Repositorio:

deb [arch=amd64] -->Deja el resto del repositorio (Esto hará que solo busque los archivos de 64 bits, ya que google dejo de dar soporte a chrome, (no a chromium) a las arquitecturas de 32 bits

-->Si tu problema no es ninguno de los 2: ve el siguiente post: ahí la causa del problema es la repo de la impresora

https://xn--deepinenespaol-1nb.org/corregir-el-error-de-actualizacion-de-deepin-20-1001/  

Respuesta
Jona Rodri Alarc
Registrado
(@jona-rodri-alarc)
Registrado: hace 3 meses

Integrante Eminente
Respuestas: 29

@hidel Si ya has cambiado tus repositorios correctamente te recomiendo el siguiente post:

https://xn--deepinenespaol-1nb.org/que-hacer-despues-de-instalar-deepin-20-guia-basica/   ==>Realiza todos y cada una de los pasos al pie de la letra para mejorar al máximo tu experiencia, de verdad, te ayudara muchísimo, al menos a mi me sirvió en gran manera, una vez corrijas el error de tus repositorios todo sera mas fácil

NOTA: Primero cambia tu espejo, después corrige el bug de la actualización y ya puedes continuar normalmente con lo demás

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1583

@jona-rodri-alarc lamento decirle que tiene un desastre en sus repos. Usted NO DEBE tener repositorios de Debian en Deepin, Deepin no es Debian y es un milagro que su sistema esté aún funcionado.

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1583

@hidel hola,

Al parecer tienes un error serio en tu sistema, la verdad cuando llega a ese punto es mejor re-instalar. Aunque lo hizo con la mejor fe, los pasos sugeridos por @jona-rodri-alarc no son correctos, así es que no le aconsejo seguirlos. De todas formas por lo que describe, usted ni siquiera puede entrar al escritorio.

Haga un respaldo de sus datos y re-instale Deepin, es lo mejor a ese punto.

Respuesta
Jona Rodri Alarc
Registrado
(@jona-rodri-alarc)
Registrado: hace 3 meses

Integrante Eminente
Respuestas: 29

@eli osea que de mi contratación laboral ya ni hablamos ????.

@eli es un milagro que mi pc no haya explotado un día de estos ????.

Entonces, en mis repos que es lo que debo de tener???

## Generated by deepin-installer    ====>     ¿Solo ésto?

deb [by-hash=force] https://mirror.deepines.com/deepin/ apricot main contrib non-free

deb https://mirror.deepines.com/testing/appstore apricot appstore

 

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1583

@jona-rodri-alarc lea la otra repuesta que le di por acá.

Respuesta
Jona Rodri Alarc
Registrado
(@jona-rodri-alarc)
Registrado: hace 3 meses

Integrante Eminente
Respuestas: 29

@eli Hola de Nuevo, al parecer el desastre con las repos me está cobrando factura, o bueno, me he causado otro error con las actualizaciones (Nota: Ya no he tocado las repos, ni archivos del sistema, solo he trabajado, agregado una impresora e instalado las actualizaciones del sistema desde el entorno grafico)

Mis Repos:

cat /etc/apt/sources.list
## Generated by deepin-installer
#deb [by-hash=force] https://community-packages.deepin.com/deepin/ apricot main contrib non-free
deb [by-hash=force] https://mirror.deepines.com/deepin/ apricot main contrib non-free
#deb-src https://community-packages.deepin.com/deepin/ apricot main contrib non-free

cat /etc/apt/sources.list.d/appstore.list
#deb https://community-store-packages.deepin.com/appstore eagle appstore
deb https://mirror.deepines.com/appstore apricot appstore

El Error:

sudo apt update
sudo: unable to resolve host LinuxOs: Nombre o servicio desconocido
Obj:2 http://packages.microsoft.com/repos/edge stable InRelease
Obj:3 https://download.sublimetext.com apt/stable/ InRelease
Obj:4 https://mirror.deepines.com/deepin apricot InRelease
Obj:5 http://repository.spotify.com stable InRelease
Obj:6 http://dl.google.com/linux/chrome/deb stable InRelease
Obj:1 https://repositorio.deepines.com/pub/deepines/4 stable InRelease
Ign:8 https://mirror.deepines.com/appstore apricot InRelease
Err:9 https://mirror.deepines.com/appstore apricot Release
404 Not Found [IP: 172.67.149.13 443]
Obj:7 http://uos-packages.deepin.com/printer eagle InRelease
Obj:10 https://brave-browser-apt-release.s3.brave.com stable InRelease
Leyendo lista de paquetes... Hecho
E: El repositorio https://mirror.deepines.com/appstore apricot Release» no tiene un fichero de Publicación.
N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.

(Al actualizar manualmente desde la terminal siempre sin exepcion me da ese error, pero al abrir mi centro de control me aparece todo normal)

image

Al darle click en "Buscar actualizaciones" cambia y me devuelve el error, y permanece así hasta cerrar el centro de control y volverlo a abrir.

image
Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1583

@jona-rodri-alarc desafortunadamente su sistema tiene algún error que desconozco. Está llamando repos que según el contenido que usted mostró ni siquiera están en su sources.list por ejemplo.

Quizás sería mejor para usted guardar todos sus datos y re-instalar. En el futuro tenga mucho cuidado qué repos o aplicaciones instala en su sistema. Por ejemplo asegúrese que son %100 compatibles con Deepin.

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1583

@jona-rodri-alarc también, al menos uno de esos errores es causado debido a que recién hemos tenido que cambiar nuevamente la URL del repo espejo de la tienda de Deepin el cual usted usa, por favor cambie el repo de la tienda a:

deb  https://mirror.deepines.com/appstore  eagle appstore

Suerte.

Respuesta
Jona Rodri Alarc
Registrado
(@jona-rodri-alarc)
Registrado: hace 3 meses

Integrante Eminente
Respuestas: 29

@eli Muchas Gracias, se ha solucionado el error, aunque si, yo creo que reinstalare todo el sistema, ya que si he notado algunos errores o bugs provocadas por las repos, solo una pregunta:

Nota:(Comparto windows y deepin en el mismo disco), primero formateo la particion en el disco, y luego elimino el dual boot, o elimino el dual boot y posteriormente formateo la particion del disco con deepin, o acaso es que se elimina el dual boot al formatear la particion?

Estoy ancioso de reinstalar todo mi sistema pero no estoy seguro de como hacerlo y no quiero dañar mi inicio. (Ya vi la guia de instalacion, ya tengo el iso y la memoria booteada, ya se lo que se tiene que hacer a grandes rasgos, pero mi duda es puntual, como elimino la version que dañe de deepin?)

Respuesta
Comparte: