OBS SE CIERRA A LA HORA DE INTENTAR TRANSMITIR  

  RSS
gtabimael
(@gtabimael)
Nuevo Miembro Registered

Hola, tengo una computadora dell con una tarjeta gráfica GeForce 920M de nvidia. Soy nuevo en Linux, yo hago transmisiones en facebook y utilizo OBS pero DeepinOS me esta dando problemas a la hora de transmitir, cuando hago clic en el botón para transmitir, se cierra. Cuando intentaba grabar me pasaba algo similar pero en configuraciones avanzadas en tipo de salida selecciona FFmpeg y ya puedo grabar sin problemas.

Adjunto logs:

14:31:47.443: CPU Name: Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz
14:31:47.443: CPU Speed: 1348.627MHz
14:31:47.443: Physical Cores: 2, Logical Cores: 4
14:31:47.443: Physical Memory: 3854MB Total, 495MB Free
14:31:47.443: Kernel Version: Linux 4.15.0-29deepin-generic
14:31:47.443: Distribution: "Deepin" "15.9"
14:31:47.445: Portable mode: false
14:31:47.511: OBS 0.0.1 (linux)
14:31:47.511: ---------------------------------
14:31:47.535: ---------------------------------
14:31:47.535: audio settings reset:
14:31:47.535: samples per sec: 44100
14:31:47.535: speakers: 2
14:31:47.550: ---------------------------------
14:31:47.550: Initializing OpenGL...
14:31:47.585: OpenGL version: 4.5 (Core Profile) Mesa 18.0.4
14:31:47.661: ---------------------------------
14:31:47.661: video settings reset:
14:31:47.661: base resolution: 1366x768
14:31:47.661: output resolution: 1092x614
14:31:47.661: downscale filter: Bicubic
14:31:47.661: fps: 30/1
14:31:47.661: format: NV12
14:31:47.675: Audio monitoring device:
14:31:47.675: name: Por defecto
14:31:47.675: id: default
14:31:47.675: ---------------------------------
14:31:47.694: No blackmagic support
14:31:47.754: os_dlopen(libnvidia-encode.so.1->libnvidia-encode.so.1): libnvidia-encode.so.1: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
14:31:47.754:
14:31:47.773: VLC found, VLC video source enabled
14:31:47.773: ---------------------------------
14:31:47.773: Loaded Modules:
14:31:47.773: vlc-video.so
14:31:47.773: text-freetype2.so
14:31:47.773: rtmp-services.so
14:31:47.773: obs-x264.so
14:31:47.773: obs-transitions.so
14:31:47.773: obs-outputs.so
14:31:47.773: obs-filters.so
14:31:47.773: obs-ffmpeg.so
14:31:47.773: linux-v4l2.so
14:31:47.773: linux-pulseaudio.so
14:31:47.773: linux-jack.so
14:31:47.773: linux-decklink.so
14:31:47.773: linux-capture.so
14:31:47.773: linux-alsa.so
14:31:47.773: image-source.so
14:31:47.773: frontend-tools.so
14:31:47.773: ---------------------------------
14:31:47.773: ==== Startup complete ===============================================
14:31:47.774: Service '' not found
14:31:47.787: All scene data cleared
14:31:47.789: ------------------------------------------------
14:31:47.800: pulse-input: Server name: 'pulseaudio 10.0'
14:31:47.800: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
14:31:47.800: pulse-input: Started recording from 'alsa_output.pci-0000_00_1b.0.analog-stereo.monitor'
14:31:47.802: pulse-input: Server name: 'pulseaudio 10.0'
14:31:47.802: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
14:31:47.802: pulse-input: Started recording from 'alsa_input.pci-0000_00_1b.0.analog-stereo'
14:31:47.804: xshm-input: Geometry 1366x768 @ 0,0
14:31:47.812: Switched to scene 'Escena'
14:31:47.813: ------------------------------------------------
14:31:47.813: Loaded scenes:
14:31:47.813: - scene 'Escena':
14:31:47.813: - source: 'Captura de pantalla (XSHM)' (xshm_input)
14:31:47.813: ------------------------------------------------
14:31:48.309: adding 46 milliseconds of audio buffering, total audio buffering is now 46 milliseconds

Citar
Publicado el : 12 febrero, 2019 6:49 pm
Eli
 Eli
(@eli)
Miembro Moderator

Qué versión de OBS estás usando @gtabimael? Trata la de la tienda de no ser esa la que usas, o si lo es entonces pudieras intentar con la versión .deb del sitio oficial, también pudieras investigar si está disponible en otro tipo de empaquetado como .flatpak .snap etc tambien puedes tratar instalando una versión más vieja de la app a ver si te funciona bien. Aveces lo último no es siempre lo mejor.

Eli @ https://www.iconnetworks.net
M51AD-US001S Desktop System Designed by Asus®
Intel® Core™ i7-4770 Processor at 3.4 GHz
Samsung UD590 Series, 28' 4K LED Monitor
EVGA GeForce GTX 960, 2GB GDDR5 GPU
8-Channel (7.1) HD Audio by Realtek
Samsung 850Pro 512GB SSD
16GB DDR3 SDRAM
Deepin 15.8 [x64]

ResponderCitar
Publicado el : 14 febrero, 2019 7:02 pm
Claudio Pier
(@claudiopier)
Nuevo Miembro Registered

hola ami me pasa lo mismo que puede ser?

ResponderCitar
Publicado el : 16 febrero, 2019 10:26 am
Federico Raika
(@federico-raika)
Nuevo Miembro Registered

creo que debe ser problema de codec faltante por ejemplo OBS necesita ffmpeg . 

sudo apt install ffmpeg 
ResponderCitar
Publicado el : 11 marzo, 2019 5:49 am
Comparte:
  
Trabajando

Por favor Iniciar Sesión o Registro