[Resuelto] No se instala mysql-community en deepin15.11  


Eduardo Orozco
Respuestas: 5
Registrado
(@eduardoorozco)
Integrante Activo
Registrado: hace 2 semanas

Tengo serios inconvenientes con la instalacion de mysql ( 5.7, 8.0) de la comunidad pues faltan librerias o apps referidas al tema y no logro poner en marcha la base de datos en mi compu.

Agradezco cualquier ayuda o guia.

Saludos a todos.

Responder
7 Respuestas
6 Respuestas
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 9 meses

Integrante Confiable
Respuestas: 73

@eduardoorozco

Hola, ¿cuál es su distribución y versión? ¿Cómo intentó instalar mysql? ¿Cuál fue el mensaje de error? Por favor suministre datos exactos.

Saludos.

Responder
Eduardo Orozco
Registrado
(@eduardoorozco)
Registrado: hace 2 semanas

Integrante Activo
Respuestas: 5

@igatjens

En la etiqueta puse deepin15.11 que se supone es una distro basada en el último Debian estable por eso descargue los archivos correspondientes desde https://dev.mysql.com/downloads/mysql.

Paso a detallar lo realizado:

1- instalé o al menos ese fue el propósito (repasando un video tutorial)

    sudo dpkg -i mysql-apt-config_0.8.13-1_all.deb

    sudo apt update

2- sudo apt install mysql-server

    esto produce el error que falta mysql-community-server

3- sudo dpkg -i mysql-community-server_8.0.17-1debian10_amd64.deb

    esto produce el error que falta mysql-common mysql-client pero igual ejecuto

    sudo apt update

4- sudo apt install mysql-server

    error paquetes rotos entonces

    sudo apt --fix-broken install

5- sudo apt install mysql-server

    faltan clases y librerias que no anoté porque estaba reloco

    intento con otro instalador

6- sudo dpkg -i mysql-community-server_5.7.27-1debian10_amd64.deb

    error faltan mysql-common mysql-client

7- sudo apt install mysql-common mysql-client

    paquetes rotos entonces

    sudo apt --fix-broken install

    y ahí paré.

NOTA 1: en el mismo equipo ya he tenido mysql instalado y funcionando bajo deepin15.10 pero se daño una partición del disco y tuve que formatear. Al ver que existía deepin15.11 lo instalé pero mysql me está dando dolores de cabeza.

NOTA 2: por ahora el problema lo he solucionado en parte, ya que instalé MariaDB 10.1.37, aunque tengo inconvenientes con la sintaxis de la base y algunas otras cosas que difieren de mysql. Tampoco sé si los proyectos que tengo hechos bajo mysql van a funcionar en MariaDB por las evoluciones de uno y otro.

Gracias.

Responder
Car
 Car
Moderador
(@car)
Registrado: hace 2 años

Integrante de Alta Reputacion
Respuestas: 430

@eduardoorozco desde el link que envíaste te bajas el paquete mysql-server_8.0.17-1debian9_amd64.deb-bundle.tar  Lo descomprimes entras en la carpeta y en ella abres un terminal y... sudo dpkg i *.deb al terminar ejecutar sudo apt install -f  Esto Instala perfectamente en deepin 15.11 stable

Responder
Eduardo Orozco
Registrado
(@eduardoorozco)
Registrado: hace 2 semanas

Integrante Activo
Respuestas: 5

@car

perfecto @car, ahí estaba el problema, bajé el paquete incorrecto.

Desintalé Mariadb pues había conflictos a la hora de instalar mysql y además tuve problemas con la libreria libmecab pero ya está todo funcionando bien.

Abrazo enorme y sigan aportando a ésta nueva distro para que crezca la comunidad Deepin. 😀 

Responder
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 9 meses

Integrante Confiable
Respuestas: 73

@eduardoorozco

Además de lo que ya mencionó @car, y viendo que intentó instalar el paquete mysql-community-server_5.7.27-1debian10_amd64.deb, aclaro que Deepin está basado en Debian 9 estable (stretch), Deepin 15.11 aún no ha actualizado la base a Debian 10 (buster), así que creo que esa es la causa del problema. Y sí pasé por alto que ya habías especificado en el título que se trataba de Deepin 15.11.

Saludos.

Responder
Eduardo Orozco
Registrado
(@eduardoorozco)
Registrado: hace 2 semanas

Integrante Activo
Respuestas: 5

@igatjens

Así es Isaías, fue erróneo considerar Debian10.

El problema que no sabía como detectar la distro stable en la cual está basado, supuse ésa.

Aclaro que lo busque dentro de los news en deepinespañol.org y no lo encontré.

De todos modos muchas gracias por responder tan pronto y que el inconveniente se solucionó.

Abrazo enorme. Idem @car.

Responder
Eduardo Orozco
Respuestas: 5
Registrado
(@eduardoorozco)
Integrante Activo
Registrado: hace 2 semanas

Gracias a los que aportaron a la solución.

Trataré de colaborar con quien lo necesite aportando mis escasos conocimientos.

Saludos.

Responder
Comparte:
  
Trabajando

Por favor Iniciar Sesión o Registro