Bloqueo/Freeze al e...
 
Notificaciones
Eliminar todas

[ BIENVENIDO  - POR FAVOR LEE LAS REGLAS DE DISCUSIÓN DEL FORO - CLIC AQUÍ - ENCUENTRA O COMPARTE SOLUCIONES ]

RECUERDA, EL FORO NO ES SOLO PARA HACER PREGUNTAS, TAMBIÉN PARA AYUDAR A OTROS SI CONOCES LA SOLUCIÓN

SI EXPERIMENTAS PROBLEMAS DE VISUALIZACIÓN EN EL FORO POR FAVOR LIMPIA EL CACHÉ DE TU NAVEGADOR

Sistema Bloqueo/Freeze al entrar en Suspensión


titobundy
Respuestas: 13
Registrado
Iniciante del hilo
(@titobundy)
Integrante Activo
Registrado: hace 3 años

Buenas a todos,

Hace poco cambié de equipo a un HP Pavilion 15-eh0011la con procesador Ryzen 7, instalé la última versión de Deepin 20.2.3, y me está sucediendo de que al cerrar la tapa del equipo y entrar en modo de suspensión, y volver en unos 30 minutos el sistema esta bloqueado con la pantalla negra (si es en un par de minutos esto no sucede), o bien aparecen las ventanas pero el sistema esta freezeado, solo se mueve el mouse pero no reacciona a nada y tengo que forzar el apagado y volver a encender.

Intenté cambiar a Hibernación al cerrar la tapa pero no fue mejor.

¿Saben a que se pueda deber, quizas el hardware ? El disco es un SSD M.2 NVMe

En el equipo anterior que tenia mas viejito esto no sucedía.

 

deepin

Más detalles del equipo acá:

https://www.hp.com/cl-es/shop/notebook-hp-pavilion-laptop-15-eh0011la-310h1la.html

 

 

 

Respuesta
Etiquetas del Hilo
4 Respuestas
1 Respuesta
Isaías Gätjens M
(@igatjens)
Registrado: hace 3 años

Integrante Prominente
Respuestas: 814

@titobundy se me ocurre que tal vez sea un problema de ACPI (el protocolo de administración de energía), es común que los fabricantes de laptops se salgan de los estándares de ACPI, se aseguran mediante drivers que funcione correctamente en Windows y no le prestan atención al kernel Linux.

Con el tiempo los desarrolladores integran soluciones al kernel para solucionar estos problemas con el hardware más reciente.

Pruebe cambiando la configuración de acpi en el grub a ver qué pasa, siga los siguientes pasos:

Respaldar la configuración del grub

sudo cp /etc/default/grub /etc/default/grub_backup_$(date +%Y-%m-%d_%H.%M.%S)

Editar grub Deepin Editor

sudo deepin-editor /etc/default/grub

Modificar la línea que dice

GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

para que quede así:

GRUB_CMLINE_LINUX_DEFAULT="quiet splash acpi=off noacpi nolapic"

Esto para cambiar la configuración de ACPI.

Luego actualizar grub con el comando,

sudo update-grub

Reiniciar la computadora y probar si el problema continúa.

 

Otra procedimiento que puede intentar es lo que dice en este artículo - https://www.linuxito.com/gnu-linux/nivel-medio/273-linux-no-se-apaga .

No tengo experiencia con este tipo de problemas, entonces no puedo asegurarle que le vaya a funcionar, pero también puede buscar más información sobre ACPI o problemas relacionados en Google.

También pruebe subir y bajar el brillo de la pantalla, a veces eso hace despertar la pantalla.

Saludos.

Respuesta
titobundy
Respuestas: 13
Registrado
Iniciante del hilo
(@titobundy)
Integrante Activo
Registrado: hace 3 años

Gracias por tu respuesta, consulta, antes de aplicar el cambio y probar, ¿Que efectos puede tener aplicar estos cambios ? He leído que puede acortar la vida útil,

Por otra parte, en github de linux deepin, me indicaron que actualice el kernel a linux-image-5.13.13-amd64-desktop, pero la verdad no se que consecuencias me puede traer, yo tengo windows y linux para arrancar, y en una ocasión una actualización del kernel que me recomendaron cuando usaba deepin 15, terminó en desastre ya que tuve que volver a instalar ambos SO, ya que no lograba arrancar nada y no supe como resolverlo.

Respuesta
titobundy
Respuestas: 13
Registrado
Iniciante del hilo
(@titobundy)
Integrante Activo
Registrado: hace 3 años

Probé las 2 soluciones, la de de cambiar:

GRUB_CMLINE_LINUX_DEFAULT="splash quiet acpi=off noapic nolapic"

y no funcinó

actualicé el kernel a la versión 5.13.13 como me habían indicado y tampoco, apenas se cierra la tapa y luego la abro, aparecen las ventanas pero todo esta bloqueado, los botones de brillo no logran nada, lo que me obliga a reiniciar forzado con el botón de apagado.

Este es el mensaje de error que aparece al inicio

[ 0.266559] ACPI BIOS Error (bug): Failure creating named object [\SMIB], AE_ALREADY_EXISTS (20210331/dsfield-639)
[ 0.845023] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.P000 (20210331/dspkginit-440)
[ 0.845088] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.P001 (20210331/dspkginit-440)
[ 0.845144] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.P002 (20210331/dspkginit-440)
[ 0.845200] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.P003 (20210331/dspkginit-440)
[ 0.845255] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.P004 (20210331/dspkginit-440)
[ 0.845310] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.P005 (20210331/dspkginit-440)
[ 0.845364] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.P006 (20210331/dspkginit-440)
[ 0.845419] ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - \_PR_.P007 (20210331/dspkginit-440)
acpi error min

 

Respuesta
titobundy
Respuestas: 13
Registrado
Iniciante del hilo
(@titobundy)
Integrante Activo
Registrado: hace 3 años

Agrego otro antecedente

 

$ cat /sys/power/mem_sleep
[s2idle]

Saqué la info desde acá:

https://nns.ee/blog/2020/10/18/acpi-patching.html

pero no sé como aplicar una solución.

 

Captura de pantalla deepin graphics driver manager 20211008170413

 

 

Respuesta
Comparte: