Error de dependenci...
 
Notificaciones
Eliminar todas

[ BIENVENIDO  - POR FAVOR LEE LAS REGLAS DE DISCUSIÓN DEL FORO - CLIC AQUÍ - ENCUENTRA O COMPARTE SOLUCIONES ]

RECUERDA, EL FORO NO ES SOLO PARA HACER PREGUNTAS, TAMBIÉN PARA AYUDAR A OTROS SI CONOCES LA SOLUCIÓN

SI EXPERIMENTAS PROBLEMAS DE VISUALIZACIÓN EN EL FORO POR FAVOR LIMPIA EL CACHÉ DE TU NAVEGADOR

Errores [Resuelto] Error de dependencias al actualizar Deepin


Antonio Luis Lallena Passas
Respuestas: 16
Registrado
Iniciante del hilo
(@antonioluislallenapassas)
Integrante Activo
Registrado: hace 3 años

Buenas tardes

Desde hace algún tiempo, cuando intento actualizar el sistema desde el centro de control, aparece el mensaje "Error de dependencias, no se encontraron actualizaciones". No sé si es normal o debo solucionar el tema de las dependencias.

Tengo la versión 20.1 de Deepin, edición Community (1030)  

Muchas gracias por vuestra ayuda.

Respuesta
11 Respuestas
10 Respuestas
profiler 2.0
Registrado
(@profiler-2-0)
Registrado: hace 4 meses

Integrante Estimado
Respuestas: 121

@antonioluislallenapassas

Hola buenos dias, prueba con esta guìa aqui

buena suerte, saludos!!!

Respuesta
Antonio Luis Lallena Passas
(@antonioluislallenapassas)
Registrado: hace 3 años

Integrante Activo
Respuestas: 16

@profiler-2-0 Hola

Muchas gracias por tu ayuda.

Al hacer

sudo apt-get check

apareció el mensaje:

E: Dependencias incumplidas. Intente «apt --fix-broken install» sin paquetes (o especifique una solución).

Al escribir 

apt --fix-broken install

apareció

Desempaquetando gimp-data (2.10.8-2) ...
dpkg: error al procesar el archivo /var/cache/apt/archives/gimp-data_2.10.8-2_all.deb (--unpack):
intentando sobreescribir `/usr/share/icons/hicolor/16x16/apps/gimp.png', que está también en el paquete gimp 2.10.23-220+1deepines
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Tubería rota)
dpkg-query: el paquete `gimp-data' no está instalado.

Y al escribir

sudo apt-get -f install

el mensaje que sale es 

Desempaquetando gimp-data (2.10.8-2) ...
dpkg: error al procesar el archivo /var/cache/apt/archives/gimp-data_2.10.8-2_all.deb (--unpack):
intentando sobreescribir `/usr/share/icons/hicolor/16x16/apps/gimp.png', que está también en el paquete gimp 2.10.23-220+1deepines
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Tubería rota)
dpkg-query: el paquete `gimp-data' no está instalado.
Use dpkg --contents (= dpkg-deb --contents) to list archive files contents.
Se encontraron errores al procesar:
/var/cache/apt/archives/gimp-data_2.10.8-2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

He intentado desintalar Gimp desde el lanzador pero aparece el mensaje:

La eliminación de la aplicación falló

Por si sirve de algo, instalé Gimp desde la Tienda Deepines

Muchas gracias

Respuesta
profiler 2.0
Registrado
(@profiler-2-0)
Registrado: hace 4 meses

Integrante Estimado
Respuestas: 121

@antonioluislallenapassas  buenos dias,

intenta mostrar el paquete de gimp instalado:

en la lista debe aparecer  "ii"gimp

dpkg -l

de cualquier manera si no aparece, y si no lo has hecho aùn intenta con:

sudo apt-get purge remove gimp--
sudo apt get purge remove gimp

ojala haya suerte, saludos!!

 

Respuesta
Antonio Luis Lallena Passas
(@antonioluislallenapassas)
Registrado: hace 3 años

Integrante Activo
Respuestas: 16

@profiler-2-0

Hola

Captura de pantalla área de selección 20210325175356
image

No ha habido éxito

Respuesta
Brandon Guerra
Registrado
(@devilment)
Registrado: hace 5 meses

Integrante Eminente
Respuestas: 26

@antonioluislallenapassas Tiene un error al intentar sobreescribir un archivo que ya tiene, podrías intentar forzando sobreescritura

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gimp-data_2.10.8-2_all.deb
Respuesta
Antonio Luis Lallena Passas
(@antonioluislallenapassas)
Registrado: hace 3 años

Integrante Activo
Respuestas: 16

@devilment

Muchas gracias. Ha funcionado y he podido desinstalar Gimp.

Ya vuelven a funcionar las actualzaciones al no haber problema de dependencias.

Respuesta
Brandon Guerra
Registrado
(@devilment)
Registrado: hace 5 meses

Integrante Eminente
Respuestas: 26
profiler 2.0
Registrado
(@profiler-2-0)
Registrado: hace 4 meses

Integrante Estimado
Respuestas: 121

@devilment excelente Brandon, gracias!!! ?

Respuesta
Eli
 Eli
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1740

@antonioluislallenapassas hola,

Por lo que cuenta parece que está en la última versión. ¿Podría mostrar una toma de cuando le sale el mensaje respecto a dependencias? ¿Podría por favor mostrar el resultado o una toma de pantalla (legible por favor) del siguiente comando?

cat /etc/apt/sources.list

Saludos

Respuesta
Antonio Luis Lallena Passas
(@antonioluislallenapassas)
Registrado: hace 3 años

Integrante Activo
Respuestas: 16

@eli

Muchas gracias por ayudarme.

image
image

[email protected]:~$ cat /etc/apt/sources.list
## Generated by deepin-installer
deb [by-hash=force] https://community-packages.deepin.com/deepin/ apricot main contrib non-free
#deb-src https://community-packages.deepin.com/deepin/ apricot main contrib non-free

 

Creo que el problema de dependencias está en la instalación de Gimp, pero no consigo desinstalarlo. Lo instalé desde la Tienda Deepines.

 

Respuesta
Brandon Guerra
Respuestas: 26
Registrado
(@devilment)
Integrante Eminente
Registrado: hace 5 meses

No sé si se pueda solucionar con Deepin Repair, tiene una opción de reparar DPKG

Captura de pantalla área de selección 20210325121856

 

Respuesta
Comparte: