COLEÇÃO de widgets Deepin

Widget Igatjens. Criado por Isaias Gatjens (Twitter)

Widgets baseados Conky

Muitos de nós gostaria de ter widgets na parte inferior do seu desktop. Para esse fim, criamos um deb com uma vasta coleção de widgets de todo o pacote tipos. Estes elementos são selecionados e configurados a partir do programa "Conky Manager", incluído no mesmo pacote.

INSTALAÇÃO

Baixe e instale o repositório de pacotes Deepines em seguida, executar o comando update && sudo sudo apt apt-instalar widgets conkys . Ele já cuida adicionar todos os pacotes necessários para o funcionamento adequado (conky-gerente, Conky, sensores, etc.).

Uma vez que o pacote é instalado e podemos usar mais de widgets integrados. No entanto, existem alguns widgets que você precisa de um pouco modificações extras para funcionar corretamente. Que irá explicar em detalhes abaixo.

OPERAÇÃO

programa Gerenciador Conky lista de widgets disponíveis. Nós podemos mover-se entre eles e selecionar aqueles que você deseja, com ícones no lado superior esquerdo [Figura 1]Ou simplesmente movendo o mouse e marcando o quadrado para selecioná-lo. Você pode mudar todos aqueles que querem o único, mas eles podem se sobrepor. No entanto, você pode mudar os widgets em toda a área de trabalho da maneira que quiser.

Imagem 1. Conky-Manager interface


Os / widgets permanecem ativos até que feche sessão ou desmarque a ativação caixa. Para ser permanente você tem que ativar a opção de boot conky de login, como mostrado na imagem abaixo.

Figura 2. Ativando Conky no arranque

Com Conky Manager você pode mudar tanto a posição ea cor de widgets fundo. O tamanho também pode ser modificado, mas pode fazer elementos de widgets não se encaixam corretamente desde o botão de configurações. Muitos deles são coleções de conkys (widgets) projetados de modo que eles se encaixam melhor visualmente entre si. Aqueles que pertencem à mesma coleção de widgets de ter o mesmo nome entre os dias 3 e 4 de barra "/". Como exemplo dessa conky "~ / .conky / Originals/ Elegante + To-do-list /config / cpu "onde todos esses widgets Elegante + To-do-lista nessa posição eles são da mesma coleção.

AJUSTES WIDGETS

  • Widgets que a rede de dados de exemplo: Na maioria das máquinas, os widgets que mostram gráficos de tráfego de rede deve funcionar corretamente.
    Se não for o seu caso, para corrigi-lo, você deve substituir o nome da rede que vem padrão em Conky Manager (wlp3s0) de sua máquina por. Para fazer isso olhamos para o terminal o nome da sua rede com o seguinte comando: show de conexão nmcli. Você vai ter o nome na coluna "Device". Vamos configurações Conky ManagerNetwork / interface Substituindo "wlp3s0" pelo nome da rede que nos deu de volta o comando.
  • Faça widget de lista (ou anotações).Para criar notas com o "~ / .conky / Originals / Elegante + a-do-list / widget Config' você tem que criar um arquivo chamado notas.txt (sem letras maiúsculas) em sua pasta / home /. Para atualizar suas notas que você escreve para o arquivo e quando você mantê-lo atualizado no widget.
  • Widget de música (~ / .Conky / Original / Paneles_en_cajas / Config / mediaplayer_rc) dados mostra as músicas que estão tocando, mas apenas com Clementine leitor de música. Portanto, para usar este widget, você deve instalar o jogador com sudo apt clementine instalar
Widget Paneles_en_cajas
 

25
O que você acha?

Por favor entrar para comentar
12 tópicos de comentários
13 fio de respostas
1 Seguidores
 
Comentar com mais reações
fio de Altamente Recomendável
14 Autores comentários
zarkofagojulio chalcojesusalbertomariaFabio BarbosaIsaías Gätjens MOs autores dos comentários mais recentes
subscrever
MAIS NOVO mais velho mais popular
relatório do
Car
autor

Parabéns !!!! excelente trabalho, o tempo gasto e Isaías Gätjens MIs Gatjens M nessa tarefa; um abraço.

f12019
Membro

Amigo muito bom obrigado por este

Akiba Illusion
autor

+1000000000000000000000000000

Nits
Membro

Expectacular! Graças Jorge para este laburito!

Juan Martín Runge
Membro

Olá! Eu queria instalá-lo em 15.9.2 e eu recebo o seguinte:

[email protected]:~$ sudo apt install conkys-widgets
Lendo listas de pacotes ... Feito
árvore de dependência edifício
Lendo informação de estado ... Feito
Eles não poderia instalar alguns pacotes. Isto pode significar que
Ele solicitou uma situação impossível ou se você estiver usando a distribuição
distribuição que alguns pacotes requeridos não foram criados ou
Eles tomaram de "entrada".
As informações a seguir podem ajudar a resolver a situação:

Os seguintes pacotes têm dependências não satisfeitas:
conkys-widgets: Depende: conky-manager, mas não é instalável
E: Não fomos capazes de corrigir problemas, você manteve pacotes quebrados.

Eu tenho algo de errado com minhas fontes, ou pode ser, não é para esta versão?

Obrigado!

Isaías Gätjens M
editor

Olá, também é importante para atualizar repositórios apenas antes de instalar

update && sudo sudo apt apt-instalar widgets conkys

E, como George sugere, a versão beta do Deepin faltando dependências.

Juan Martín Runge
Membro

Muito obrigado a ambos. Quando a queda não tinha idéia que era beta, snif. Eu posso ir para o estábulo sem reinstalar nada?

Saudações!

Eli
Administrador

interessante Jorge KenobiJorge KenobiMuito bem explicado.

ariel campos
Membro

Olá! instalar em Deepin 15,10 e alguns não pode aplicá-los transparências, desaparecidos e feche outros ícones. Como você pode ser reparado? obrigado

luisrosales0130
Membro

Boa tarde em Deepin 15.10 não se aplica transparências e widgets de esperança pode ser resolvido em breve desaparecer graças são cheveres

Isaías Gätjens M
editor

Oi, como Jorge indicado na resposta ao comentário anterior, com a mudança do gerenciador de janelas Deepin 15,10, muitas configurações estão desatualizados, nós preparamos uma atualização que resolve esses problemas e estará disponível no novo repositório deepines compatíveis com o novo Deepin 15,10, que será publicado nos próximos dias.

Fabio Barbosa
Membro

Possível E na Widgets moverá tecido. ou mostraram vozes aqui na Primeira Imagem Muito ficou nenhum top porem meu pouoquinho Acima e Onde hum Barra do Deepin topo FICA FICA na ligeiramente ao longo do tempo ou widget.

Isaías Gätjens M
editor

Oi! Eu nao entendo português, estou usando o Google ou Tradutor.

Rápido Você PODE vai passar, ou gerenciador Conky permite rápido Você mova cada widget de modo Independente.

Vou com hum tentar mostrar vídeo.

Isaías Gätjens M
editor

CARREGAR ou vídeo aqui Não deu Certo, um link de Passo ENTÃO eu.

https://photos.app.goo.gl/oZqzSaqSpzPyhpw89

jesusalbertomaria
Membro

instalá-lo seguindo os passos e até então eu ainda obter o conky managger

🙁

Isaías Gätjens M
editor

Olá, por favor exibir a mensagem de erro e detalhes, os dados fornecidos são insuficientes para determinar qual é o problema.

jesusalbertomaria
Membro

Eu não posso mostrar-lhe o erro que, como ele é normalmente instalado, mas quando se olha para pasta pessoal e até mesmo arquivos ocultos não aparecem, ou seja, eu segui os passos, mas quando me começando nada aparece.

Isaías Gätjens M
editor

OK, eu vou tentar adivinhar, você não é mais fácil ... por exemplo, eu teria servido vista o conteúdo da pasta pessoal ou screenshots do processo de instalação que você fez, todos esses são detalhes com informações úteis.

Execute os seguintes comandos, um por vez, cuidado para não pular nenhuma e por favor, mostrar os resultados.

-a lsb_release

/etc/apt/{sources.list,trusted.gpg}.d/ && sudo ls -la debconf-show deepines-repositório

mv ~ / ~ .conky / .conky _ $ (data +% Y% m-% d% H% H% S)

Sudo apt purga conkys-Widgets

update && sudo apt -f install sudo apt

atualizar && sudo sudo apt apt instalar conky-tudo

update && sudo sudo apt apt-instalar widgets conkys

julio chalco
Membro

O comando não funciona

zarkofago
Membro

Ya realice la instalación y configuración, la mayoria de widgets funciona bien pero tengo inconveniente con el de red llamado conky-iganjens-med-internet.conf, de pantalla pequeña, sucede que no me muestra información de la red, y si accedo a cambiar el nombre de la interfaz de red me dice que a ese widget no se le puede editar la interface de red, como puedo hacer dicho ajuste

Isaías Gätjens M
editor

Hola, conky-igatjens-med-internet está pensado para medir el ancho de banda de Internet, no de la tarjeta de red, tomando como escala el lo que se indica debajo del porcentaje del centro, ancho de banda de referencia o de escala se establece manualmente en conky-igatjens-000-ajustes.lua. Por eso el medidor se llama Internet y no red.

Puede modificar los ajustes en conky-igatjens-000-ajustes.lua, advierto que estos no son sencillos conkys de los viejos, son más complejos y tienen programación en lenguaje LUA. Los conky de igatjens detectan automáticamente los dispositivos de red, pero esto se puede cambiar en conky-igatjens-000-ajustes.lua.

Le recomiendo ver el widget de ayuda.

DeepinScreenshot_Seleccionar área_20200218093732.png
DeepinScreenshot_Seleccionar área_20200218092930.png
DeepinScreenshot_Seleccionar área_20200218093711.png
Isaías Gätjens M
editor

Agrego, por ejemplo el ancho de banda por defecto es de 6Mbps, si el ancho de banda usado es de 60kbps sólo representa el 1% de 6Mbps. El siguiente es un ejemplo del funcionamiento normal del widget.