PYTHON 3.6.9をディープインに簡単にインストールする方法

Python es un lenguaje de programación interpretado, de alto nivel y de propósito general. Creado por Guido van Rossum y lanzado por primera vez en 1991, la filosofía de diseño de Python enfatiza la legibilidad del código con su notable uso de importantes espacios en blanco.

幸い、どんなプログラミング言語でも(それが何であれ)経験のあるプログラマーであれば、Pythonをすぐに理解できます。 また、初心者にとっても使いやすく、習得も簡単です。 Pythonプログラミング言語は、そのデータサイエンス、機械学習、システムオートメーション、APIおよびWeb開発などで際立っています。

この出版物で私は簡単な スクリプト これにより、愛するDeepinでのPythonのインストールが非常に簡単になり、次の3つの簡単な手順に従ってインストールできます。

  • 以下をクリップボードにコピーします。
cd /tmp
wget  https://www.python.org/ftp/python/3.6.9/Python-3.6.9.tar.xz  
sudo apt update
sudo apt install -y build-essential zlib1g-dev libncurses5-dev libgdbm-dev libnss3-dev libssl-dev libreadline-dev libffi-dev libsqlite3-dev
tar -xf Python-3.6*.tar.xz
cd Python-3.6.9
./configure --enable-loadable-sqlite-extensions # Avoid an error in sqlite
make
sudo make altinstall
sudo python3.6 -m pip install --upgrade pip
sudo python3.6 -m pip install --upgrade setuptools 
echo 'Done. Type python3.6 to run.'
  • 開く Deepin-Editor 貼り付けて、たとえば次の名前で保存します。 install-python3.6.sh そして、それが実行可能であることを確認してください。
  • 上記のファイルを保存したのと同じパスでターミナルを開き、次のように入力します。
bash install-python3.6.sh

最後に、完璧なPythonのインストールを行うには、これで完了です。

Algo de historia sobre Python

1991年にさかのぼるPythonプログラミング言語は、ギャップを埋める方法、「退屈なことを自動化する」スクリプトを書く方法(Pythonの学習に関する一般的な本のように)、またはアプリケーションのプロトタイプをすばやく作成する方法と見なされていました他の言語で実装されます。

しかし、近年、Pythonは最新のソフトウェア開発、インフラストラクチャ管理、およびデータ分析において一流の市民になりました。 これはもはやバックルームユーティリティ言語ではなく、ウェブアプリケーションの構築とシステム管理における主要な力であり、ビッグデータ分析とマシンインテリジェンスの急増の主要な推進力です。

記事が役に立った場合は、以下の正の評価を残していただき、ご不明な点がございましたら、お気軽にお問い合わせください。

明確化

Si usas Deepin V20 beta o superior entonces no tienes necesidad de seguir este tutorial ya que Deepin 20 ya trae instalado Python 3.7.3. La versión por defecto en Deepin 15.11 es sin embargo inferior y lo puedes actualizar siguiendo este tuto. Gracias @JareGM リマインダー。



4.8 18 投票
記事を評価する
 
サブスクライブ
の報告書
10 レビュー
もっと人気
新しい 古い
記事からの意見
すべてのコメントを見る
Jare GM
Jare GM (@jaregm)
1ヶ月前

Python 3.7.3はすでにdeepinにインストールされています。 簡単に言えば、「python3 ′ (引用符なしで)deepinターミナルで、IDLEまたはPythonシェルに入ります(deepin 20のバージョン3.7.3)。
deepinターミナルで、「python'(引用符なし)、Pythonのバージョンは2.7.16になります。
3つのディプルが表示されるため、Pythonインタープリターにいることがわかります:>>>。 Pythonシェルを終了するには、「出口 ()'(引用符なし)、または'終了する ()'(引用符なし)。

Эли
Эли (@eli)
管理
に答える ジャレGM
1ヶ月前

ジャレGM いつもお会いできて光栄です。

実際、このチュートリアルはDeepin 15.11のユーザーを対象としています。最終的には、Deepinの安定版です。 Deepin 20がリリースされたら、記事を更新するか、Pythonのバージョンを更新する方法について、新しい記事を作成します。

とにかくありがとうございます。Deepin20ベータ版でこれを読んだ人は誰でも、このチュートリアルを実行するべきではないことを知っているので、説明する価値があります。 記事の最後に説明文を載せておきます。

再度、感謝します。

Luis Serrano
Luis Serrano (@luis-serrano)
1ヶ月前

スクリプトはプロセスを簡略化します エドゥアルド・ウィリアンズ

Car
Car (@car)
1ヶ月前

入力ありがとうございます。

javier velasquez
javier velasquez (@javiervelasquez)
1ヶ月前

エドゥアルド・ウィリアンズ <あなたの貢献に感謝します、とても良い..祝福

Эли
Эли (@eli)
管理
1ヶ月前

エドゥアルド・ウィリアンズ 素晴らしいコラボレーションをありがとう。

Alkyt
Alkyt (@alkyt)
1ヶ月前

こんにちは、疑問があります。 そのバージョン以降のバージョンにpython-tkをインストールする場合はどうすればよいですか?

s384
s384 (@s384)
に答える アルキト
1ヶ月前

異なるバージョンのpythonを使用するには、使用するバージョンを指定する必要があります。
コンソールのこれらのコマンド:
python3と入力すると、デフォルトになります
代わりにpython3.6を作成すると、インタープリター3.6が提供されます
python-tkがpip内のモジュールである場合は、次を実行します
pip3.6 install python-tk(pipかどうかはわかりません)
現在、最も推奨されるのは、異なるプロジェクトにモジュールをインストールするためにvenv(仮想環境)を使用することです。

Frank Alvarez
Frank Alvarez (@franky08)
1ヶ月前

どうもありがとうございました。

10
0
私たちはあなたの考えを知りたいのですが、議論に参加してください。x