MIGLIORA LA VELOCITÀ DEI REPOSITORI DEEPIN OS OGGI

ARTICOLO AGGIORNATO

19-04-2020: Il repository di AppStore.
27-08-2020: aggiornato per adattarsi a Deepin 20 1001
21/09/2020: il titolo è stato aggiornato per riflettere che la procedura funziona con Deepin 20 Final
05-12-2020: l'URL e il parametro di distribuzione dei repository mirror Deepin sono stati aggiornati.
01-12-2021: corretto l'URL del repository del mirror per rimuovere la parola test.
12-01-2021: il titolo dell'articolo è stato modificato per riflettere che la procedura funziona in Deepin 20 e versioni successive.
03-02-2021: L'URL del repository mirror del negozio Deepin è stato aggiornato.

MIGLIORA LA VELOCITÀ DEI REPOSITORI

Offriamo una soluzione per aumentare la velocità del repository Deepin 20 e superiore. A causa dell'immensa richiesta di repository di Deepin 20 (e versioni successive) ospitata in Cina, la comunità sta riscontrando interruzioni, ritardi di connessione e velocità lente.

Per questo, a nome di tutto il nostro team, vogliamo fare la nostra parte e rendere pubblico il nostro specchio il Comunità Deepin in spagnolo. Questo mirror è ospitato al di fuori della Cina e offre velocità di trasferimento migliori.

Di seguito è riportata la configurazione dei mirror.

deb [by-hash=force] https://mirror.deepines.com/deepin/ apricot main contrib non-free
deb https://mirror.deepines.com/appstore eagle appstore

Se utilizzi per configurare manualmente i repository, sai già che devi cambiare il repository modificando il filesources.list.

Forniamo anche un metodo semplice e veloce per cambiare il mirror, selezionare per intero il seguente comando con un triplo clic (tutto il testo in un unico comando), copiarlo, incollarlo nel terminale e premere il tasto entrare.

Questo primo comando aggiunge il repository principale del sistema.

sudo sed -i "s|^deb \[by-hash=force\] https://community-packages.deepin.com/deepin/ apricot main contrib non-free|#deb \[by-hash=force\] https://community-packages.deepin.com/deepin/ apricot main contrib non-free\ndeb \[by-hash=force\] https://mirror.deepines.com/deepin/ apricot main contrib non-free|" /etc/apt/sources.list

Puoi verificare se hai cambiato il mirror con successo con il seguente comando.

cat /etc/apt/sources.list

E dovresti ottenere il seguente risultato.

[email protected]:~$ cat /etc/apt/sources.list
## Generated by deepin-installer
#deb [by-hash=force] https://community-packages.deepin.com/deepin/ apricot main contrib non-free
deb [by-hash=force] https://mirror.deepines.com/deepin/ apricot main contrib non-free
#deb-src https://community-packages.deepin.com/deepin/ apricot main contrib non-free
[email protected]:~$ 

Ora aggiungeremo il repository dell'archivio applicazioni con questo secondo comando, ripetiamo il processo. Selezionare il seguente comando intero facendo triplo clic (tutto il testo in un unico comando), copiarlo, incollarlo nel terminale e premere il tasto entrare.

sudo sed -i "s|^deb https://community-store-packages.deepin.com/appstore eagle appstore|#deb https://community-store-packages.deepin.com/appstore eagle appstore\ndeb https://mirror.deepines.com/appstore eagle appstore|" /etc/apt/sources.list.d/appstore.list

Puoi verificare se hai cambiato il mirror con successo con il seguente comando.

cat /etc/apt/sources.list.d/appstore.list

E dovresti ottenere il seguente risultato.

[email protected]:~$ cat sources.list.d/appstore.list 
#deb https://community-store-packages.deepin.com/appstore eagle appstore
deb https://mirror.deepines.com/appstore eagle appstore
[email protected]:~$ 

Ora dobbiamo solo aggiornare il database APT con il seguente comando.

sudo apt update

Se il terminale non mostra messaggi di errore, tutto è stato configurato correttamente.

CHIARIMENTO

Il repository mirror di Deepin non deve essere confuso con Negozio Deepines, il repository mirror è una copia esatta del repository Deepin in Cina, Negozio Deepines (Precedentemente noto esclusivamente come Repository della community di Deepines) è quello con i pacchetti personalizzati. E sì, Deepin in spagnolo mantiene due repository, il repository mirror e il repository della community Deepines (Now Deepines Store).

Il contenuto delle immagini e del testo del negozio di applicazioni Deepin dipende da un sito Web ospitato in Cina. Cambiare il repository mirror con quello della nostra community non velocizzerà il caricamento di immagini e testo. Ciò che sarà più veloce sono i download delle applicazioni una volta installate, che verranno scaricate dai nostri server.

4.9 36 voti
Valuta l'articolo
 
Abbonarsi
Relazione
32 Reacciones
I più popolari
Più nuovo Più vecchio
Opinione dall'articolo
Vedi tutti i commenti
Gabriel
Gabriel (@gabriel-acu)
Membro
10 meses atrás

Qualcuno mi dà una mano, quando provo ad aggiornare (sudo apt update) ottengo il seguente errore.

E: Impossibile ottenere https://mirror.deepines.com/testing/deepin-20-beta/dists/apricot/main/Contents-amd64 404 Non Trovato [IP: 172.67.149.13 443]
E: Alcuni file di indice non possono essere scaricati, sono stati ignorati o sono stati utilizzati quelli vecchi.

Nelle verifiche ho lo stesso dettaglio della pubblicazione con cui capisco che il problema potrebbe essere un altro. Sono un utente alle prime armi in questo mondo, mi scuso se questo non è il luogo o il modo per chiedere una mano.

Grazie in anticipo. Un saluto!

Omar G
Omar G (@omarg)
Membro
1 año atrás

Di solito le comunità più attive sono in inglese, ma questo è sicuramente il migliore per il deepin. Grazie per l'ottimo lavoro

Juan Carlos
Juan Carlos (@juan-carlos)
Membro
Respondiendo a  Omar G
1 año atrás

È vero, grazie per il grande impegno della comunità.

Beyman Mcgregor Lopez Mejia
Beyman Mcgregor Lopez Mejia (@beymanmcgregorlopezmejia)
Membro
1 año atrás

Sono d'accordo, questa è la migliore comunità Linux spagnola in cui sia mai stato !!
Adoro questo sistema operativo !!

danny672007
danny672007 (@danny672007)
Membro
1 año atrás

Grazie per il contributo Fenoll, mi ha aiutato molto!

Jare GM
Jare GM (@jaregm)
Membro
1 año atrás

Grazie per il lavoro, Fenoll.

BorisJSMX
BorisJSMX (@borisjsmx)
Membro
1 año atrás

Grazie mille, in questo momento sto andando molto più veloce.

Eli
Eli (@eli)
Admin
1 año atrás

Ottimo contributo alle comunità profonde di tutto il mondo, ottimo lavoro Fenoll.

Car
Car (@car)
autore
1 año atrás

Gracias por todo el trabajo Fenoll ya podemos comenzar con los ajustes finales para deepines 4 y la nueva Deepines Store de la comunidad.

luis eduardo
luis eduardo (@luis-eduardo)
Membro
1 año atrás

Quando pensi che verrà rilasciata la versione finale di Deepin 20?

XOdein
XOdein (@xodein)
Membro
1 año atrás

Buon complemento per testare bene la beta, grazie.

ErnestoRyes
ErnestoRyes (@ernestoryes)
Membro
1 año atrás

Ora è più facile per me installare applicazioni dallo store.

sebas
sebas (@sebas)
autore
1 año atrás

Grazie mille per il contributo.

Memo Soria
Memo Soria (@gsorian)
Membro
1 año atrás

Ciao come stai

Ho eseguito questa operazione e ha migliorato molto il tempo di risposta per gli aggiornamenti, tuttavia oggi ricevo un errore quando voglio aggiornare nuovamente il sistema, con un messaggio di «Errore di dipendenza, non è riuscito a rilevare gli aggiornamenti», Cosa ho è stato restituito ai repository originali Deepin 20 Beta, installati di default, anche se il problema continua. Per ora, aspetto, pensando a un problema con i server.

Qualcuno sul forum ha riscontrato lo stesso problema? ... Se sì ... lo ha risolto?

Grazie in anticipo e saluti,
Memo.

Eli
Eli (@eli)
Admin
Respondiendo a  Memo Soria
1 año atrás

Memo Soria bravissimo, l'errore che conti non mi sembra correlato a questo repository, infatti non credo sia legato ai repository che usi, potrebbe essere qualcosa di diverso.

Puoi per favore dire esattamente il comando che stai usando quando lo ottieni? Puoi mostrare uno screenshot dell'errore? Stai cercando di aggiornare tramite terminale o tramite l'interfaccia grafica?

Saluti.

Memo Soria
Memo Soria (@gsorian)
Membro
Respondiendo a  Eli
1 año atrás

Ciao Eli, grazie mille per aver risposto! ... Bene, si scopre che l'ho rifatto adesso, aggiornamento da interfaccia grafica e da terminale e ... non ci sono errori! ...

Saluti!

Daniel Berin
Daniel Berin (@danielberin1)
Membro
1 año atrás

Domanda ... questo mirror continua ad aggiornarsi? è l'ultimo della Cina? o quanto tempo ci vuole per replicare

Eli
Eli (@eli)
Admin
Respondiendo a  Daniel Berin
1 año atrás

Daniel Berin lo specchio continua ad aggiornarsi, l'ora specifica delle repliche non saprei dirti, forse Fenoll o Auto possono darti maggiori dettagli a riguardo.

Saluti.

Maxidiazbattan
Maxidiazbattan (@maxidiazbattan)
Membro
1 año atrás

Mi genera un errore durante l'aggiornamento, ho copiato tutto così com'è nel post. Qualche soluzione? Da già grazie mille.

Obj:2 https://mirror.deepines.com/testing/deepin-20-beta apricot InRelease        
Ign:3 https://community-packages.deepin.com/printer eagle InRelease            
Err:4 https://community-packages.deepin.com/printer eagle Release             
 404 Not Found [IP: 94.130.49.186 443]
Obj:5 https://mirror.deepines.com/testing/appstore eagle InRelease
Leyendo lista de paquetes... Hecho
E: El repositorio https://community-packages.deepin.com/printer eagle Release» no tiene un fichero de Publicación.
N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.

Isaías Gätjens M
Isaías Gätjens M (@igatjens)
Admin
Respondiendo a  Maxidiazbattan
1 año atrás

Maxidiazbattan

Ciao, controlla l'articolo Cosa fare dopo aver installato Deepin 20? - https: //deepinenespañol.org/que-hacer-despues-de-instalar-deepin-20-guia-basica/ - C'è una soluzione a quel problema.

 

Maxidiazbattan
Maxidiazbattan (@maxidiazbattan)
Membro
Respondiendo a  Isaías Gätjens M
1 año atrás

Isaías Gätjens M Eccellente, grazie mille per aver risposto così presto Isaías. Grazie all'articolo ho potuto correggerlo. Saluti!

Daniel Berin
Daniel Berin (@danielberin)
Membro
11 meses atrás

Funziona per l'ufficiale? o non è necessario?

Eli
Eli (@eli)
Admin
Respondiendo a  Daniel Berin
11 meses atrás

Daniel Berin Sì funziona.

José Paredes
José Paredes (@joseparedes)
Membro
11 meses atrás

Grazie mille per il contributo della migliore comunità in GNU Linux.

Ruben PC
Ruben PC (@rubenpc)
Membro
11 meses atrás

Grazie.

caradecavalo
caradecavalo (@caradecavalo)
Membro
11 meses atrás

La ringrazio maestro.

MartCuv
MartCuv (@martcuv)
Membro
3 meses atrás

Buongiorno. Buon pomeriggio. Buona Notte. Ho iniziato nel mondo Linux con Deepin e la community ha avuto un'influenza definitiva sulla scelta della distro. Grazie mille per il tuo ottimo lavoro. Un abbraccio.

NEO-TECH
NEO-TECH (@neo-tech)
Membro
3 meses atrás

Ottimo il tutorial di Fenoll.
Ho eseguito i passaggi e ho ricevuto un errore due volte durante l'aggiornamento, ovvero durante l'esecuzione del comando sudo apt update. So che l'errore non è dovuto alla procedura che spieghi ma si riferisce all'applicazione Etcher, che ho installato fuori dall'Application Store.
Il problema è che l'ho disinstallato ma ogni volta che eseguo quel comando ottengo di nuovo lo stesso errore. Vorrei sapere come pulirlo dal sistema, poiché l'applicazione non è installata.
Successivamente lo reinstallerò dall'App Store.
Tutto questo è successo perché c'è una versione obsoleta nello Store e uno di questi, volendo avere sempre l'ultima versione, si installa dal sito Web dell'applicazione (che so che non è consigliato). E a quanto pare rovina il sistema.
Allego le immagini che rispecchiano ciò che voglio risolvere.
Da già grazie mille.
Un abbraccio

acutualizandoRepositorios01

actualizandoRepositorios02

 

Эли
Эли (@eli)
Admin
Respondiendo a  NEO-TECH
3 meses atrás

Ciao NEO-TECH,

Il problema riscontrato nelle acquisizioni non è correlato ai passaggi in questo articolo.

Tuttavia ti dirò che quegli errori si verificano perché il repository di quell'applicazione incisore che ha problemi o non è più funzionante.

Per correggere questi errori devi rimuovere il repository che da incisore.io. Il modo più semplice e sicuro per te sarebbe rimuoverlo attraverso Synaptic. Se non lo hai installato, puoi farlo eseguendo il seguente comando in un terminale:

sudo apt install synaptic

Quindi apri l'applicazione e nel menu in alto scegli "Repository" quindi cerca il repository che of incisore O lo rimuovo o lo disabilito.

Saluti.

NEO-TECH
NEO-TECH (@neo-tech)
Membro
Respondiendo a  Эли
3 meses atrás

Eli Ciao!
Intelligente. Repository rimosso dal sistema. Grazie. 😊
È emerso un nuovo argomento. Il deposito «deb https://mirror.deepines.com/appstore eagle appstore »appare disabilitato in Synaptic. L'ho abilitato e ho ricevuto un errore che non sono riuscito a catturare perché la finestra che lo mostra scompare rapidamente. Tutto quello che potevo vedere era che diceva "Fallito". Per cui deduco che non riuscirei ad ottenere il vantaggio di accelerare i download. Come può essere risolto?
In conclusione, vorrei che la finestra che mostra Synaptic, elencando tutti i repository, comparisse direttamente nel Centro di controllo di Deepin, ad esempio all'interno della sezione "Aggiornamenti". Sarebbe molto pratico visto che non dovremmo, come nel mio caso, installare un'applicazione non nativa per risolvere problemi con i repository o aggiungerne di nuovi. Inoltre, non ho ancora le conoscenze per farlo tramite Terminale.
Allego gli screenshot che mostrano la mia esperienza con l'argomento in questione.
Da già grazie mille.
Un abbraccio

repositorioNoFuncional00

repositorioNoFuncional01

repositorioNoFuncional02

 

Eli
Eli (@eli)
Admin
Respondiendo a  NEO-TECH
3 meses atrás

NEO-TECH Non so perché, ma non ho visto questo tuo messaggio, comunque controlla quello che vuoi L'ho spiegato qui ad un'altra persona.

Saluti.

Carlos Araya
Carlos Araya (@carlosaraya)
Membro
3 meses atrás

Ho problemi con il terminale perché non riconosce nulla che inserisco, nemmeno la password.

32
0
Vorremmo sapere cosa ne pensate, unitevi alla discussione.X