Deskjet stampante HP 2540 non stampa Wifi Deepin 15.11 (lavorato in 15.9)


Radec
Risposte: 1
registrato
(@Radec)
Nuovo (a) membro
Registrado: hace 4 meses

Ho cercato di impostare la stampante tramite USB e separato in esecuzione USB senza fili e senza wifi. Il caso presente, che sono entrambi impostati allo stesso tempo, è solo per dimostrare il fallimento confrontandoli.

In allegato un video che illustra il problema.

https://drive.google.com/file/d/144JmmdO6dRJxj6p6sCZPW3EeqwwdRKZ7/view?usp=sharing

 

Risposta
6 risposte
EchedeyLR
Respuestas: 14
registrato
(@Echedeylr)
membro attivo
Registrado: hace 10 meses

Buonanotte.

Ho lo assiste durante l'installazione della stampante. Ti ho detto di includere qui perché sembra che ci sia un bug nei driver, in quanto la stampante è perfettamente rilevata e USB e Wi-Fi, oltre a fornire informazioni sullo stato rilevante e USB possono essere stampati senza problemi aggiunto.

Come si è visto durante la stampa wifi sembra che il lavoro sia correttamente inviato alla stampante, ma non elaborato per la stampa.

Come un commento aggiuntivo devo dire che cerchiamo di visualizzare la configurazione tramite tazze pannello web, ma almeno abbiamo potuto collegare (dovrebbe essere localhost: 631) e tuttavia il servizio è stato contrassegnato come in esecuzione (abbiamo anche cercato di riavviare) . Non so se ha qualcosa a che fare.

Devo anche dire che si tratta di un impianto di Deepin 15.11 0 il cui unico extra pacchetto installato connessi alla stampa è "hplip-gui", il resto sono stati già installato di default.

Risposta
4 risposte
Eli
 Eli
moderatore
(@Eli)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 554

@radec e @echedeylr

Aprire un terminale e digitare:

hp-setup

Questo dovrebbe impostare le cose, se si dà errori ritorno mostrano qui. Anche in un terminale scrive:

CV-check

Basta scrivere il risultato qui.

Risposta
EchedeyLR
registrato
(@Echedeylr)
Registrado: hace 10 meses

membro attivo
Respuestas: 14

@eli

Buon pomeriggio e la ringrazio molto per ritrovare la pubblicazione in posizione.

Forse dovrei essere più specifico nella risposta precedente.

 

Il motivo per cui il video di esempio abbiamo presentato con il HPLIP strumento grafico è dovuto aggiungere stampanti che utilizzano tale software.

Per essere chiari, tranne che per la stampante USB, che viene aggiunto completamente grafica, le impostazioni Wi-Fi, utilizzando la consolidata "hp-setup 192.xxx.x.xx" (le X non mettere l'ip completo qui ) ed è stato aggiunto senza alcun tipo di errore.

Come specificato in precedenza nessun problema a trovare le informazioni di stato Wi-Fi. Certamente va con leggero ritardo per quanto riguarda l'informazione tramite USB e il video non viene visualizzato correttamente, ma normale durante la stampa tramite USB sulle prove che abbiamo fatto è che quando si stampa tramite USB, lo strumento della clessidra grafica ottiene di richieste processate e uno o due secondi dopo appare sulla connessione wireless.

Abbiamo anche ipotizzato che potrebbe essere necessario riconfigurare la stampante a 0 e utilizzare la procedura dallo strumento HPLIP collegare graficamente tramite USB, indicare alla stampante di rete deve connettersi e una volta collegato ricevuto correttamente il comando "hp-setup IP "printer-corrente che indica il software da eseguire. Si procede ed è lo stesso caso di cui sopra, senza intoppi e con successo la ricezione di informazioni di stato.

Poi si dimostra con "CV-check" per verificare se si tratta di qualcosa di diverso da aggiornare lo stato. Abbiamo anche effettuato il riavvio del sistema dopo aver aggiunto la stampante e test per verificare in modo corretto quando si carica nuovamente l'applicazione in fase di avvio, questo ci ha detto che la stampante wifi è stato scollegato. Nessun problema di nuovo e la ricezione di informazioni sullo stato in modo corretto.

Risposta
EchedeyLR
registrato
(@Echedeylr)
Registrado: hace 10 meses

membro attivo
Respuestas: 14

@eli

Qui si ha l'uscita CV-check alle stesse condizioni di prova del video.

Ciò che mi lascia con più domande è la parte di dipendenze esterne. So che alcuni sono opzionali come xsane ma il fatto che le tazze da non installato o in esecuzione è quello che mi lascia un sacco di dubbi circa l'esperienza che ho menzionato in precedenza. Un altro caso è dbus. Ripeto che si tratta di un'installazione di default di Deepin 15.11 a causa del ribasamento e il cui unico extra pacchetto installato connessi alla stampa è stato "hplip-gui". Né è disinstallato il sotto menzionati, ma non hanno esaminato tutti e ciascuno se venissero installati di default (anche se è noto a CUPS e sono necessari dbus)

hp-controllo [15409]: info:
hp-controllo [15409]: info: [01mHP Linux Imaging and Printing System (. vedi 3.16.11) [0m
hp-controllo [15409]: info: [01mDependency / Utility Versione controllare per vedere. 15.1 [0m
hp-controllo [15409]: info:
hp-controllo [15409]: info: Copyright (c) 2001-15 Hewlett-Packard Development Company, LP
hp-controllo [15409]: info: Questo software ASSOLUTAMENTE NESSUNA GARANZIA Comes With.
hp-controllo [15409]: info: Questo è un software libero, e siete invitati a distribuirlo
hp-controllo [15409]: info: alcune condizioni. Vedere file COPYING per ulteriori dettagli.
hp-controllo [15409]: info:
hp-controllo [15409]: info: [01mNote: HP-controllo può essere eseguito in tre modalità: [0m
hp-controllo [15409]: info: 1. Compile-time modalità di controllo (-c o --compile): utilizzare questa modalità prima di compilare il
hp-controllo [15409]: info: HPLIP tarball in dotazione (.tar.gz o .run) per determinare se le dipendenze corrette
hp-controllo [15409]: info: sono installati per compilare correttamente HPLIP.
hp-controllo [15409]: info: 2. Di run-time modalità di controllo (-r o --run): utilizzare questa modalità per determinare se una distro
hp-controllo [15409]: Info: Pacchetto in dotazione (.deb, .rpm, ecc) o un tarball HPLIP già costruito ha fornito
hp-controllo [15409]: info: le dipendenze corretti installati per eseguire correttamente.
hp-controllo [15409]: info: 3. Sia la modalità di compilazione e run-time di controllo (-b o --both) (Default): questa modalità
hp-controllo [15409]: info: controllare entrambi i casi di cui sopra (sia di compilazione e run-time le dipendenze).
hp-controllo [15409]: info:
hp-controllo [15409]: info: Controllare i tipi:
hp-controllo [15409]: info: a. EXTERNALDEP - Dipendenze esterne
hp-controllo [15409]: info: b. GENERALDEP - Dipendenze generali (richiesto in fase di compilazione ed eseguire Sia il tempo)
hp-controllo [15409]: info: c. COMPILEDEP - Compilare dipendenze temporali
hp-controllo [15409]: info: d. [Tutti sono in fase di esecuzione dei controlli]
hp-controllo [15409]: info: PERMESSO PYEXT SCANCONF CODE
hp-controllo [15409]: info:
hp-controllo [15409]: info: Tipi di stato:
hp-controllo [15409]: Info: OK
hp-controllo [15409]: info: MISSING - Dipendenza o permesso o plug-in mancante
hp-controllo [15409]: info: INCOMPAT - Versione incompatibile o di dipendenza-plugin-versione
hp-controllo [15409]: info:
warning: Deepin distro non si trova in AUTH_TYPES
warning: [01m0- "15.11" versione non è supportata. 0-0 Utilizzo di versioni per verificare le dipendenze e l'installazione ... [0m
hp-controllo [15409]: info:
hp-controllo [15409]: Info: ---------------
hp-controllo [15409]: info: 😐 SYSTEM INFO |
hp-controllo [15409]: Info: ---------------
hp-controllo [15409]: info:
hp-controllo [15409]: info: Kernel: 4.15.0-30deepin-generic # 31 SMP Ven Nov 30, 2018 04:29:02 UTC GNU / Linux
Host: javi-PC
Proc: 4.15.0-30deepin-generic # 31 SMP Ven 30 Nov 2018 04:29:02 GMT GNU / Linux
Distribuzione: 0 '15 .11 "
hp-controllo [15409]: info: bitness: 64 bit

hp-controllo [15409]: info:
hp-controllo [15409]: Info: -----------------------
hp-controllo [15409]: info: HPLIP 😐 CONFIGURAZIONE |
hp-controllo [15409]: Info: -----------------------
hp-controllo [15409]: info:
hp-controllo [15409]: info: HPLIP-Version: 3.16.11 HPLIP
hp-controllo [15409]: info: HPLIP-Home: / usr / share / hplip
Attenzione: HPLIP-installazione: versione di installazione automatica non è supportata per 0 distro "15.11"
hp-controllo [15409]: info:
hp-check[15409]: info: :[01mCurrent contents of 'https://h7f7v6z9.stackpathcdn.com/etc/hp/hplip.conf' file:[0m
hp-controllo [15409]: info: # hplip.conf. Generato da hplip.conf.in dal set.

[HPLIP]
version = 3.16.11

[Eds]
home = / usr / share / hplip
eseguire = / var / run
ppd = / usr / share / PPD / hplip / HP
ppdbase = / usr / share / PPD / hplip
doc = / usr / share / doc / hplip
html = / usr / share / doc / hplip-doc
icon = no
cupsbackend = / usr / lib / cups / backend
cupsFilter = / usr / lib / cups / filter
DRV = / usr / share / cups / drv
bin = / usr / bin
apparmor = / etc / apparmor.d
# seguenti valori sono determinati a al momento della configurazione e non possono essere cambiati.
[Set]
rete-build = yes
libusb01-build = no
pp-build = yes
gui-build = yes
scanner-build = yes
fax-build = yes
dbus-build = yes
cups11-build = no
doc-build = yes
ombra-build = no
hpijs-install = yes
foomatic-DRV-install = yes
foomatic-ppd-install = yes
foomatic-rip-hplip-install = no
hpcups-install = yes
cups-DRV-install = yes
cups-ppd-install = no
interno-tag = 3.16.11
= Non limitata-build
ui-toolkit = QT5
Qt3 = no
qt4 = no
QT5 = yes
politica-kit = yes
lite-build = no
udev_sysfs_rules = no
hpcups-solo-build = no
hpijs-solo-build = no
apparmor_build = no

hp-controllo [15409]: info:
hp-check[15409]: info: :[01mCurrent contents of 'https://h7f7v6z9.stackpathcdn.com/var/lib/hp/hplip.state' file:[0m
hp-controllo [15409]: Info: I plugin non sono installati. Impossibile accedere al file: No such file or directory
hp-controllo [15409]: info:
hp-controllo [15409]: info: [01mCurrent contenuto del file '~ / .hplip / hplip.conf': [0m
hp-controllo [15409]: info: [comandi]
scan = / usr / bin / single-scan% SANE_URI%

[Fax]
email_address =
voice_phone =

[Last_used]
device_uri = "HP: / net / ip = 192.168.1.38 Deskjet_2540_series?"
ÉÖvÅárÖfÅhÄr = Deskjet_2540
Working_dir =.

[Polling]
device_list =
enable = true
Intervallo = 5

[Aggiorna]
enable = true
rate = 30
type = 1

[Impostazioni]
systray_messages = 0
systray_visible = 0

[Aggiornamento]
last_upgraded_time = 1564176737
notify_upgrade = false
pending_upgrade_time = 0

[Installazione]
07/27/19 18:49:41 DATE_TIME =
version = 3.16.11

hp-controllo [15409]: Informazioni: <nome-pacchetto> <pacchetto-disc> <Richiesto / Opzionale> <Min-Version> <installata-Version> <stato> <Commento>
hp-controllo [15409]: info:
hp-controllo [15409]: Info: --------------
hp-controllo [15409]: info: 😐 COMPILEDEP |
hp-controllo [15409]: Info: --------------
hp-controllo [15409]: info:
hp-controllo [15409]: info: make make - GNU make programma di utilità per mantenere gruppi di programmi necessari 3.0 4.1 OK -
hp-controllo [15409]: info :: [31; errore di 01m: libtool libtool - servizi di supporto edificio libreria richiesta - - MISSING libtool deve essere installato '[0m
hp-controllo [15409]: info: gcc gcc - Progetto GNU C e C ++ Compiler RICHIESTO - 6.3.0 OK -
hp-controllo [15409]: info:
hp-controllo [15409]: Info: ---------------------
hp-controllo [15409]: info: Python 😐 Extentions |
hp-controllo [15409]: Info: ---------------------
hp-controllo [15409]: info:
hp-controllo [15409]: info: hpmudext IO-interno desiderato - 3.16.11 OK -
hp-controllo [15409]: info: cupsext CUPS-interno desiderato - 3.16.11 OK -
hp-controllo [15409]: info:
hp-controllo [15409]: Info: ----------------------
hp-controllo [15409]: info: 😐 configurazione di scansione |
hp-controllo [15409]: Info: ----------------------
hp-controllo [15409]: info:
hp-check[15409]: info: :'https://h7f7v6z9.stackpathcdn.com/etc/sane.d/dll.d/hpaio' not found.
hp-controllo [15409]: info: hpaio HPLIP-SANE-backend RICHIESTO - 3.16.11 OK 'hpaio trovato in /etc/sane.d/dll.conf'
hp-controllo [15409]: info: scanext Scan-SANE-Extension RICHIESTO - 3.16.11 OK -
hp-controllo [15409]: info:
hp-controllo [15409]: Info: ------------------------
hp-controllo [15409]: info: Dipendenze generali 😐 |
hp-controllo [15409]: Info: ------------------------
hp-controllo [15409]: info:
hp-controllo [15409]: info: SANE guarire - biblioteca Scansione RICHIESTE - - OK -
hp-controllo [15409]: info: python3-pil pil - Python Imaging Library (riga di comando richiesto per la scansione con HP-scan) OPTIONAL - 1.1.7 OK -
hp-controllo [15409]: info: [31; errore di 01m: libjpeg libjpeg - biblioteca JPEG RICHIESTE - - mancante 'libjpeg deve essere installato' [0m
hp-controllo [15409]: info :: [31; errore di 01m: python3-4- PyQt4 interfaccia PyQT per Python Qt (Qt per la versione 4.x) richiesta 4.0 - MISSING python3-PyQt4 deve essere installato '[0m
hp-controllo [15409]: info: libcrypto libcrypto - OpenSSL libreria crittografica RICHIESTO - 1.1.0 OK -
hp-controllo [15409]: info: librerie XML python3-XML Python richiesto - 2.2.0 OK -
hp-controllo [15409]: info: [31; 01m errore: python3 Python-devel devel - file di sviluppo di Python 2.2 3.5.3 obbligatorio mancante 'python3-devel deve essere installato' [0m
hp-controllo [15409]: info: [31; errore 01M: python3-PyQt4-dbus DBus PyQt 4 - DBus Supporto per PyQt4 OPTIONAL 4.0 - MISSING 'esigenze python3-PyQt4-dbus per essere installato' [0m
hp-controllo [15409]: info: libpthread libpthread - thread POSIX libreria richiesta - b'2.24 'OK -
hp-controllo [15409]: info: python3X Python 2.2 o superiore - linguaggio di programmazione Python 2.2 3.5.3 RICHIESTO OK -
hp-controllo [15409]: Info: CUPS DDK DDK-CUPS - CUPS conducente kit di sviluppo OPTIONAL - - OK -
hp-controllo [15409]: info :: [31; errore 01M: cups-devel CUPS svi- file di sviluppo Common Unix Printing System RICHIESTE - - MISSING tazze-devel deve essere installato '[0m
hp-controllo [15409]: info: [31; 01m errore: libusb libusb - biblioteca USB richiesta - 1.0 mancante 'libusb deve essere installato' [0m
hp-controllo [15409]: info :: [31; errore 01M: sane-devel SANE - Scansione di file di sviluppo libreria richiesta - - MISSING sane-devel deve essere installato '[0m
hp-controllo [15409]: info: python3-ReportLab ReportLab - libreria di PDF per Python 3.3.0 2.0 OPTIONAL OK -
hp-controllo [15409]: info :: [31; errore 01M: libnetsnmp-devel libnetsnmp-devel - SNMP in rete file di sviluppo libreria richiesta 5.0.9 - MISSING libnetsnmp-devel deve essere installato '[0m
hp-controllo [15409]: info: python3-dbus DBus Python - Python per DBus 1.2.4 0.80.0 RICHIESTO OK -
hp-controllo [15409]: info :: [31; errore 01M: cups-immagine immagine CUPS - CUPS file di sviluppo dell'immagine richiesta - - tazze-Immagine mancante deve essere installato '[0m
hp-controllo [15409]: info: python3-Notify2 libnotify Python - Python per le notifiche per il desktop libnotify OPTIONAL - - OK -
hp-controllo [15409]: info:
hp-controllo [15409]: Info: -------------------------
hp-controllo [15409]: info: 😐 Dipendenze esterne |
hp-controllo [15409]: Info: -------------------------
hp-controllo [15409]: info:
hp-controllo [15409]: info :: [31; 01m errore: dbus DBus - sistema bus messaggio desiderato - 1.10.26 manca DBUS non può essere installato o non in esecuzione '[0m
hp-controllo [15409]: info :: [31; errore 01M: avahi-utils avahi-utils OPTIONAL - - MISSING avahi-utils deve essere installato '[0m
hp-controllo [15409]: info: [31; errore di 01m: Xsane Xsane - Interfaccia grafica per scanner SANE 0.9 OPTIONAL - mancante 'xsane deve essere installato' [0m
hp-controllo [15409]: info: [31; 01m errore: scanimage scanimage - programma di scansione OPTIONAL Shell 1.0 - mancante 'scanimage deve essere installato' [0m
hp-controllo [15409]: info: PolicyKit PolicyKit - quadro politico amministrativo OPTIONAL - 0,105 OK -
hp-controllo [15409]: Info: GhostScript gs - PostScript e PDF linguaggio interprete e visualizzatore 7.05 9.26 RICHIESTO OK -
hp-controllo [15409]: info :: [31; errore di 01m: Cups Coppe - Common Unix Printing System RICHIESTO 1.1 - Incompat 'CUPS non può essere installato o non in esecuzione' [0m
hp-controllo [15409]: info: -wget di rete di rete opzionale - 1.18 OK -
hp-controllo [15409]: info:
hp-controllo [15409]: Info: ------------------------------
hp-controllo [15409]: Info: 😐 SCANNER SCOPERTO DISPOSITIVI |
hp-controllo [15409]: Info: ------------------------------
hp-controllo [15409]: info:
hp-controllo [15409]: info:
hp-controllo [15409]: Info: --------------------------
hp-controllo [15409]: Info: 😐 DISPOSITIVI USB SCOPERTE |
hp-controllo [15409]: Info: --------------------------
hp-controllo [15409]: info:
hp-controllo [15409]: info: URI modello di dispositivo
hp-controllo [15409]: info: -------------------------------- -------- --------------
hp-controllo [15409]: info: hp: / usb / Deskjet_2540_series Seri HP Deskjet serie 2540
a = CN4CJ5F03N0604
hp-controllo [15409]: info:
hp-controllo [15409]: Info: ---------------------------------
hp-controllo [15409]: Info: 😐 CUPS stampante installata CODE |
hp-controllo [15409]: Info: ---------------------------------
hp-controllo [15409]: info:
hp-controllo [15409]: info:
hp-controllo [15409]: info: [01mDeskjet_2540 [0m
hp-controllo [15409]: info: [01M ------------ [0m
hp-controllo [15409]: info: Tipo: Stampante
CV-check [15409]: Info: Dispositivo URI: hp: / net / ip = 192.168.1.38 Deskjet_2540_series?
hp-controllo [15409]: info: PPD: /etc/cups/ppd/Deskjet_2540.ppd
hp-controllo [15409]: info: PPD Descrizione: HP Deskjet serie 2540, hpcups 3.16.11
hp-controllo [15409]: info: Stato della stampante: la stampante è inattiva Deskjet_2540. attivato dal luglio 2019 23:14:41 Mon WEST 26
hp-controllo [15409]: info: Stato della comunicazione: Buono
hp-controllo [15409]: info:
hp-controllo [15409]: info: [01mDeskjet_2540_2 [0m
hp-controllo [15409]: info: [01M -------------- [0m
hp-controllo [15409]: info: Tipo: Stampante
hp-controllo [15409]: Info: Dispositivo URI: HP: / USB / Deskjet_2540_series seriali = CN4CJ5F03N0604
hp-controllo [15409]: info: PPD: /etc/cups/ppd/Deskjet_2540_2.ppd
hp-controllo [15409]: info: PPD Descrizione: HP Deskjet serie 2540, hpcups 3.16.11
hp-controllo [15409]: info: Stato della stampante: la stampante è inattiva Deskjet_2540_2. attivato dal luglio 2019 23:38:42 Mon WEST 26
hp-controllo [15409]: info: Stato della comunicazione: Buono
hp-controllo [15409]: info:
hp-controllo [15409]: info:
hp-controllo [15409]: Info: --------------
hp-controllo [15409]: info: PERMESSO 😐 |
hp-controllo [15409]: Info: --------------
hp-controllo [15409]: info:
hp-controllo [15409]: info: USB Deskjet_2540_2 richiesto - - Nodo OK: '/ dev / bus / usb / 001/004' 'root rw- rw- rw- rw- rw- r-- lp' Perm
hp-controllo [15409]: info:
hp-controllo [15409]: Info: -----------
hp-controllo [15409]: info: 😐 SINTESI |
hp-controllo [15409]: Info: -----------
hp-controllo [15409]: info:
hp-controllo [15409]: info: [01mMissing dipendenze richieste [0m
hp-controllo [15409]: info: [01M ----------------------------- [0m
hp-controllo [15409]: Info: Nessuno
hp-controllo [15409]: info:
hp-controllo [15409]: info: [01mMissing Dipendenze opzionali [0m
hp-controllo [15409]: info: [01M ----------------------------- [0m
hp-controllo [15409]: Info: Nessuno

hp-controllo [15409]: info:
hp-controllo [15409]: Info: Errori totali: 15
hp-controllo [15409]: info: Avvertenze totali: 0
hp-controllo [15409]: info:
hp-controllo [15409]: info:
hp-controllo [15409]: info: Fatto.

Risposta
EchedeyLR
registrato
(@Echedeylr)
Registrado: hace 10 meses

membro attivo
Respuestas: 14

@eli

Alguna novedad en la búsqueda de solución. El problema en sí persiste.

Risposta
sarch
Respuestas: 24
registrato
(@sarch)
Integrante Eminente
Registrado: hace 2 años

yo he tenido problemas con una hp tank wireles 415, en arch, debian y elementary no tuve problemas al instalar pero en deepin no me dejo, la impresora esta por wifi, en ninguna hice instalacion por usb

Risposta
Condividi:

Por favor Iniciar Sesión o Registro