SOLUTION, NVIDIA AND EXTERNAL MONITOR - FOR DEEPIN 20.2

SOLUCIÓN NVIDIA
NVIDIA SOLUTION AND EXTERNAL MONITOR

There is a problem when trying to use external monitors on PCs equipped with Nvidia graphics cards. Unfortunately the nvidia drivers They tend to cause problems in the Linux world, and many of us suffer the side effects of Nvidia's decision not to provide access to their drivers, so in this article I will explain the problem I had and the solution to it. Solution for which Pablo collaborated (@ Senpai86), group administrator Deepin in Spanish on Telegram, and a member of the community developer team, Latin Code.

The problem I had when installing Deepin were the dependencies of bumblebee, specifically with a broken dependency "Bbswitch-dkms", so Pablo recompiled a plugin new, which is developed by Deepin, to convert it into a packaged package in format deb for easy installation. It solves this dependency problem.

STEPS TO INSTALL BUMBLEBEE

IMPORTANT: Before being able to obtain the solution to the problem through the commands explained below, it must first be installed Deepines Store

Once installed Deepines Store, entonces procede a abrir una terminal y ejecutar los comandos que se muestran a continuación, ejecútalos en este mismo orden:

sudo apt update && sudo apt install dde-dock-graphics-plugin

Then we will install bumblebee

sudo apt install bumblebee

To apply the changes we will install Deepin Graphic manager, since since version 20 of Deepin does not come pre-installed

sudo apt install deepin-graphics-driver-manager

Now we choose the option bumblebee in the app

SOLUCIÓN NVIDIA
Deepin graphics controller

It is important to restart and follow the steps that will appear. They may already be able to use their external monitor up to this point, if it still doesn't work I'll go on to explain a possible solution to this problem.

SOLUTION TO THE PROBLEM WITH EXTERNAL MONITOR

This is a possible solution that worked for me, before applying these steps, please make a backup.

With the above installation, it should be in the dock the plugin of the graph

plugin to control graphics from the dock

We choose the option of Nvidia, we wait patiently for the change notification to be completed and ask us to log out, however what we must do is restart the computer again.

If you have a problem with any of these steps, we will listen to your comments.

NOTE: If the dock appears on the other monitor and you don't want it to be there, in settings, choose the monitor you want as the main monitor and restart.

5 32 votes
Rate the Article
 
Subscribe
Report of
20 Reacciones
More popular
Newer Older
Opinion from the article
See all comments
Arceli
Arceli (@arceli)
Member
26 días atrás

I had this situation with my second team, I will try later to see how it works, thank you.

Эли
Эли (@eli)
Admin
26 días atrás

Genial colaboración ProgrammingJS y senpai86Thank you very much for providing solutions for the community.

profiler 2.0
profiler 2.0 (@profiler-2-0)
Author
26 días atrás

Thanks for the input, Greetings!!

Luis Serrano
Luis Serrano (@luis-serrano)
Member
26 días atrás

Well, it works very well, thank you all for offering the solution!

jesus david agudelo vallejo
jesus david agudelo vallejo (@jesusdavidagudelovallejo)
Member
25 días atrás

Works like a charm!!! Thank you very much for the prompt help. I already have all the functions I need in Deepin.

Эли
Эли (@eli)
Admin
Respondiendo a  jesus david agudelo vallejo
24 días atrás

Excellent, I'm glad you found it. That is the purpose of these tutorials.

SmileyDrooler
SmileyDrooler (@smileydrooler)
Member
25 días atrás

It has worked perfectly for my setup, thank you very much.

jesus david agudelo vallejo
jesus david agudelo vallejo (@jesusdavidagudelovallejo)
Member
23 días atrás

ProgrammingJS
 
Yes I already made a backup of the system. When reinstalling with the command

sudo apt update && sudo apt install dde-dock-graphics-plugin

same error appears:

"Dpkg: error processing package bbswitch-dkms (–configure):
the thread installed package bbswitch-dkms post-installation script returned error exit code 10
dpkg: dependency issues preventing bumblebee from setting:
bumblebee depends on bbswitch-dkms | bbswitch-source; However:
The package bbswitch-dkms' no está configurado todavía.
El paquete
bbswitch-source 'is not installed'.

How do i install this package?

Car
Car (@car)
Author
Respondiendo a  jesus david agudelo vallejo
22 días atrás

I do not have Nvidia but I join the discussion thread, it is not the dde-dock-graphics-plugin package, the problem is generated by bumblebee and it gives this message. I'll see what else I find out.

Captura de pantalla_área-de-selección_20210414203828.png
Jorge Villegas
Jorge Villegas (@jorgevillegas)
Member
Respondiendo a  jesus david agudelo vallejo
22 días atrás

I have this same problem, I just did a clean installation, and I followed the steps indicated here and I have the same problem as Jesús David

Car
Car (@car)
Author
Respondiendo a  Jorge Villegas
22 días atrás

Jorge Villegas placeholder image I already discovered the problem and I have reported it to deepin. the cause is two badly built debian packages. these are bbswitch-dkms Y pirmus-libs which already have patched versions on debian 10 backports. So first they solve the dpkg problem like this

 sudo rm /var/lib/dpkg/info/bbswitch-dkms.postinst 

Then you have to purge bumblebee and primus like this

sudo apt purge bumblebee primus primus-libs

Then run a

sudo apt autoremove 

Finally download and double-click both packages

https://packages.debian.org/buster-backports/bbswitch-dkms and

 https://packages.debian.org/buster-backports/primus-libs

and we can continue this tutorial.

Эли
Эли (@eli)
Admin
24 días atrás

Luis Serrano Y SmileyDrooler great, I'm glad you found it to follow the steps in the article. Thank you for reporting your experience.

Greetings.

jesus david agudelo vallejo
jesus david agudelo vallejo (@jesusdavidagudelovallejo)
Member
23 días atrás

ProgramacionJS, today I find a problem after following the steps described in this article, which helped me to solve my problem with my external monitor. When executing the command sudo apt upgrade it shows me the following message (Attached image of the terminal)

What can I do to correct this error that appears every time I update the system?

Thanks. Greetings.

error.png
jesus david agudelo vallejo
jesus david agudelo vallejo (@jesusdavidagudelovallejo)
Member
20 días atrás

Car Thank you very much for the collaboration, with your indications I have already fixed the problem. It is a pleasure to have your prompt response and help.
 

Alex Andrade
Alex Andrade (@alex-andrade-30)
Member
20 días atrás

Over here it works very well guys, thanks for the colbaroacion

XOdein
XOdein (@xodein)
Member
18 días atrás

It worked perfectly, thank you very much for the tuto people

Ramon Milian
Ramon Milian (@ramonmilian)
Member
16 días atrás

Excellent tutorial here, thanks for sharing with everyone.

Mauricio Mandaglio
Mauricio Mandaglio (@mauriciomandaglio)
Member
12 días atrás

Very good information !! Thank you so much!

20
0
We would like to know what you think, join the discussion.x
()
x