FORMAT NUMBER AND CURRENCY IN WPS (CORRECTION)

This time I will show the solution of how to correct the number format and currency for Spanish region of Mexico (But should work for other countries if you encojes the correct file) because this little problem lies in the configuration files of language Deepin system.

This problem affects especially the WPS Spreadsheets application (spreadsheet), then typing a number and then apply the format separated by decimal point and thousands separator numbers not successful, ie:

If 1500 is written as 1,500.00 and shows this is not the correct result, as expected 1,500.00

Malformed WPS

SOLUTION:

1. Open a terminal

2. Edit the file / Usr / share / i18n / locales / es_MX (Or your country if you do not live in Mexico) with the following command.

$ sudo gedit /usr/share/i18n/locales/es_MX

LC_MONETARY
int_curr_symbol «<U004D> <U0058> <U004E> <u0020>»
currency_symbol «<U0024>»
mon_decimal_point «<U002E>»
mon_thousands_sep «<U002C>»<- change <u0020> by <U002C>
mon_grouping 3; 3
positive_sign ''
negative_sign «<U002D>»
int_frac_digits 2
frac_digits 2
p_cs_precedes 1
p_sep_by_space 1
n_cs_precedes 1
n_sep_by_space 1
p_sign_posn 1
n_sign_posn 1
END LC_MONETARY

and in this section must also be modified

LC_NUMERIC
decimal_point «<U002E>»
thousands_sep «<u0020>»<- change <u0020> by <U002C>
grouping 3; 3
END LC_NUMERIC

3. Run the following command

$ sudo dpkg-reconfigure locales

We seek and mark (mark with the space bar)

[*] Es_MX.UTF-8 UTF-8

pressed OK

Select es_MX.UTF-8 and press accept

will correct this if:

Generating locales (this might take a while)...
en_US.UTF-8... done
es_ES.UTF-8... done
es_MX.UTF-8... done
Generation complete.

4. To secure that everything will be fine, reboot PC and Spreadsheets WPS function properly as expected.

I hope will be of great help to all new users of Deepin system. This should also apply to other GNU / Linux distributions.

16
What do you think about it?

please Enter to comment
4 Comment threads
12 Responses thread
0 Followers
 
Comment with more reactions
Highly Commended thread
8 Authors comments
LearchmanABadDONXOdeindanny672007RhymeDanger Authors of the most recent comments
subscribe
Newer oldest More popular
Report of
Eli
Publisher

Excellent Avatarppjc72, Thank you very much for sharing the solution with the rest of the community, would you like to publish an article on the main page?

ArtP0
Member

Sorry, I do not serve me, he tells me: sudo: gedit: command not found

XOdein
Member

Seriously ask that? do not see the other answers here? gedit have to install or use nano.

ArtP0
Member

Tells me:
sudo: gedit: command not found
What I do?

RhymeDanger
Member

That's because you have not installed gedit, type:

sudo apt install gedit

ArtP0
Member

Thank you very much for your help, and it succeeds.

danny672007
Member

Posiblemente no tienes gedit, sustituyelo por nano en el comando.

ABadDON
Member

uhm… no me funciono ! soy de Perú y sigo con la configuracion de España.
Alguien que me pueda dar alguna opcion de como arregarlo?
Gracias

Learchman
Member

Acabo de realizar el procedimiento descrito pero veo que todo ya está corregido, así que no tuve que cambiar nada. Gracias.