TERMINAL FÜR ANFÄNGER: Programme installieren APT

Hallo Leute, heute sehen wir das Problem Programme für die Installation mit APT, aber auch aktualisieren, deinstallieren, suchen und einige andere Dinge. Aber lassen Sie uns zuerst Überprüfung einige grundlegende Konzepte, ohne dabei zu tief nicht zu verlängern zu diesem Artikel, einschließlich mir Repository, Paket und System APT.

Paket-Manager: Was es ist und was es tut

Pakete kapseln die Dateien benötigt ein Programm und in einigen Fällen ein einzelnes Paket installiert mehrere Programme zu installieren. Das Paketformat in Deepin verwendete deb. Viele Programme verwenden, um andere Programme auszuführen, so dass das System sieht aus wie eine große Toolbox oder eher einen Workshop voller Werkzeuge, in denen Werkzeuge mit anderen Werkzeugen gebaut werden, lassen Sie sich verwendet eine Analogie Tisch Schneiden Holz, die mit einem Tisch und einem elektrischen Handsäge eingebaut werden, das heißt, dass zu bauen (Installation) eine Tabelle von geschnittenem Holz benötigt wird, um (je), dass es eine Tabelle ist, und eine elektrische Handsäge in der Werkstatt. Dies wäre eine Analogie von Abhängigkeiten der Installation eines Programms sein.

Fortsetzung der Analogie, ein Repository sieht aus wie ein Baumarkt, wo wir die Werkzeuge bekommen wir brauchen und die wir haben, hat das Repository in der Regel mehr Programme als wir die unterschiedlichen Bedürfnisse der Nutzer müssen aber erfüllen, wie zum Beispiel Hardware hat mehr Tools, die jeder individuell benötigt. In den wie Baumärkten hat jedes Repository eine Bestandsaufnahme der alles, was sie zur Verfügung haben, und wenn es ein Repository wir brauchen, ist, können wir ein Repository hinzufügen, das hat, was wir brauchen.

Aber wir müssen dafür sorgen, dass das Repository ist kompatibel; Nach der Analogie von Baumärkten, wie wir in Europa wissen, dass der elektrische Strom ist 220 Volt, aber in den meisten von Amerika ist 110 Volt sowie Steckdosen nicht gleich sind, dann werden die Elektrowerkzeuge der europäischen Baumärkten sind nicht zu zu verbinden kehrt in Amerika und Laster, und wenn der Stecker gezwungen ist, arbeitet ein europäisches Instrument in Amerika wird nicht mit voller Leistung und ein Amerikaner in Europa brennt (Funke). So stellen Sie sicher, dass die Verwahrungs, dass wir zum System hinzuzufügen kompatibel sind.

Es Paketmanager, hat eine Liste aller auf Ihrem Computer installierten Programme auch Sie eine Liste von allem, was in den Repositories haben hinzugefügt, wenn ein Paket installiert wird, wird geprüft, ob Sie bereits alles installiert haben (Abhängigkeiten) erforderlich ist oder wenn Sie benötigen, um zusätzliche Pakete zu installieren, um von den installierten Repositories.

das System Paketverwaltung Deepin wird mit APT, aber es gibt mehr in anderen Distributionen wie Fedora YUM, YaST auf openSUSE und Arch Linux Pacman, die beliebtesten zu nennen.

Schließlich werden wir den Konflikt Paket erwähnen, dass passiert, wenn ein Paket andere deinstallieren Installation muss, dies entspricht, dass aus Platzgründen, ein Werkzeug-Shop zu setzen, müssen Sie nehmen eine andere Platz zu machen. Dies ist der Hauptgrund dafür, dass ein System gebrochen wird, wenn ein Repository hinzugefügt wird, die nicht kompatibel ist, weil viele Programme, dass die Arbeit gut mit anderen, die nicht konzipiert wurde in unserem System, nachdem genug ändert das System nicht mehr funktionierte ersetzt laufen .

OPTIONS APT

Hier sind einige grundlegende Befehle APT und sie sind sehr nützlich.

Updaterepository

sudo apt-Update

Diese Downloads und Updates der Liste der verfügbaren Paket-Repositories installiert.

Install Package

sudo apt install nombre_del_paquete

Dieser Befehl installiert ein Paket, zum Beispiel Sudo apt installieren firefox-latest Mozilla Firefox installiert in der aktuellen Version.

Sie können auch ein Paket, indem Sie die Parameter neu zu installieren -Neuinstallation.

sudo apt install --reinstall nombre_del_paquete

SUCHE PAKET

Eine Möglichkeit ist, starten Sie den Namen des Pakets eingeben und drücken Sie die TAB-Taste zweimal, so dass er alle Pakete zeigt, die mit beginnen, was wir geschrieben haben, zum Beispiel alle Pakete mit Gimp starten.

[email protected]:~$ sudo apt install gimp
gimp                  gimp-gluas            gimp-help-es          gimp-help-ru
gimp-cbmplugs         gimp-gmic             gimp-help-fr          gimp-help-sl
gimp-data             gimp-gutenprint       gimp-help-it          gimp-help-sv
gimp-data-extras      gimp-help-ca          gimp-help-ja          gimp-lensfun
gimp-dbg              gimp-help-common      gimp-help-ko          gimp-plugin-registry
gimp-dcraw            gimp-help-de          gimp-help-nl          gimp-texturize
gimp-dds              gimp-help-el          gimp-help-nn          gimp-ufraw
gimp-gap              gimp-help-en          gimp-help-pt          
[email protected]:~$ sudo apt install gimp

Wenn zu viele Ergebnisse uns dann fragen, ob wir sie alle zeigen wollen.

[email protected]:~$ sudo apt install firefox
Display all 104 possibilities? (y or n)

Wenn Sie die Y-Taste drücken, ist ja, wenn Sie die N-Taste drücken, ist es nicht. Wenn ja bis zum Ende des Terminalfensters wird die Legende angezeigt werden -mehr- darauf hinweist, dass es mehr Ergebnisse als im Fenster angezeigt werden.

[email protected]:~$ sudo apt install firefox
Display all 104 possibilities? (y or n)
firefoxdriver           firefox-esr-l10n-en-gb  firefox-esr-l10n-id     firefox-esr-l10n-pl
firefox-esr             firefox-esr-l10n-en-za  firefox-esr-l10n-is     firefox-esr-l10n-pt-br
firefox-esr52.9-cn      firefox-esr-l10n-eo     firefox-esr-l10n-it     firefox-esr-l10n-pt-pt
firefox-esr-dev         firefox-esr-l10n-es-ar  firefox-esr-l10n-ja     firefox-esr-l10n-rm
firefox-esr-l10n-ach    firefox-esr-l10n-es-cl  firefox-esr-l10n-ka     firefox-esr-l10n-ro
firefox-esr-l10n-af     firefox-esr-l10n-es-es  firefox-esr-l10n-kab    firefox-esr-l10n-ru
firefox-esr-l10n-all    firefox-esr-l10n-es-mx  firefox-esr-l10n-kk     firefox-esr-l10n-si
firefox-esr-l10n-an     firefox-esr-l10n-et     firefox-esr-l10n-km     firefox-esr-l10n-sk
firefox-esr-l10n-ar     firefox-esr-l10n-eu     firefox-esr-l10n-kn     firefox-esr-l10n-sl
firefox-esr-l10n-as     firefox-esr-l10n-fa     firefox-esr-l10n-ko     firefox-esr-l10n-son
--More--

Sie können durch Drücken der Taste bewegen eingeben oder Leertaste. Drücken Sie die Q-Taste zu beenden.

Eine weitere Möglichkeit für Pakete in APT zu suchen ist die Möglichkeit, SucheZum Beispiel:

apt search firefox

Liste aller Pakete, die den Begriff „firefox“ entsprechen.

Wenn Sie sehen wollen, nur installiert denen Sie die Suche mit dem grep Befehl kombiniert werden.

apt search chrome | grep instal

System-Upgrades

Es gibt zwei Möglichkeiten.

sudo apt upgrade

Diese aktualisierte alles, was installiert ist, aber nicht deinstallieren jedes Paket, dann, wenn das Update-Paket erfordert, dass Sie deinstallieren etwas, wird dieses Paket nicht aktualisiert, aber der Rest selbst. Die andere Option ist mit dem folgenden Befehl.

sudo apt full-upgrade

Diese Option neben aller Aktualisierung installiert ist, deinstallieren Sie alle Pakete notwendig, alle Updates zu installieren, stellt sicher, dass alles auf die neueste Version aus den Repositories installiert vorhanden aktualisiert wird.

Pakete deinstallieren

Wir präsentieren drei Optionen

sudo apt remove paquete

Deinstalliert das Paket aber einige Dateien, wie zum Beispiel Konfigurationsdateien lassen.

sudo apt purge

Mit dieser Option ist das Paket deinstalliert und löschen Sie alle zugehörigen Dateien und versucht, keine Spur von dem Paket zu verlassen installiert wurde.

sudo apt autoremove

Dieser Befehl ist damit verbundene Abhängigkeiten. Wenn ein Paket deinstalliert wird, werden seine Abhängigkeiten nicht deinstalliert. Mit der autoremove Option APT findet alle Pakete, die als Abhängigkeiten installiert wurden, jedoch nicht mehr von anderen Paketen verwendet und automatisch deinstalliert.

ACHTUNG bricht das System

Wenn Sie ein Update ausführen, installieren oder deinstallieren, sollten Sie die Warnungen des Systems beachten. Das Format und die Warnungen Verhalten ist in allen Fällen gleich. Im Folgenden ist ein Beispiel für die Deinstallation wo löschen ein einzelnes Paket die Deinstallation des gesamten Desktop Deepin auslöst; vlc-plugin-Basis auf den ersten Blick nichts zu tun, aber es ist wichtiger, als vermutet.

[email protected]:~$ sudo apt remove vlc-plugin-base 
[sudo] password for usuario: 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  libkf5activitiesstats1 libkf5js5 libkf5khtml-data libkf5kirigami2-5 libkf5parts-data
  libkworkspace5-5 libnotify-bin qml-module-org-kde-kirigami2
Utilice «sudo apt autoremove» para eliminarlos.
Los siguientes paquetes se ELIMINARÁN:
  dde-clipboard dde-control-center dde-daemon dde-kwin dde-session-shell dde-session-ui kio
  kwin-common kwin-x11 libkf5declarative5 libkf5kcmutils5 libkf5khtml-bin libkf5khtml5
  libkf5newstuff5 libkf5newstuffcore5 libkf5notifications5 libkf5parts-plugins libkf5parts5
  libkf5plasma5 libkf5plasmaquick5 libkf5quickaddons5 libkf5wallet-bin libkf5wallet5
  libkscreenlocker5 libkwalletbackend5-5 libkwin4-effect-builtins1 phonon4qt5
  phonon4qt5-backend-vlc plasma-framework qml-module-org-kde-kcm qml-module-org-kde-kconfig
  qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons startdde
  systemsettings vlc-plugin-base
0 actualizados, 0 nuevos se instalarán, 36 para eliminar y 0 no actualizados.
Se liberarán 252 MB después de esta operación.
¿Desea continuar? [S/n] n
Anulado.

Das erste, was zu beachten ist, sorgfältig die Liste der Pakete, die durch den Begriff der Leitung entfernt werden: „Die folgenden Pakete werden ENTFERNT“. Wenn Sie nicht verstehen, was das Deinstallationspaket Liste schon sagt, ist es besser, die N-Taste drücken und dann eingeben um den Vorgang abzubrechen.

Der zweite Test ist der Änderungszähler, in diesem Fall „0 aktualisiert, 0 neu installiert, 36 zu entfernen und 0 nicht aktualisiert“. Dies ist auch ein Indikator dafür, ob die Operation ist das, was wir erwartet haben oder Kontrolle geraten werden.

Es wird auch das Gesamtgewicht der Dateien zu sehen, interessant hinzugefügt werden oder nach der Operation freigegeben werden, im Beispiel „252 MB nach dieser Operation veröffentlicht werden.“

Schließlich, wenn Sie einverstanden sind und verstehen, die Änderungen drücken Sie die S-Taste und eingebenWenn Sie bessere Fragen und drücken Sie die Taste N eingeben um den Vorgang abzubrechen.

Wenn der Vorgang andere Pakete beeinträchtigen nicht bereits installiert ist, funktioniert das System nicht fragen, ob oder nicht fortzusetzen.

Reparatur-Installation

kaputte Pakete zu haben ist, wenn wurde eine Installation aus irgendeinem Grunde unterbrochen oder nicht erfolgreich abgeschlossen, mit dem folgenden Befehl alle ausstehenden Einrichtungen repariert.

sudo apt install --fix-broken

Wenn das, was Sie brauchen, ist das Paket, um neu konfigurieren zu rekonfigurieren, wenn es installiert wurde, verwenden Sie den folgenden Befehl ein.

sudo dpkg-reconfigure paquete

SHOW INFORMATIONEN

alle die Details des Optionspaketes zu sehen ShowMit dem Sie überprüfen Sie die Version, Beschreibung, Größe unter anderem. Der Befehl ist wie folgt.

apt show paquete

Wenn Sie den Schalter -a sehen möchten hinzufügen alle verfügbaren Versionen.

apt show -a paquete

Um zu sehen, eine Liste der Standortdateien von dem Paket installiert die folgenden ausgeführt werden.

dpkg-query -L paquete

Limpar CACHE PAKET

Jedes Mal, wenn ein Paket von einem Repository installiert ist, Sie laden Sie die .deb-Datei entspricht, und in den Ordner / var / cache / apt / archives gespeichert /. Wenn Sie alle Dateien löschen möchten, und dass der Raum freizugeben, führen Sie den folgenden Befehl ein.

sudo apt autoclean

All diese Dateien und deb sind nicht erforderlich, da sie bereits verwendet werden, um die entsprechenden Pakete zu installieren. Sie sind nur dann sinnvoll, wenn Sie die gleichen Pakete neu installieren müssen.

Für Anfänger glauben wir, dass dies mehr als genug ist, obwohl der apt-Befehl mehr Optionen. Ich bemerkte, dass es Programme APT grafisch zu verwenden, unter ihnen ist Synaptische und GDebi, die erste ist, die Pakete auf dem System und in den installierten Repositories zu verwalten, und die zweite die Pakete zu installieren, wenn Sie eine Datei manuell herunterladen. deb. Deepin hat Deepin Manager-Programmpakete (Deepin-deb-installer) kommen preintalado, hat die gleiche Funktion wie GDebi aber mehr vereinfacht und leicht.

SONSTIGE DIESE SERIE

TERMINAL FÜR ANFÄNGER

Dies war der erste Artikel in dieser Serie. Schnell zeigen Tricks und grundlegende Befehle mit dem Terminal auf GNU / Linux zu starten.

TERMINAL FÜR ANFÄNGER: FISH, SHORTCUTS, ALIAS UND MEHR

Das Terminal ist ein sehr nützliches Werkzeug, und seine Verwendung ist fast unausweichlich. Wir erleichtern die Handhabung mit diesen Tricks.

TERMINAL FÜR ANFÄNGER: sudo

Sudo, ein sehr einfacher und sehr einfach Befehl zu verwenden. Es wird verwendet, um Komponenten zu ändern, die das gesamte System und nicht nur die Kontoeinstellungen des Benutzers beeinträchtigt.

Terminal für Newbies: Verwaltung von Ordnern und Dateien

Wie zu kopieren, verschieben, löschen und Dateien und Ordner erstellen.

 

15
¿Qué piensas al respecto?

bitte eingeben Kommentar
5 Kommentar-Threads
10 Responses Gewinde
0 Anhänger
 
Kommentar mit mehr Reaktionen
Sehr empfehlenswert Gewinde
7 Autoren Kommentare
CarXOdeinGjcelis7Juan CarlosJare GMDie Autoren der jüngsten Kommentare
zeichnen
NEUESTE älteste beliebtesten
Bericht des
PedroTirse
Mitglied

Sehr gute Sachen, obwohl es in einigen dieser Befehle schön delve gewesen wäre, zum Beispiel dpkg hat viel Stoff, wo zu schneiden. trotzdem viel Spaß beim Lesen.

Jare GM
Mitglied

Vielen Dank.

Juan Carlos
Mitglied

El tuto dice sudo apt update pero he visto en otros lougares que se debe hacer sudo apt full-upgrade, que es lo mas recomendable?

Juan Carlos
Mitglied

Beantwortet von: Isaías Gätjens MIsa Gätjens M

Diese Option neben aller Aktualisierung installiert ist, deinstallieren Sie alle Pakete notwendig, alle Updates zu installieren, stellt sicher, dass alles auf die neueste Version aus den Repositories installiert vorhanden aktualisiert wird.

Uups Entschuldigung bemerkte nicht, dass Detail, jetzt durch.

Gjcelis7
Mitglied

Grüße, ich weiß, es ist ein Thema, das nicht geht, aber es ist etwas, das ich allein in dieser Distro gewesen, warum Stiefel benötigt nur 2 GB verwenden Fast 300mb? Es gibt einen Grund, weil es nicht weniger setzen sich lassen: /

XOdein
Mitglied

AvatarGjcelis7 Ich habe nicht bemerkt, dass, immer daran denken, können Sie entscheiden, ob Sie Raum erweitert Partitionierung verwenden.

 

Gjcelis7
Mitglied

AvatarXOdein Dann begann ich mir zu denken, dass die am wenigsten, die ich für entweder automatisch oder manuell fragen: /