Error con sudo apt-...
 
Notificaciones
Eliminar todas

[Resuelto] Error con sudo apt-get update  


Facuu Délvaa
Respuestas: 6
Registrado
Iniciante del hilo
(@facuudelvaa)
Integrante Activo
Registrado: hace 1 mes

necesito sus ayudas si serian tan amables, como no pude instalar java me dios 101mil errores y quedaron algunas secuelas ahora cuando busco actualizaciones me dice "la actualización falló" y a traves de los comandos me tira este error

[email protected]:~$ sudo apt-get update
Contraseña
[sudo] password for facu:
Verificación exitosa
Obj:1 http://ftp.debian.org/debian stretch-backports InRelease
Obj:2 http://packages.microsoft.com/repos/edge stable InRelease
Des:3 http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease [15,9 kB]
Err:3 http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease
Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY EA8CACC073C3DB2A
Obj:4 https://community-packages.deepin.com/printer eagle InRelease
Obj:5 https://community-store-packages.deepin.com/appstore eagle InRelease
Leyendo lista de paquetes... Hecho
W: Error de GPG: http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY EA8CACC073C3DB2A
E: El repositorio http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease» no está firmado.
N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.

Respuesta
Etiquetas del Hilo
11 Respuestas
Céssar
Respuestas: 135
Moderador
(@ppjc72)
Integrante Estimado
Registrado: hace 2 años

hola que tal.

simple. Tienes repositorios de ubuntu,etc.etc. y no deberias usarlos es muy problable que te den problemas. Para rapido.

1 Abre una terminal, Ctrl +Alt +t

2. Escribe:sudo nano  /etc/apt/sources.list y solo pon lo siguiente, es decir, solo debes tener esto, como si fueras a reiniciar todo. Lo demas que tienes lo puedes comentar con una almohadilla al inicio de cada linea, o de plano quitas todo y lo dejas como te indico abajo.

## Generated by deepin-installer
deb [by-hash=force] https://community-packages.deepin.com/deepin/ apricot main contrib non-free
#deb-src https://community-packages.deepin.com/deepin/ apricot main contrib non-free

 

3. Presionas Ctrl+O para guardar cambios y despues presionas la tecla enter.

4. Y para salir presionas Ctrl+X

5. Ahora solo utiliza el comando para actualizar, el que habias puesto.  sudo apt-get update

 

Obj:2 https://community-packages.deepin.com/deepin apricot InRelease
Obj:3 https://community-packages.deepin.com/printer eagle InRelease
Obj:1 https://repositorio.deepines.com/pub/deepines/4 stable InRelease
Obj:4 https://cdn-package-store6.deepin.com/appstore eagle InRelease
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Todos los paquetes están actualizados.

Hasta aquí solo lo tienes como si todo no hubiera ocurrido nada.. Todo debería funcionar correctamente.

Suerte.

Respuesta
2 Respuestas
Facuu Délvaa
Registrado
(@facuudelvaa)
Registrado: hace 1 mes

Integrante Activo
Respuestas: 6

@ppjc72  Hola buenas muchas gracias por su ayuda! pero lo intente y me sigue dando el mismo error lo reinicie y todo y nada ? ? ? ? 

 

[sudo] password for facu:
Verificación exitosa
Obj:1 http://packages.microsoft.com/repos/edge stable InRelease
Obj:2 http://ftp.debian.org/debian stretch-backports InRelease
Des:3 http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease [15,9 kB]
Obj:4 https://community-packages.deepin.com/deepin apricot InRelease
Obj:5 https://community-packages.deepin.com/printer eagle InRelease
Obj:6 https://community-store-packages.deepin.com/appstore eagle InRelease
Err:3 http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease
Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY EA8CACC073C3DB2A
Leyendo lista de paquetes... Hecho
W: Error de GPG: http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY EA8CACC073C3DB2A
E: El repositorio http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic InRelease» no está firmado.
N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.

Respuesta
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 2 años

Integrante Prominente
Respuestas: 793

@facuudelvaa

Lo siguiente es un texto que tengo anotado, lo copio y lo pego, porque es un tema frecuente lo de agregar repositorios a Deepin.

Deepin está basado en Debian, pero no es Debian. Los programadores de Deepin han modificado, personalizado y optimizado mucho del código, los cambios son suficientes como para que Deepin no sea compatible con repositorios de Debian.

Deepin tampoco es compatible con repositorios de Ubuntu, incluidos los PPA.

Si usted tiene conocimientos suficientes para revisar el contenido de los repositorio, además de conocer la base de Deepin y puede determinar si el contenido de un repositorio está libre de conflictos con la base de Deepin, si está seguro de que el contenido del repositorio no rompe el sistema, o sea, si usted sabe exactamente lo que está haciendo, usted puede agregar repositorios externos a Deepin bajo su propio riesgo, es más, si tiene esos conocimientos también sabrá como forzar la instalación de repositorios PPA de Ubuntu.

Si usted no tiene los conocimientos necesarios, la regla general es únicamente agregar repositorios que declaren que son compatibles con Deepin.

Agregar un repositorio no compatible con Deepin, tarde o temprano siempre rompe el sistema, puede que no sea de inmediato, puede se sea en la siguiente actualización, puede que se rompa dentro de 3 o más actualizaciones, pero siempre se rompe, frecuentemente en el momento menos indicado.

Como en Ubuntu hay cientos de repositorios, la mayoría PPAs, y se pueden usar en Kubuntu, Lubuntu, Xubuntu, Ubuntu Budgie y en todos los derivados de Ubuntu como Elementary, PopOS, Mint, etc. la gente se ha confiado y tienen la falsa impresión de que uno puede agregar cualquier repositorio que se encuentre en artículos y foros, y todo sigue funcionando bien.

Cuando se salen de la burbuja de Ubuntu siguen son las mismas costumbres, cuando rompen el sistema se chocan con la realidad. Ni Debian, ni Deepin, ni Fedora, ni Centos, ni otras decenas de distribuciones están basadas en Ubuntu y no son compatibles con repositorios de Ubuntu.

El cambio a un repositorio espejo más rápido, para que las instalaciones y actualizaciones sean más rápidas, se hace en el Centro de control→Actualizar→Ajustes de actualización. Se recomienda desactivar el intercambio de espejo inteligente porque no funciona muy bien.

No se recomienda modificar manualmente el archivo /etc/apt/sources.list, la forma recomendad de agregar manualmente un repositorio es agregándolo a la carpeta /etc/apt/sources.list.d/.

Respuesta
Facuu Délvaa
Respuestas: 6
Registrado
Iniciante del hilo
(@facuudelvaa)
Integrante Activo
Registrado: hace 1 mes
WhatsApp Image 2020 12 12 at 21.43.09
Respuesta
4 Respuestas
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1316

@facuudelvaa hola,

¿Para qué utiliza ese repo de linuxuprising? el problema es con ese repo en particular, veo que dice Ubuntu en él, eso ya para empezar es mala señal.

Respuesta
Facuu Délvaa
Registrado
(@facuudelvaa)
Registrado: hace 1 mes

Integrante Activo
Respuestas: 6

@eli eso de cuando estaba intentando instalar java pero no lo logre y me quedo eso ?

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1316

@facuudelvaa obviamente te quedo así porque no es algo para Deepin, debes remover ese repo, no debes usarlo. La manera más fácil para ti es instalar Synaptic.

sudo apt install synaptic

Abre Synaptic entonces ve a Settings (Configuración quizás en Español, no estoy seguro) Después ve a Repositorios y busca ese repo haces clic en él y entonces abajo haces clic en Borrar, después le das OK. y cierra Synaptic.

La próxima vez que hagas sudo apt update no debe darte ese error. Ojalá no se haya roto alguna otra cosa en tu sistema.

Te aconsejaría que escucharas Este Episodio del Podcast para que aprendas sobre porqué no debes usar Repos no diseñados para Deepin.

Saludos. 

Respuesta
Facuu Délvaa
Registrado
(@facuudelvaa)
Registrado: hace 1 mes

Integrante Activo
Respuestas: 6

@eli esta! muchísimas gracias!!

Respuesta
Céssar
Respuestas: 135
Moderador
(@ppjc72)
Integrante Estimado
Registrado: hace 2 años

puedes  mostrar el contenido de tu archivo y poner una pantalla?

Respuesta
2 Respuestas
Facuu Délvaa
Registrado
(@facuudelvaa)
Registrado: hace 1 mes

Integrante Activo
Respuestas: 6

@ppjc72 y eso que sería?

Respuesta
Céssar
Moderador
(@ppjc72)
Registrado: hace 2 años

Integrante Estimado
Respuestas: 135

@facuudelvaa

en mi caso tengo esto, que es lo mismo que debiste haber puesto como lo comenté al principio

Captura de pantalla área de selección 20201214133356
Respuesta
Comparte: