FORMATO DE NÚMERO Y MONEDA EN WPS (CORRECCIÓN)  

Página 1 / 2

Céssar
Respuestas: 54
Moderador
(@ppjc72)
Integrante Confiable
Registrado: hace 12 meses

En esta ocasión mostraré la solución de cómo corregir el formato de número y moneda para el idioma español de la región de México (Pero debe funcionar para otros países si encojes el fichero correcto) pues este pequeño problema reside en los archivos de configuración de idioma del sistema deepin.

Este problema repercute en especial en la aplicación WPS Spreadsheets (hoja de cálculo), pues al escribir un número y después aplicarle el formato de números separados por punto decimal y separación de miles no lo realiza  correctamente, es decir:

Si se escribe 1500 lo muestra como 1.500,00 y este no es el resultado correcto, pues se espera 1,500.00

Formato Correcto en WPS

SOLUCIÓN:

1. Abrir una terminal

2. Editar el archivo  /usr/share/i18n/locales/es_MX (O el de su país si no vive en México) con el siguiente comando.

$ sudo gedit /usr/share/i18n/locales/es_MX

LC_MONETARY
int_curr_symbol "<U004D><U0058><U004E><U0020>"
currency_symbol "<U0024>"
mon_decimal_point "<U002E>"
mon_thousands_sep "<U002C>"         <----- cambiar  <U0020> por <U002C>
mon_grouping 3;3
positive_sign ""
negative_sign "<U002D>"
int_frac_digits 2
frac_digits 2
p_cs_precedes 1
p_sep_by_space 1
n_cs_precedes 1
n_sep_by_space 1
p_sign_posn 1
n_sign_posn 1
END LC_MONETARY

y en este apartado también se debe modificar

LC_NUMERIC
decimal_point "<U002E>"
thousands_sep "<U0020>"                  <----- cambiar  <U0020> por <U002C>
grouping 3;3
END LC_NUMERIC

3. Ejecutamos el siguiente comando

$ sudo dpkg-reconfigure locales

buscamos y marcamos (marcamos con la barra espaciadora)

[*] es_MX.UTF-8 UTF-8

presionamos Aceptar

Seleccionamos es_MX.UTF-8 y presionamos aceptar

saldrá esto si es correcto:

Generating locales (this might take a while)...
en_US.UTF-8... done
es_ES.UTF-8... done
es_MX.UTF-8... done
Generation complete.

4. Para segurar que todo saldrá bien, reiniciamos PC y en WPS Spreadsheets funcionará correctamente como lo esperamos.

Espero sea de gran ayuda para todos los nuevos usuarios del sistema deepin. Esto también debería aplicar para las demás distribuciones GNU/Linux.

Responder
21 Respuestas
Eli
Respuestas: 501
 Eli
Moderador
(@eli)
Integrante Honorable
Registrado: hace 2 años

Excelente @ppjc72, muchas gracias por compartir la solución con el resto de la comunidad, ¿te gustaría publicarlo como un articulo en la pagina principal?

Responder
4 Respuestas
Céssar
Moderador
(@ppjc72)
Registrado: hace 12 meses

Integrante Confiable
Respuestas: 54

si me gustaría.

Responder
Eli
 Eli
Moderador
(@eli)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 501

Muy bien, veo que lo has enviado a la redacción, pronto sera revisado y publicado, gracias por tu colaboración.

Responder
ArtP0
Registrado
(@artp0)
Registrado: hace 5 meses

Integrante Activo
Respuestas: 10

Disculpa, a mí no me sirve, me dice: sudo: gedit: command not found

Responder
XOdein
Registrado
(@xodein)
Registrado: hace 4 meses

Integrante Activo
Respuestas: 13

En serio pregunta eso? no ve las otras respuestas aqui? tiene que instalar gedit or usar nano.

Responder
ArtP0
Respuestas: 10
Registrado
(@artp0)
Integrante Activo
Registrado: hace 5 meses

Me dice:
sudo: gedit: command not found
¿Qué hago?

Responder
3 Respuestas
RhymeDanger
Registrado
(@rhymedanger)
Registrado: hace 1 año

Integrante Eminente
Respuestas: 32

Eso es porque no tiene instalado gedit, tipea:

sudo apt install gedit

Responder
ArtP0
Registrado
(@artp0)
Registrado: hace 5 meses

Integrante Activo
Respuestas: 10

Muchas gracias por su ayuda, ya lo logre.

Responder
danny672007
Registrado
(@danny672007)
Registrado: hace 10 meses

Nuevo(a) Integrante
Respuestas: 4

Posiblemente no tienes gedit, sustituyelo por nano en el comando.

Responder
ABadDON
Respuestas: 3
Registrado
(@abdonandia)
Nuevo(a) Integrante
Registrado: hace 6 meses

uhm... no me funciono ! soy de Perú y sigo con la configuracion de España.
Alguien que me pueda dar alguna opcion de como arregarlo?
Gracias

Responder
4 Respuestas
Céssar
Moderador
(@ppjc72)
Registrado: hace 12 meses

Integrante Confiable
Respuestas: 54

Ejecuta en una terminal $ locales y muestra el resultado

Responder
Céssar
Moderador
(@ppjc72)
Registrado: hace 12 meses

Integrante Confiable
Respuestas: 54

hola que tal, espero poder ayudar nuevamente.

hace unos 10 minutos terminé de configurar una nueva pc con el mismo problema, y todo funcionó perfectamente.

 

Otro caso es el mio (en mi computadora personal), realicé el procedimiento, sin tener resultado. 

Si realizaste el procedimiento al pie de la letra, te recomiendo ahora que crees otro usuario, y ahi debería funcionarte. Fijense como quedó en la siguiente pantalla.

DeepinScreenshot 20190625191402

 

Responder
ABadDON
Registrado
(@abdonandia)
Registrado: hace 6 meses

Nuevo(a) Integrante
Respuestas: 3

ok gracias probare...

Responder
ABadDON
Registrado
(@abdonandia)
Registrado: hace 6 meses

Nuevo(a) Integrante
Respuestas: 3

Ahora si todo perfecto gracias !!!

Responder
Learchman
Respuestas: 27
Registrado
(@learchman)
Integrante Eminente
Registrado: hace 7 meses

Acabo de realizar el procedimiento descrito pero veo que todo ya está corregido, así que no tuve que cambiar nada. Gracias.

Responder
1 Responder
Céssar
Moderador
(@ppjc72)
Registrado: hace 12 meses

Integrante Confiable
Respuestas: 54

perfecto.

son dos casos que se pueden presentar.
saludos.

Responder
Página 1 / 2
Comparte:

Por favor Iniciar Sesión o Registro