Notificaciones
Eliminar todas
[ BIENVENIDO  - POR FAVOR LEE LAS REGLAS DE DISCUSIÓN DEL FORO - CLIC AQUÍ - ENCUENTRA O COMPARTE SOLUCIONES ]

RECUERDA, EL FORO NO ES SOLO PARA HACER PREGUNTAS, TAMBIÉN PARA AYUDAR A OTROS SI CONOCES LA SOLUCIÓN

SI EXPERIMENTAS PROBLEMAS DE VISUALIZACIÓN EN EL FORO POR FAVOR LIMPIA EL CACHÉ DE TU NAVEGADOR

[Resuelto] Multiples Monitores


GarVied
Respuestas: 20
Registrado
Iniciante del hilo
(@garvied)
Integrante Eminente
Registrado: hace 3 años

Buenas, tengo instalado Deepin 15.8 y no me detecta un segundo monitor, el 1º (si funciona) esta conectado por HDMI a una Nvidia 1050 y el segundo (no lo detecta) a la gráfica de la placa base Intel i915. xrandr no muestra la 2ª pero lshw -c display si me da información de la 2ª.

En ese mismo equipo tengo instalado Kubuntuy 18.10 y Windows 10 y en ambos funcionan las dos pantallas correctamente

Alguien puede echarme una mano.

Gracias

Respuesta
16 Respuestas
4 Respuestas
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1655
Respondido por: GarVied

Buenas, tengo instalado Deepin 15.8 y no me detecta un segundo monitor, el 1º (si funciona) esta conectado por HDMI a una Nvidia 1050 y el segundo (no lo detecta) a la gráfica de la placa base Intel i915. xrandr no muestra la 2ª pero lshw -c display si me da información de la 2ª.

En ese mismo equipo tengo instalado Kubuntuy 18.10 y Windows 10 y en ambos funcionan las dos pantallas correctamente

Alguien puede echarme una mano.

Gracias

Hmmm te iba a decir que te aseguraras que la salida HDMI de la placa esta habilitada en tus BIOS, pero según dices funciona en otros casos, por lo que esta no debe ser la razón. ¿Estas seguro que no se ha deshabilitado recientemente? ¿Aun puedes usarlo en este mismo momento como cuentas?

Esperemos a ver si otro miembro de la comunidad puede ayudarte al respecto.

Respuesta
Car
 Car
Moderador
(@car)
Registrado: hace 3 años

Integrante Honorable
Respuestas: 721

Que driver estas usando? esa Nvidia requiere el privativo sudo apt install bumblebee primus

 

Respuesta
GarVied
Registrado
(@garvied)
Registrado: hace 3 años

Integrante Eminente
Respuestas: 20

Primero gracias por responder.

Estoy usando los drivers privativos pero también he probado con los libres noveau y el mismo resultado.

La salida HDMI de la placa esta activada

¿Se os ocurre algo que pueda mirar?

Nuevamente gracias

Respuesta
Car
 Car
Moderador
(@car)
Registrado: hace 3 años

Integrante Honorable
Respuestas: 721

Arranca deepin con el segundo monitor encendido  y conectado al HDMI

Respuesta
GarVied
Respuestas: 20
Registrado
Iniciante del hilo
(@garvied)
Integrante Eminente
Registrado: hace 3 años

Gracias por responder.

Siempre arranco con los dos monitores conectados y encendidos, también he probado a encender con el primer monitor apagado y desconectado y en el 2º monitor sigue sin aparecer nada, mi ordenador es un sobremesa no un portátil, por eso no tengo instalado ni prime ni bumblebee sino los drivers normales de nvidia (privativos) la versión 390, en kubuntu tengo la misma versión de los drivers.

El primer monitor es de 23 pulgadas conectado a la tarjeta nvidia y el 2º es de 10 pulgadas conectado a la intel integrada.

Inxi (en kubuntu) en el apartado grafico me muestra

Graphics: Device-1: Intel HD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 390.87
Display: x11 server: X.Org 1.20.1 driver: modesetting,nvidia unloaded:fbdev,nouveau,vesa
resolution: 1920x1080~60Hz, 1024x600~43Hz

inxi (en deepin) en el apartado grafico me muestra

Graphics: Card-1: Intel HD Graphics 630 driver: i915 v: kernel
Card-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 390.67
Display: x11 server: X.Org 1.20.0 driver: modesetting,nvidia unloaded: fbdev,vesa
resolution: 1920x1080~60Hz

xrandr (en kubuntu)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
1920x1080 60.00*+ 59.94 50.00
1680x1050 59.95
1440x900 59.89
1280x1024 60.02
1280x720 60.00 59.94 50.00
1024x768 60.00
800x600 60.32
720x576 50.00
720x480 59.94
640x480 59.94 59.93
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 connected 1024x600+1920+1056 (normal left inverted right x axis y axis) 150mm x 100mm
1024x600 43.07*+
HDMI-1-2 disconnected (normal left inverted right x axis y axis)

xrandr (en deepin)
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
1920x1080 60.00*+ 59.94 50.00
1680x1050 59.95
1440x900 59.89
1280x1024 60.02
1280x720 60.00 59.94 50.00
1024x768 60.00
800x600 60.32
720x576 50.00
720x480 59.94
640x480 59.94 59.93
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

lshw -C display (en kubuntu)
*-display
descripción: VGA compatible controller
producto: GP107 [GeForce GTX 1050 Ti]
fabricante: NVIDIA Corporation
id físico: 0
información del bus: [email protected]:01:00.0
versión: a1
anchura: 64 bits
reloj: 33MHz
capacidades: pm msi pciexpress vga_controller bus_master cap_list rom
configuración: driver=nvidia latency=0
recursos: irq:149 memoria:de000000-deffffff memoria:c0000000-cfffffff memoria:d0000000-d1ffffff ioport:e000(size=128) memoria:c0000-dffff
*-display
descripción: Display controller
producto: HD Graphics 630
fabricante: Intel Corporation
id físico: 2
información del bus: [email protected]:00:02.0
versión: 04
anchura: 64 bits
reloj: 33MHz
capacidades: pciexpress msi pm bus_master cap_list
configuración: driver=i915 latency=0
recursos: irq:140 memoria:dd000000-ddffffff memoria:b0000000-bfffffff ioport:f000(size=64)

lshw -C display (en deepin)
*-display
description: VGA compatible controller
product: GP107 [GeForce GTX 1050 Ti]
vendor: NVIDIA Corporation
physical id: 0
bus info: [email protected]:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:150 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:c0000-dffff
*-display
description: Display controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: [email protected]:00:02.0
version: 04
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm bus_master cap_list
configuration: driver=i915 latency=0
resources: irq:140 memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64)

Como se ve en ambos sistemas es igual excepto en xrandr e inxi que no aparece la segunda pantalla en Deepin,

¿Alguien sabe que puedo hacer?

Gracias

Respuesta
9 Respuestas
Car
 Car
Moderador
(@car)
Registrado: hace 3 años

Integrante Honorable
Respuestas: 721

Instala esto sudo apt install  arandr eso te ofrecera un a interfaz grafica muy potente para manejar las opciones de xrandr con el puedes apagar o encender las pantallas decidir cual sera primaria , etc

Respuesta
GarVied
Registrado
(@garvied)
Registrado: hace 3 años

Integrante Eminente
Respuestas: 20

Muchas gracias, ya conocia arandr pero el problema era que no aparecía el segundo monitor tampoco ahí, al final he conseguido arreglarlo siguiendo las instrucciones de la pagina External HDMI monitor not detected

Respuesta
Car
 Car
Moderador
(@car)
Registrado: hace 3 años

Integrante Honorable
Respuestas: 721

Nos alegramos. tendremos en cuenta el comando si aparece un caso similar.

Respuesta
xary
 xary
Registrado
(@xary)
Registrado: hace 1 año

Integrante Activo
Respuestas: 8

@garvied tengo el mismo problema podrías ayudar me con los pasos que seguiste para solucionarlo te lo agradecería mucho

Respuesta
GarVied
Registrado
(@garvied)
Registrado: hace 3 años

Integrante Eminente
Respuestas: 20

@xary Como pone en la web que indique en una consola ejecuta

xrandr --listproviders

Esto te mostrara las tarjetas de video que tienes instaladas y que detecta el sistema

Provider 0: id: 0x1b8 cap: 0x1, Source Output crtcs: 4 outputs: 4 associated providers: 0 name:NVIDIA-0

(Yo ahora solo uso una tarjeta de video) pero a ti deberían aparecer dos entonces en la consola pon

xrandr --setprovideroutputsource 1 0

Los numeros deben ser los que te ha dado al poner la primera linea que he puesto.

Respuesta
xary
 xary
Registrado
(@xary)
Registrado: hace 1 año

Integrante Activo
Respuestas: 8

@garvied Muchas Gracias por Responder, al poner el primer comando me sale lo siguiente:

Providers: number : 1
Provider 0: id: 0x45 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 3 associated providers: 0 name:modesetting

Tengo una tarjeta grafica de NVIDIA  en congreto la geforce GTX 1050 pero no Tengo los Driver privativos instalados 

me parece que por eso me arrojo el siguiente erro al ingresar el segundo comando 

Could not find provider with index 1

Respuesta
GarVied
Registrado
(@garvied)
Registrado: hace 3 años

Integrante Eminente
Respuestas: 20

@xary ¿Tienes los dos monitores conectados Nvidia o uno a la Nvidia y el otro a la integrada?

Respuesta
xary
 xary
Registrado
(@xary)
Registrado: hace 1 año

Integrante Activo
Respuestas: 8

es un portatil la compu

Respuesta
xary
 xary
Registrado
(@xary)
Registrado: hace 1 año

Integrante Activo
Respuestas: 8

el xrandr me arroja esto
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
1920x1080 60.01*+ 60.01 59.97 59.96 59.93 40.00
1680x1050 59.95 59.88
1600x1024 60.17
1400x1050 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 60.02
1440x900 59.89
1400x900 59.96 59.88
1280x960 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1360x768 59.80 59.96
1280x800 59.99 59.97 59.81 59.91
1152x864 60.00
1280x720 60.00 59.99 59.86 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
800x512 60.17
700x525 59.98
800x450 59.95 59.82
640x512 60.02
720x450 59.89
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
680x384 59.80 59.96
640x400 59.88 59.98
576x432 60.06
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)

Respuesta
xary
Respuestas: 8
 xary
Registrado
(@xary)
Integrante Activo
Registrado: hace 1 año

finalmenten los solucione com este conmando gracias por su ayuda le agradesco mucho

sudo ./NVIDIA.sh

Respuesta
1 Respuesta
JdrashDev
Registrado
(@jdrashdev)
Registrado: hace 5 meses

Nuevo(a) Integrante
Respuestas: 4

@xary Hola, no te sucede que al conectar el segundo monitor se te relentiza el sistema?.

osea derrepente se me pone lento al conectar el segundo monitor a mi lap

Respuesta
Comparte: