FLATPAK, imposible ...
 
Notificaciones
Eliminar todas
[ BIENVENIDO  - POR FAVOR LEE LAS REGLAS DE DISCUSIÓN DEL FORO - CLIC AQUÍ - ENCUENTRA O COMPARTE SOLUCIONES ]

RECUERDA, EL FORO NO ES SOLO PARA HACER PREGUNTAS, TAMBIÉN PARA AYUDAR A OTROS SI CONOCES LA SOLUCIÓN

SI EXPERIMENTAS PROBLEMAS DE VISUALIZACIÓN EN EL FORO POR FAVOR LIMPIA EL CACHÉ DE TU NAVEGADOR

[Resuelto] FLATPAK, imposible de instalar


Juanca
Respuestas: 40
Registrado
Iniciante del hilo
(@juanca)
Integrante Eminente
Registrado: hace 2 meses

Hola, buenas noches, he procedido a instalar "app outlet" ( https://app-outlet.github.io/)   que de paso la recomiendo. Desde esta pagina puedo descargar aplicaciones por snap, image y flatpak.   He probado a instalar flatpak (como paso previo a instalar apps para mi Deepin) y nada siempre me da algún error. He probado dos alternativas según he visto en esta web y en otras webs.

image

2

image

gracias, espero vuestras noticias.

 

Respuesta
20 Respuestas
3 Respuestas
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1446

@juanca, tienes repositorios incorrectos, te recomiendo borrar los repos que tienes en este momento e instalar los correctos, la verdad no tengo ni idea porque está usando los repositorios Panda y los de Deepines 4. Todo eso es incorrecto. 

Por favor diríjase a: https://deepinenespañol.org/velocidad-de-los-repositorios/

Entonces siga todas las instrucciones allí al pie de la letra. Después de seguir aquellos pasos venga aquí de nuevo y muestre el resultado del comando:

cat /etc/apt/sources.list

Saludos.

Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40

@eli

Gracias por responder. ¿Cómo borro los repos, te refieres a las repos que he puesto sobre FLATPAK?. La verdad he puesto estas acciones por lo siguiente. He introducido en la pagina de Flatpak:

image

dentro si pinchas en configurar aparece:

image

elegimos nuestra distro Deepin y nos lleva directamente a las instrucciones:

image

por eso estoy donde estoy, tal vez las instrucciones de FLATPAK (WEB) sean erroneas.

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1446

@juanca No, lo de flatpak no tiene nada que ver con donde está ahora. ¿Ya realizó los pasos que le pedí que hiciera? No me ha mostrado el comando que le pedí ejecutara y me mostrara los resultados aquí.

Todo eso que me muestra no tiene nada que ver con la solución.

Respuesta
Juanca
Respuestas: 40
Registrado
Iniciante del hilo
(@juanca)
Integrante Eminente
Registrado: hace 2 meses

Hola ya he realizado los pasos: 

image

 ciertamente no me da los resultados de la web.

Gracias, espero su lectura.

 

Respuesta
16 Respuestas
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1446

@juanca muy bien, los errores que mostraba arriba deben haber desaparecido ahora y usted debería poder actualizar el sistema normalmente utilizando:

sudo apt update && sudo apt full-upgrade

¿Lo ha intentado?

Saludos.

Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1446

@juanca ahora me doy cuenta después de mirar mejor lo que respondió anteriormente veo que aún tiene el Repositorio Panda, entonces no siguió los pasos que le dije correctamente.

Usted ha agregado repositorios incorrectos a su sistema.

Flatpak está en los repos y no debería haber problema alguno al instalarlo, al menos que por supuesto, como en su caso existen repos incorrectos agregados al sistema y no solo tendrá problemas instalado flatpak sino otras aplicaciones también.

Respuesta
Car
 Car
Moderador
(@car)
Registrado: hace 3 años

Integrante Honorable
Respuestas: 699

@juanca A ver arrancaría por decir que flatpack esta en los repos de deepin y obviamente en todos sus espejos. Cual es el problema??

Captura de pantalla deepin terminal 20210128091641
Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40

@car

hola gracias he respondido en el anterior mensaje

Respuesta
Céssar
Moderador
(@ppjc72)
Registrado: hace 2 años

Integrante Estimado
Respuestas: 145

@juanca

Hola que tal.

Yo sigo viendo que tienes el repositorio de panda, y al parecer ese ya no está en uso. 

Deberia ser apricot, quedaria de la siguiente forma, en mi caso yo en mi archivo /etc/apt/sources.list solo tengo esto. 

## Generated by deepin-installer
deb [by-hash=force] https://community-packages.deepin.com/deepin/ apricot main contrib non-free
#deb-src https://community-packages.deepin.com/deepin/ apricot main contrib non-free

 

Guarda y actualiza y con eso funcionaria.

Suerte. y no dudes en seguir consultando.

 

Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40

@ppjc72  Hola, muchas gracias a los tres, de verdad yo estaba demasiado perdido, ¡qué mala es la ignorancia! con vuestra información y accediendo a variada información de esta pagina parece que va todo bien, me parece increible, os voy a poner algun pantallazo que tal vez no esté perfecto pero creo que ya me he dispuesto a descargar un par de cosas y parece ir bien. Antes intentaba de cada 4 apps 1 sí salía bien y las otras mal.     He podido instalar flatpak.

image
image
image

 De verdad, no conozco a nadie para preguntar y teneros a vosotros...¡qué lujazo!. Gracias.

Respuesta
Car
 Car
Moderador
(@car)
Registrado: hace 3 años

Integrante Honorable
Respuestas: 699

@juanca Amigo tiene un lío en esa sources mire lo invito a unirse a nuestro telegram allí lo arreglamos rápidamente

https://t.me/deepinenespanol

 

Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40

@car

gracias por la invitacion. Acabo de entrar en Telegram "Juanca O.O.". un saludo.

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1446

@juanca se le ha dado la solución a su problema como tres veces ya en este hilo creo, pero se lo voy a dar una vez más paso por paso:

1-) Abra una terminal

2-) En la terminal copie y pegue lo siguiente (Puede copiar fácilmente por medio de hacer clic 3 veces seguidas sobre el texto a continuación):

sudo deepin-editor /etc/apt/sources.list

3-) En la nueva ventana que se abrirá borre todo lo que esté ya esta alli, entonces copie y pegue lo siguiente (Puede copiar fácilmente por medio de hacer clic 3 veces seguidas sobre cada una de las lineas en el texto a continuación):

## Generated by deepin-installer
deb [by-hash=force] https://mirror.deepines.com/deepin/ apricot main contrib non-free
#deb-src https://community-packages.deepin.com/deepin/ apricot main contrib non-free

4-) Entonces cierre esa ventana, al cerrarla le saldrá una ventana pequeña preguntándole si desea guardar los cambios; Diga que "Si" por medio de hacer clic en "Guardar".

5-) Cierre todo lo que tiene abierto.

6-) Abra una terminal nuevamente y escriba:

sudo apt update && sudo apt full-upgrade

Si siguió esos pasos al pie de la letra ya no debía tener más problemas al actualizar o instalar aplicaciones.

Adicionalmente si desea también cambiar a nuestro espejo para la tienda de Deepin, entonces hagalo por medio de este sencillo paso:

Abra una terminal y entonces copie y pegue lo siguiente (Puede copiar fácilmente por medio de hacer clic 3 veces seguidas sobre el texto a continuación):

sudo sed -i "s|^deb  https://community-store-packages.deepin.com/appstore  eagle appstore|#deb  https://community-store-packages.deepin.com/appstore  eagle appstore\ndeb  https://mirror.deepines.com/appstore  apricot appstore|" /etc/apt/sources.list.d/appstore.list

Saludos.

 

Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40

@eli

tras el paso 2:

image
Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1446

@juanca, disculpe, no lo escribí correctamente (ya lo he arreglado) lo correcto seria:

sudo deepin-editor /etc/apt/sources.list

Saludos.

Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40

@eli   Gracias accedí con nano ahora he probado con deepin-editor va bien también (no lo conocía). Si no es mucha molestia, dado que el último paso se me resiste podrías enviarme pantallazo de qué es lo que tu vez tras "

sudo deepin-editor /etc/apt/sources.list" para así yo ponerlo igualito. Gracias.

Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40

ahora sí:

image

el último paso con eagle se me resiste...

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1446

@juanca le vuelvo a repetir lo mismo que le dije en mi primer mensaje en ese hilo, siga las instrucciones las cuales están muy claramente delineadas en:

https://deepinenespañol.org/velocidad-de-los-repositorios/

Si después de seguir todo eso, aún le da errores, lo siento, pero mi conocimiento llega hasta ahí.

Aparte no es necesario que cambie el repositorio de la tienda, eso es opcional, lo puede dejar como esta ya.

Respuesta
Juanca
Registrado
(@juanca)
Registrado: hace 2 meses

Integrante Eminente
Respuestas: 40

@eli

Ahora creo que sí lo tengo perfecto, muchísimas gracias por su tiempo y paciencia: Antes de preguntar debí de ver la Post-instalación que está muy detallada y aunque aún así no lo habría hecho a la primera me habría venido muy bien pero francamente no tenía ni idea de repositorios, nano, cat ni nada de nada...

image

 Gracias una vez más.

Respuesta
Comparte: