Corregir el error d...
 
Notificaciones
Eliminar todas

Corregir el error de actualización de Deepin 20 1001  

Página 4 / 4

Fernando
Respuestas: 21
Registrado
(@fds75j)
Integrante Eminente
Registrado: hace 1 mes

Hola, pido ayuda porque tengo el problema de fallo al actualizar y no me funcionan los métodos expuestos. Gracias de antemano.

Respuesta
7 Respuestas
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1121

@fds75j si está seguro que siguió la guía al pie de la letra y no le funciono la verdad no veo otra cosa que pueda hacer que borrar directamente el repo de los printers.

Instale Synaptic y busque la pestaña de "Repositorios" entonces una vez allí busque el repo Eagle de los printers y bórrelo, entonces haga nuevamente sudo apt update.

Respuesta
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 732

@eli

El problema no es el repositorio de impresoras, sino un repositorio de Ubuntu que agregó.

Respuesta
Эли
Admin
(@eli)
Registrado: hace 3 años

Integrante Admirado
Respuestas: 1121

@igatjens hola, tienes toda la razón, no mire bien los mensajes de error en sus tomas de pantalla, yo no debería responder más mensajes cuando estoy cansado o apurado. 🤣 

Saludos.

Respuesta
Fernando
Registrado
(@fds75j)
Registrado: hace 1 mes

Integrante Eminente
Respuestas: 21

@eli Sus respuestas siempre son agradecidas, pues para los usuarios que tenemos menos conocimientos son de vital apoyo y nos sirven de mucha orientación. Muchas gracias.

Respuesta
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 732

@eli

Descanse buen hombre, usted hace todo lo humanamente posible, pero uno no puede hacer todo todo el tiempo. Descanse por que si uno no descansa termina loco y enfermo.

Respuesta
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 732

@fds75j

Hola, la causa de su problema es el repositorio de java para Ubuntu que usted agregó.

Captura de pantalla área de selección 20201013195647

Borre este repositorio con el siguiente comando.

sudo rm /etc/apt/sources.list.d/java-8-deepin.list

 

Lo siguiente es un texto que tengo anotado, lo copio y lo pego, porque es un tema frecuente lo de agregar repositorios a Deepin.

Deepin está basado en Debian, pero no es Debian. Los programadores de Deepin han modificado, personalizado y optimizado mucho del código, los cambios son suficientes como para que Deepin no sea compatible con repositorios de Debian.

Deepin tampoco es compatible con repositorios de Ubuntu, incluidos los PPA.

Si usted tiene conocimientos suficientes para revisar el contenido de los repositorio, además de conocer la base de Deepin y puede determinar si el contenido de un repositorio está libre de conflictos con la base de Deepin, si está seguro de que el contenido del repositorio no rompe el sistema, o sea, si usted sabe exactamente lo que está haciendo, usted puede agregar repositorios externos a Deepin bajo su propio riesgo, es más, si tiene esos conocimientos también sabrá como forzar la instalación de repositorios PPA de Ubuntu.

Si usted no tiene los conocimientos necesarios, la regla general es únicamente agregar repositorios que declaren que son compatibles con Deepin.

Agregar un repositorio no compatible con Deepin, tarde o temprano siempre rompe el sistema, puede que no sea de inmediato, puede se sea en la siguiente actualización, puede que se rompa dentro de 3 o más actualizaciones, pero siempre se rompe, frecuentemente en el momento menos indicado.

Como en Ubuntu hay cientos de repositorios, la mayoría PPAs, y se pueden usar en Kubuntu, Lubuntu, Xubuntu, Ubuntu Budgie y en todos los derivados de Ubuntu como Elementary, PopOS, Mint, etc. la gente se ha confiado y tienen la falsa impresión de que uno puede agregar cualquier repositorio que se encuentre en artículos y foros, y todo sigue funcionando bien.

Cuando se salen de la burbuja de Ubuntu siguen son las mismas costumbres, cuando rompen el sistema se chocan con la realidad. Ni Debian, ni Deepin, ni Fedora, ni Centos, ni otras decenas de distribuciones están basadas en Ubuntu y no son compatibles con repositorios de Ubuntu.

El cambio a un repositorio espejo más rápido, para que las instalaciones y actualizaciones sean más rápidas, se hace en el Centro de control→Actualizar→Ajustes de actualización. Se recomienda desactivar el intercambio de espejo inteligente porque no funciona muy bien.

No se recomienda modificar manualmente el archivo /etc/apt/sources.list, la forma recomendad de agregar manualmente un repositorio es agregándolo a la carpeta /etc/apt/sources.list.d/.

Respuesta
Fernando
Registrado
(@fds75j)
Registrado: hace 1 mes

Integrante Eminente
Respuestas: 21

@igatjens Muchas gracias, efectivamente ahí estaba el error, además pensaba que Deepin era totalmente compatible con los repositorios Debian.

Screen Capture dde control center 20201014143113
Screen Capture deepin terminal 20201014144235
Respuesta
Martin Hacthoun
Respuestas: 8
Registrado
(@martinhacthoun)
Integrante Activo
Registrado: hace 1 semana

Buen día, Isaías por mantener este foro de ayuda, y a Fernando y otros linuxeros -o deepineros- que comparten sus experiencia. Soy cubano y uso Linux desde hace 12 años, y ahora, debuto con Deepin, y me sorprendió los errores de actualización que da. Los errores que confronto NO son los que han abordado acá. Les pego a continuación mi configuración del /etc/apt/sources.list y a continuación los errores que me alerta la terminal, específicamente me advierte que el repo no tiene fichero de publicación y que no puede darle la mano porque recibió un paquete TLS inesperado… Por favor, si uno de Uds. pudiera evaluar el error y compartir una solución se lo agradezco, me gustaría continuar con esta experiencia del Deepin.
Muchas Gracias

CONFIGURACIÓN DE /etc/apt/sources.list

## Generated by deepin-installer
#deb [by-hash=force] https://community-packages.deepin.com/deepin/ apricot main contrib non-free
deb [by-hash=force] https://mirror.deepines.com/testing/deepin-20-beta/ apricot main contrib non-free
#deb-src https://community-packages.deepin.com/deepin/ apricot main contrib non-free

– – – – –

ERROR QUE DA LA TERMINAL
[email protected]:~$ sudo apt update
Ign:1 https://mirror.deepines.com/testing/deepin-20-beta apricot InRelease
Ign:2 https://mirror.deepines.com/testing/appstore eagle InRelease
Err:3 https://mirror.deepines.com/testing/deepin-20-beta apricot Release
Could not handshake: An unexpected TLS packet was received. [IP: 181.225.231.140 1080]
Err:5 https://mirror.deepines.com/testing/appstore eagle Release
Could not handshake: An unexpected TLS packet was received. [IP: 181.225.231.140 1080]
Obj:4 http://uos-packages.deepin.com/printer eagle InRelease
Leyendo lista de paquetes… Hecho
E: El repositorio https://mirror.deepines.com/testing/deepin-20-beta apricot Release» no tiene un fichero de Publicación.

Respuesta
9 Respuestas
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 732

@martinhacthoun

Hola, me parece que es un error de comunicación de red, o sea, que algo está interrumpiendo o bloqueando la conexión de red en Internet. Puede ser solo un error temporal de red o puede ser algún error temporal en el servidor.

Es posible que si intenta después, el error desaparezca. Acabo de probar la conexión con el mirror de deepines.com y no me da ningún error.

Respecto a la configuración del repositorio, está correcta, no contiene errores. Por favor inténtelo de nuevo y nos avisa si el error continúa.

Respuesta
Luis Vicente Castillo Corbella
(@luis-vicente-castillo-corbella)
Registrado: hace 2 años

Integrante Confiable
Respuestas: 64

@igatjens Los repositorios funcionan, y en un nuevo intento lograrás actualizar, y allí quedo porque la siguente actualización será de aqui a medio año, este proyecto avanza excesivamente lento, parece que los creadores no publican actualizaciones o no tienen nada que corregir.

Respuesta
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 732

@luis-vicente-castillo-corbella

Tome en cuenta que además de Deepin 20, el equipo de desarrollo mantiene UOS PersonalUOS Professional, UOS Enterprise, UOS Server y UOS Euler, así que de mantener 2 distribuciones, pasaron a mantener 6. Y además de eso están coordinando con muchos desarrolladores y fabricantes para integrar software y hardware a UOS y a Deepin. También tienen que colaborar con los nuevos centros de capacitación, soporte y atención al cliente. Es importante tener eso presente.

Si quiere estar al tanto de la actividades que están realizando, le recomiendo vigilar las noticias de Tongxin Software (Union Tech es el nombre occidental) - uniontech.com/news -.

En el sitio web hay una serie de 3 artículos que explican la situación de Deepin en el último año.

https://deepinenespañol.org/?s=que+esta+pasando+con+deepin

Respuesta
Martin Hacthoun
Registrado
(@martinhacthoun)
Registrado: hace 1 semana

Integrante Activo
Respuestas: 8

@igatjens

Buen día, Isaías. Muchas gracias por su gentil y solidaria respuesta. En eso precisamente estaba pensando, pues mi conexión a Internet es a través de un proxy, y también durante la instalación el instalador me preguntó para verificar mi conexión, pero no me dio variante para establecer el proxy en ese momento. En otras distribuciones de linux que he utilizado, me veo obligado a configrar el proxy en la terminal una vez instalda la distro. Hice lo mismo con el Deepin. Ahora no sé si quedó bien. Utilicé la misma variante de Debian Mate, Linux Mint, Neon KDE y MX Linux.

¿Tienes alguna sugerencia para el Deepin?

Muchas Gracias

Respuesta
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 732

@martinhacthoun

Con proxys prácticamente no tengo experiencia, sí sé que son en teoría, pero poca más. Lo que sé es que los proxy y apt no son muy amigos, en Deepin 20, en el Centro de control hay una sección de proxy de aplicaciones pero no sé si funciona para permitir el uso de apt.

image

Puede probar si configurando le proxy para aplicaciones funciona apt. Creo que el proxy es el obstáculo en su caso. También puede probar el siguiente procedimiento, que usaban en Deepin 15 y supongo que aún funciona.

Configurar proxy para APT

 

Cuando nos encontramos detrás de un servidor proxy, puede volverse un poco engorroso utilizar programas como Apt. Aqui os dejo una forma sencilla de configurar nuestro proxy para apt:

 

  1. Editaremos el siguiente archivo /etc/bash.bashrc como root

 

sudo nano  /etc/bash.bashrc

 

  1. Pondremos las siguientes líneas al final de este archivo, modificandolas con nuestros datos de conexión

 

export HTTP_PROXY= http://username:[email protected]:port/

export FTP_PROXY= http://username:[email protected]:port/

  1. Luego creamos el archivo Proxy dentro de /etc/apt/apt.conf.d/

 

sudo nano /etc/apt/apt.conf.d/proxy

 

  1. Y agregamos las siguientes líneas modificandolas con nuestros datos

 

Acquire::http::Proxy "http://usuario:[email protected]_del_proxy:puerto";

Acquire::ftp::Proxy "ftp://usuario:[email protected]_del_proxy:puerto";

Con esto, ya debería funcionar nuestro APT para instalar y actualizar apps detrás de un servidor proxy.

 

Agradecimientos a Armando por facilitar la información.

Armando es un colaborador de Cuba. Por favor nos informa cómo le fue.

Saludos.

Respuesta
Martin Hacthoun
Registrado
(@martinhacthoun)
Registrado: hace 1 semana

Integrante Activo
Respuestas: 8

@igatjens,

Muchas gracias, Isaís. Ahora estoy en la oficina. Una vez en casa dedicaré un tiempo para con calma seguir esta sugerencia. Me alegra que tengas un colaborador cubano. Acá la comunidad de linuxeros está creciendo por días, claro, más entre los profesionales y técnicos de la informática. Saludos, extendidos a Armando. Ya les diré cómo me fue.

Respuesta
Martin Hacthoun
Registrado
(@martinhacthoun)
Registrado: hace 1 semana

Integrante Activo
Respuestas: 8

@igatjens

Isaís, buen día. Bueno, lamento, compartir que el problema continúa y ejecuté la orientación al pie de la letra, con esmero cuidado. Te pego abajo el error que sigue dando. Mañana me llevo la laptop para una zona de wi fi, o en la oficina que tenemos wi fi intentaré actualizar el software. Ya te diré.

Muchas gracias por el solidario gesto de ayudarme...

Martin

Respuesta
Isaías Gätjens M
Moderador
(@igatjens)
Registrado: hace 2 años

Integrante Honorable
Respuestas: 732

OK, que mal que nos se solucionó el problema, luego nos cuenta cómo le fue o si encontró alguna solución. Saludos.

Respuesta
Martin Hacthoun
Registrado
(@martinhacthoun)
Registrado: hace 1 semana

Integrante Activo
Respuestas: 8

@igatjens

   Isaías, buenas noches. Bueno, desde el Wi Fi en la oficina, quitando el proxy, y deshabilitando la configuración del proxy en APT, logré que se actualizara hace un rato todo el sistema e incluso logré que la App Store me instalara varias app que necesito para el trabajo. Claro, desde la casa, como ahora, con el  proxy, sigue dando el mismo, nada de conexión al repo deepines. Pero, nada, desde Wi Fi ya comprobé que lo puedo hacer.

   Ahora, luego de la actualizción el clic derecho del mouthpad dejó de funcionar; no así desde un mouth. Un deepinero en el foro comentó que logró reparar ese bug "remapeando los botones"... ¿Cómo se hace eso?

Muchas gracias por tu atención y apoyo.

Martin

 

 

Respuesta
Martin Hacthoun
Respuestas: 8
Registrado
(@martinhacthoun)
Integrante Activo
Registrado: hace 1 semana

Isaís,

   Este es el error que me sigue dando:

[email protected]:~$ sudo apt update
Ign:1 https://mirror.deepines.com/testing/deepin-20-beta apricot InRelease
Ign:2 https://mirror.deepines.com/testing/appstore eagle InRelease
Err:3 https://mirror.deepines.com/testing/deepin-20-beta apricot Release
Could not handshake: An unexpected TLS packet was received. [IP: 181.225.231.140 1080]
Err:4 https://mirror.deepines.com/testing/appstore eagle Release
Could not handshake: An unexpected TLS packet was received. [IP: 181.225.231.140 1080]
Obj:5 http://uos-packages.deepin.com/printer eagle InRelease
Leyendo lista de paquetes... Hecho
E: El repositorio https://mirror.deepines.com/testing/deepin-20-beta apricot Release» no tiene un fichero de Publicación.
N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
E: El repositorio https://mirror.deepines.com/testing/appstore eagle Release» no tiene un fichero de Publicación.
N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.

Reitero mi agradecimiento, y en el Centro de Control configuré el ambiente del proxy correctamente.

Respuesta
Página 4 / 4
Comparte: