Notificaciones
Eliminar todas

[Resuelto] Ayuda, comandos para instalar el flatpack  


HENRY GARCIA M.
Respuestas: 10
Registrado
(@henrygarciam)
Integrante Activo
Registrado: hace 2 años

ayuda, acabo de instalar deepin 115.10, y no me dan los comandos para instalar el flatpack;

[email protected]:~$ sudo apt install flatpak
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
flatpak ya está en su versión más reciente (0.8.9-0+deb9u1).
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 1 no actualizados.
[email protected]:~$ sudo apt install gnome-software-plugin-flatpak
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
gnome-software-plugin-flatpak ya está en su versión más reciente (3.22.5-1).
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 1 no actualizados.
[email protected]:~$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
[email protected]:~$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
[email protected]:~$ flatpak list
[email protected]:~$

Respuesta
15 Respuestas
7 Respuestas
HENRY GARCIA M.
Registrado
(@henrygarciam)
Registrado: hace 2 años

Integrante Activo
Respuestas: 10

[email protected]:~$ sudo add-apt-repository ppa:alexlarsson/flatpak
Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 95, in
sp = SoftwareProperties(options=options)
File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
self.reload_sourceslist()
File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
self.distro.get_sources(self.sourceslist)
File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in get_sources
(self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Deepin/stable
[email protected]:~$

Respuesta
Эли
Moderador
(@eli)
Registrado: hace 2 años

Integrante Prominente
Respuestas: 766

El tutorial al cual usted respondio y estaba siguiendo creo que ya esta obsoleto, para instalar flatpak en deepin, por favor trate los siguientes comandos en este mismo orden:

 

sudo apt update && sudo apt install flatpak

sudo apt install gnome-software-plugin-flatpak

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

 

Después de esto debería estar listo para instalar aplicaciones Flatpak en Deepin 15.11.

Respuesta
HENRY GARCIA M.
Registrado
(@henrygarciam)
Registrado: hace 2 años

Integrante Activo
Respuestas: 10

Pasa lo mismo....nada

[email protected]:~$ sudo apt update && sudo apt install flatpak
[sudo] password for usuario:
Obj:1 https://deb.opera.com/opera-stable stable InRelease
Obj:2 http://packages.microsoft.com/repos/vscode stable InRelease
Obj:3 https://packages.microsoft.com/ubuntu/19.10/prod eoan InRelease
Des:4 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease [1.306 B]
Err:4 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease
Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 03C3AD3A7F068E5D
Obj:5 http://packages.deepin.com/deepin lion InRelease
Leyendo lista de paquetes... Hecho
W: Error de GPG: https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 03C3AD3A7F068E5D
E: El repositorio « https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease» no está firmado.
N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
[email protected]:~$ udo apt install gnome-software-plugin-flatpak
bash: udo: no se encontró la orden
[email protected]:~$ sudo apt install gnome-software-plugin-flatpak
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
gnome-software-plugin-flatpak ya está en su versión más reciente (3.22.5-1).
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 1 no actualizados.
[email protected]:~$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
br />[email protected]:~$
[email protected]:~$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
br />[email protected]:~$

 

Respuesta
Эли
Moderador
(@eli)
Registrado: hace 2 años

Integrante Prominente
Respuestas: 766

@henrygarciam acabé de instalar Flatpak en una instalación limpia de deepin y se instaló todo sin problemas siguiendo los comandos que le mostré arriba.

El mensaje ultimo que usted mostró dice que usted ya tiene la versión de Flatpak mas reciente instalada,  no entiendo, ¿cual es el problema? Los mensajes que usted ve en la terminal no tienen nada que ver con Flatpak, son debido a repositorios que usted ha instalado y que no son para deepin.

Tenga en cuenta que deepin no es Ubuntu, no puede usar repos de Ubuntu en deepin. Lea todos esos mensajes con detenimiento. cual programa especifico Flatpak esta buscando instalar?

 Saludos.

 

Respuesta
HENRY GARCIA M.
Registrado
(@henrygarciam)
Registrado: hace 2 años

Integrante Activo
Respuestas: 10

Pues, esperaba que mostrara una lista de programas que se pudieran instalar, pero abro el flatpack y no hay nada.

 

Respuesta
Эли
Moderador
(@eli)
Registrado: hace 2 años

Integrante Prominente
Respuestas: 766

@henrygarciam creo que esta confundido sobre como funciona el instalado de aplicaciones de Flatpak, para una lista de aplicaciones Flatpak disponibles para instalación y los comandos apropiados para instalarlas y abrirlas por primera vez por favor visite:

https://flathub.org/apps

Las aplicaciones Flatpak, así como las Snaps y AppImages no son parte de la tienda y no aparecen alistadas de la manera que usted las espera.

También tenga en cuenta que una vez instalado Flatpak usted necesita hacer un re-inicio de su sistema antes de poder instalar y correr aplicaciones Flatpak.

Saludos.

 

Respuesta
HENRY GARCIA M.
Registrado
(@henrygarciam)
Registrado: hace 2 años

Integrante Activo
Respuestas: 10

por ejemplo necesito instalar el GIMP.

Respuesta
HENRY GARCIA M.
Respuestas: 10
Registrado
(@henrygarciam)
Integrante Activo
Registrado: hace 2 años

mira lo que me sale al tratar de instalar el GIMP.

DeepinScreenshot 20200403223735

 

Respuesta
3 Respuestas
Эли
Moderador
(@eli)
Registrado: hace 2 años

Integrante Prominente
Respuestas: 766

@henrygarciam no use el botón "Instalar" para instalar aplicaciones Flatpak en deepin, use los comandos en su lugar:

flatpak install flathub org.gimp.GIMP

flatpak run org.gimp.GIMP

Después Gimp aparecerá en su menú de aplicaciones como todas las demás, cada aplicación en Flathub tiene los comandos correspondientes, ese botón de instalar no funciona en todas las distribuciones.

 

Respuesta
HENRY GARCIA M.
Registrado
(@henrygarciam)
Registrado: hace 2 años

Integrante Activo
Respuestas: 10

Muchas gracias por responder, agradezco mucho la colaboración que me presta, mañana lo intentaré de nuevo.

Respuesta
HENRY GARCIA M.
Registrado
(@henrygarciam)
Registrado: hace 2 años

Integrante Activo
Respuestas: 10

[email protected]:~$ flatpak install flathub org.gimp.GIMP
error: GPG verification enabled, but no summary signatures found (use gpg-verify-summary=false in remote config to disable)
[email protected]:~$ sudo flatpak install flathub org.gimp.GIMP
[sudo] password for usuario:
error: GPG verification enabled, but no summary signatures found (use gpg-verify-summary=false in remote config to disable)
[email protected]:~$

 

Respuesta
Nicolas Smiriglia
Respuestas: 18
Registrado
(@nicolassmiriglia)
Integrante Activo
Registrado: hace 1 año

hola instale flatpak sin problema instale fondo y el problema que tengo es que no aparece en menu tengo que ir al software flatpak y abrirlo de ahi

 

Respuesta
2 Respuestas
Nicolas Smiriglia
Registrado
(@nicolassmiriglia)
Registrado: hace 1 año

Integrante Activo
Respuestas: 18

al reiniciarlo aparece en menu

Respuesta
Martin Valladares
Registrado
(@mvalladares2006)
Registrado: hace 3 meses

Integrante Activo
Respuestas: 6

@nicolassmiriglia eso pasa en deepin muchas veces, tienes que salir, cuando ingreses nuevamente ya sale en el menu.

 

Respuesta
Isaías Gätjens M
Respuestas: 404
Moderador
(@igatjens)
Integrante de Alta Reputacion
Registrado: hace 2 años

@henrygarciam

Hola, instalar aplicaciones con flatpack es muy sencillo, la complicación se da cuando suponen que tiene que instalar con una aplicación tipo tienda, cuando es mucho más fácil usarlo como se a diseñado, usando la terminal y copiando y pegando los comandos correspondientes.

Pero primero hay que arreglar el problema del repositorio de Mega, eso es porque a Mega se le venció la firma del repositorio y hay que poner la nueva firma. Ellos lo anunciaron en su blog - https://mega.nz/blog_55 .

Copie, peque y ejecute el siguiente comando en la terminal

 

sudo apt install curl && curl -fsSL "https://mega.nz/keys/MEGA_signing.key" | sudo apt-key add - && sudo apt update

 

Ahora continuando con flatpack, el principal catálogo de aplicaciones de flatpack es https://flathub.org/ , abra flathub y busque la aplicación.

Si aún no ha configurado flathub, en todas las aplicaciones hay un enlace a las instrucciones de instalación, para Deepin corresponden la instrucciones para Debian.

 

DeepinScreenshot Seleccionar área 20200404210056

 

Las instrucciones están en inglés pero puede usar Google Translate para traducirlas - https://flatpak.org/setup/Debian/

DeepinScreenshot Seleccionar área 20200404210312

Se indica que ejecute los comandos como root, por eso hay que usar sudo, luego el paso 2 sólo se aplica si se usa GNOME, pero Deepin no lo usa, así que solo hay que hacer los pasos 1, 3 y 4.

sudo apt install flatpak

sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Luego reiniciar la computadora.

 

Ahora ya está listo para instalar las aplicaciones flatpack, busca la aplicación en https://flathub.org, va la final de la página, copia, pega y ejecuta el comando de instalación de la aplicación.

 

DeepinScreenshot Seleccionar área 20200404210955
DeepinScreenshot Seleccionar área 20200404211037

 

En este caso el comando de instalación de GIMP es

 

flatpak install flathub org.gimp.GIMP

 

Personalmente prefiero usar la versión de GIMP que no es flatpack, flatpack por su naturaleza de aplicación encapsulada a veces tiene problemas para integrarse al sistema por ejemplo al abrir o guardar archivos, a veces reitero, solo a veces.

Puede instalar gimp con el siguiente comando sin usar flatpack.

 

sudo apt install gimp

 

Saludos.

Respuesta
Comparte: