OBS ES TANCA A L'HORA D'INTENTAR TRANSMETRE

avatar
(@Gtabimael)
nou Membre Registrat

Hola, tinc un ordinador dell amb una targeta gràfica GeForce 920M de nvidia. Sóc nou en Linux, jo faig transmissions en facebook i faig servir OBS però DeepinOS em aquesta donant problemes a l'hora de transmetre, quan faig clic al botó per transmetre, es tanca. Quan intentava gravar em passava alguna cosa similar però en configuracions avançades en tipus de sortida selecciona FFmpeg i ja puc gravar sense problemes.

Adjunt logs:

14: 31: 47.443: CPU Name: Intel (R) Core (TM) i3-5005U CPU @ 2.00GHz
14: 31: 47.443: CPU Speed: 1348.627MHz
14: 31: 47.443: Physical Cores: 2, Logical Cores: 4
14: 31: 47.443: Physical Memory: 3854MB Total, 495MB Free
14: 31: 47.443: Kernel Version: Linux 4.15.0-29deepin-generic
14: 31: 47.443: Distribution: "Deepin" "15.9"
14: 31: 47.445: Portable mode: false
14: 31: 47.511: OBS 0.0.1 (linux)
14: 31: 47.511: ---------------------------------
14: 31: 47.535: ---------------------------------
14: 31: 47.535: àudio settings reset:
14: 31: 47.535: samples per sec: 44100
14: 31: 47.535: speakers: 2
14: 31: 47.550: ---------------------------------
14: 31: 47.550: Initializing OpenGL ...
14: 31: 47.585: OpenGL version: 4.5 (Core Profile) Taula 18.0.4
14: 31: 47.661: ---------------------------------
14: 31: 47.661: vídeo settings reset:
14: 31: 47.661: base resolution: 1366x768
14: 31: 47.661: output resolution: 1092x614
14: 31: 47.661: downscale filter: Bicubic
14:31:47.661: fps: 30/1
14: 31: 47.661: format: NV12
14: 31: 47.675: Àudio monitoring device:
14: 31: 47.675: name: Per defecte
14: 31: 47.675: id: default
14: 31: 47.675: ---------------------------------
14: 31: 47.694: No Blackmagic support
14: 31: 47.754: os_dlopen (libnvidia-encode.so.1-> libnvidia-encode.so.1): libnvidia-encode.so.1: no es pot obrir el fitxer de l'objecte compartit: No existeix el fitxer o el directori
14: 31: 47.754:
14: 31: 47.773: VLC found, VLC vídeo source enabled
14: 31: 47.773: ---------------------------------
14: 31: 47.773: Loaded Modules:
14: 31: 47.773: vlc-video.so
14: 31: 47.773: text-freetype2.so
14: 31: 47.773: rtmp-services.so
14: 31: 47.773: obs-x264.so
14: 31: 47.773: obs-transitions.so
14: 31: 47.773: obs-outputs.so
14: 31: 47.773: obs-filters.so
14: 31: 47.773: obs-ffmpeg.so
14:31:47.773: linux-v4l2.so
14: 31: 47.773: linux-pulseaudio.so
14: 31: 47.773: linux-jack.so
14: 31: 47.773: linux-decklink.so
14: 31: 47.773: linux-capture.so
14: 31: 47.773: linux-alsa.so
14: 31: 47.773: image-source.so
14: 31: 47.773: frontend-tools.so
14: 31: 47.773: ---------------------------------
14: 31: 47.773: ==== Startup completi ====================================== =========
14: 31: 47.774: Service '' not found
14: 31: 47.787: All scene data cleared
14: 31: 47.789: -------------------------------------------- ----
14: 31: 47.800: premi-input: Server name: 'pulseaudio 10.0'
14: 31: 47.800: premi-input: Àudio format: s16le, 44100 Hz, 2 channels
14: 31: 47.800: premi-input: Started recording from 'alsa_output.pci-0000_00_1b.0.analog-stereo.monitor'
14: 31: 47.802: premi-input: Server name: 'pulseaudio 10.0'
14: 31: 47.802: premi-input: Àudio format: s16le, 44100 Hz, 2 channels
14: 31: 47.802: premi-input: Started recording from 'alsa_input.pci-0000_00_1b.0.analog-stereo'
14: 31: 47.804: xshm-input: Geometry 1366x768 @ 0,0
14: 31: 47.812: Switched to scene 'Escena'
14: 31: 47.813: -------------------------------------------- ----
14: 31: 47.813: Loaded scenes:
14: 31: 47.813: - scene 'Escena':
14: 31: 47.813: - source: 'Captura (XSHM)' (xshm_input)
14: 31: 47.813: -------------------------------------------- ----
14: 31: 48.309: adding 46 milliseconds of àudio buffering, total àudio buffering is now 46 milliseconds

Citar
Publicat el: 12 febrer, 2019 6: 49 pm
Eli
(@eli)
Membre Presentador

Quina versió de OBS utilitzeu @gtabimael? Tracta la de la botiga de no ser aquesta la que fas servir, o si ho és llavors poguessis intentar amb la versió .deb del lloc oficial, també poguessis investigar si està disponible en un altre tipus d'embalatge com .flatpak .snap etc també pots tractar instal·lant una versió més vella de l'app a veure si et funciona bé. De vegades l'últim no és sempre el millor.

Eli @ https://www.iconnetworks.net
M51AD-US001S Desktop System Designed by Asus®
Intel ® Core ™ i7-4770 Processor at 3.4 GHz
Samsung UD590 Sèries, 28 '4K LED Monitor
EVGA GeForce GTX 960, 2GB GDDR5 GPU
8-Channel (7.1) HD Audio by Realtek
Samsung 850Pro 512GB SSD
16GB DDR3 SDRAM
Deepin 15.8 [x64]

respondreCitar
Publicat el: 14 febrer, 2019 7: 02 pm
Claudio Pier
(@Claudiopier)
nou Membre Registrat

hola ami em passa el mateix que pot ser?

respondreCitar
Publicat el: 16 febrer, 2019 10: 26 am
Federico Raika
(@ Federico-Raika)
nou Membre Registrat

crec que ha de ser problema de còdec que falta ara OBS necessita ffmpeg.

sudo apt install ffmpeg 
respondreCitar
Publicat el: 11 març, 2019 5: 49 am
Comparteix:

treballant

Si us plau Iniciar Sessió o Registre